PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Suse 8.1-Install- + FritzCard!DSL-Probleme



Stub
28.04.2003, 02:40
Blutiger Linux-Anfänger braucht hilfe bei FritzCard!DSL

2 Probleme

1. Ich krieg das nicht gebacken, die FritzCard!DSL (ISDN+DSL)
unter Linux 8.1 in Betrieb zu nehmen

2. Der PC bootet(e) nicht mehr von der Platte


DAS ERSTE PROBLEM: Die FritzCard

Ausgangsbasis + was bisher geschah:
================================================== ===========================

Ich hab auf nem PC mit Win98se zusätzlich Suse 8.1 installiert:
Komplette 8.1er Version aus dem Netz auf meinen PC runtergeladen,
eine Install-CD von boot.iso erzeugt + Suse installiert
= Suse wurde installiert + lief (erstmal).

Die eingebaute FritzCard!DSL kann zwar ISDN + DSL, ich nutze aber nur DSL
und möchte nur DSL nutzen.


Infos zur Installation/Hardware:
================================================== =
P III, 500 MHz, 128 MB RAM,
Grafikkarte: Matrox Millenium
3 Festplatten, 1 CD-ROM

Auf der 1. Platte liegt
- Win98se (vorn mit ca. 2 GB)
- Suse (dahinter mit ca. 5,5 GB)
- LinuxSwap-Partiton (ca. 500 MB)

Auf Platte 2+3 sind nur Daten


Was ich wegen der FritzCard!DSL tat
===========================================

Treiber; fcdsl-suse8.1-03.10.05 von der AVM-Homepage runtergeladen, die Doku
gelesen + danach installiert = DSL geht nicht!

Dann Infos im internet nach Infos gesucht... / was gefunden ...
/die Anweisungen befolgt (Datei: "install" editiert, dort die Zeile
"...=2.4.19-4GB" abgeändert; dann "make", dann "make install" und "./install")
aber es funktioniert immer noch nicht.

Nach "./install" krieg ich die fehlermeldung:
> ./install.card: No such file or directory


Hier der Auszug aus der Datei: install.card
------------------------------------------------------
56: fi
57: if test -x $SBINDIR/drdsl; then
58: rm -vf $SBINDIR/drdsl >> $LOGFILE
59: fi
------------------------------------------------------

Offensichtlich existiert bei mir kein "SBINDIR/drdsl"

Dann hab ich weitergesucht im Internet, fand eine Info das die Treiber für
Fritz schon in Suse ab 8.1 drin sein soll(t)en. Bei mir wurde nach der Install
von Suse auch die FritzCard erkannt, aber sonst geht nix damit.

Das "./install" sollte mit ner erfolgreichen Meldung abschließen, tuts
bei mir aber nicht.
Ich weiß nicht weiter.... Hülfä!

Was muß ich tun um diese FritzCard!DSL zum Laufen zu bringen?



DAS ZWEITE PROBLEM: Das Booten

Als ich die ersten Einstellungen nach den Anweisungen gemacht hatte,
die bei den Fritz-treibern von der AVM-HP dabei waren, "rödelte" Suse
beim Abarbeiten/Speichern der Einstellungen.
Bei der Position "ISDN" blieb die Anzeige dann stehen. D.h.
die Festplatte hörte sich an, als wenn da ordentlich gearbeitet wird.
Anfangs konnte der Mauszeiger auch noch bewegt werden.
Ich dachte das wird ne Weile dauern, Suse scheint auf der/den Platte(n)
was zu suchen. Aber als nach 45 Minuten immer noch nix weiter passierte
und ich merkte das alles eingefroren war, mußte ich
einen Kaltstart machen, um Suse abzuwürgen.

Nach dem Kaltstart (das war der erste Reset nach der Installation)
fand das BIOS keine aktive Partiton (oder kein OS auf aktiver Partition)
zum Booten mehr.

Booten konnte ich ab da nur noch mit der Suse-Boot-CD. hab dann versucht in Linux
den Loader neu zu schreiben... neu booten ohne CD = kein Erfolg.
Ich mußte immer mit Linux-Install-CD booten.

Dann hab ich beim Booten das alte Windows zum starten ausgewählt.
Ich hatte XFDISK als Bootmanager zuvor eingerichtet gehabt (weil
ich vorher schon Red Hat, Mandrake + Suse 8.0 erfolglos ausprobiert
hatte. Bei allen 3 Linux-Versionen konnte garnicht erst die FritzCard
erkannt werden). (Suse 8.1 erkennt wenigstens die FritzCard)

Ich hab mit XFdisk (unter Win gebootet) dann die Suse
8.1-Partiton mit ins Bootmenü aufgenommen + den MBR
neu schreiben lassen.

Jetzt krieg ich wieder den XFDisk-Bootmanager beim booten, habe
Win98se + Suse8.1 in der Auswahl und kann darüber Windows starten
aber NICHT MEHR Suse!
Wenn ich im Bootmanager Suse wähle passiert nix. Der Screen flackert
ne 1/4-Sekunde und dann is die Bootmanager-Auswahl immer noch da.

Was muß ich machen um Win98se + Suse 8.1 mittels Bootmanager
wahlweise von der Festplatte booten zu können?

Bin für jeden Hinweis dankbar.

Gruß Stub

devilz
28.04.2003, 10:43
Auch wenns nun blöde klingt, Neuinstall mit der 8.2 probieren !!!

Die 8.1 ist ziemlich "alt" und hate soweit mir bekannt ist etliche Probleme auch mit der FrtzCard DSL !

Du solltest dir von einem Freund die SuSE 8.2 ausleihen und die mal installieren !

Dein Problem mit dem Bootloader kann ich leider nicht nachvollziehen :(
(Sollte sich aber mit ner Neuinstallation der 8.2 erübrigen !)

Stub
28.04.2003, 12:04
Dankeschön für Deine Antwort.

Zum BootManager:
weiß uach nicht wieso es nicht ging. ich hatte es mehrmals gemacht, ohne Erfolg.
Nachdem ich das im Forum dann geschrieben hab, hab ich den Vorgang (wieder mit Boot-Cd laden, nochmal probieren den loader zu speichern) dann doch mal geklappt.

Es scheint ein blöder Fehler zu sein, hab auch an anderen Stellen viel über Bootloader Anomalien gelesen und auch über Fritz mit Suse.
Jetzt wo ich Suse intensiever versucht mit Fritz in die gänge zu bringen, erfuhr ich auch das Suse zu schnell mit neuen Versionen rauskommt. Ich las mehrfach das es in den ersten 1-2 Versionen eines Versionssprung immer viele Macken hat.

Aber bevor ich diesen Krampf mir auch in Zukunft antue, wechsel ich lieber für in etwa das gleiche Geld die FritzCard gegen eine Lösung aus mit der jedes Linux zurechtkommt und nutz dann doch lieber Red Hat.

Hab auch einige User-Einträge in Foren gelesen, wo die leute FritzCard haben, mit 8.0 / 8.1 das Ding zum laufen brachten, auf 8.2 updateten und dann ging das Ding wieder nicht.

devilz
28.04.2003, 13:18
Also ne frische 8.2 Install sollte mit der Fritz DLS zurecht kommen ....

Da ich selber Gentoo User bin und SuSE 8.2 "nur" auf dem PC meiner Frau laufen lasse, kann ich dir leider nicht mit dem DSL Prob helfen.

Ich geh selber über einen (Hardware-)Router ins internet, deswegen hab ich mit sowas keine Probleme :)