PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : fat dateinamen



g_eXx
10.04.2003, 14:54
Hi,
also ich hab ein problem mit den gemounteten fat32 partitionen.
Die Dateinamen verändern sich unter Gentoo z. B. von the-kernel in the-ke~1.
Hat wohl was mit der Dateinamenlänge von DOS zu tun aber kann man das Problem irgendwie umgehen? ?(

THX.

devilz
10.04.2003, 14:59
Original geschrieben von g_eXx
Hi,
also ich hab ein problem mit den gemounteten fat32 partitionen.
Die Dateinamen verändern sich unter Gentoo z. B. von the-kernel in the-ke~1.
Hat wohl was mit der Dateinamenlänge von DOS zu tun aber kann man das Problem irgendwie umgehen? ?(

THX.

Du hast nen Kernel Option vergessen :)

<*> VFAT (Windows-95) fs support
This option provides support for normal Windows file systems with long filenames ...

g_eXx
10.04.2003, 15:02
obwohl ich mir sicher bin dass ich das im kernel drin hab muss ich sowiso nen neuen kernel backen.
Ich werd das heute abend machen und dann bescheit geben ob es funktioniert hat. 8)

g_eXx
10.04.2003, 16:02
Ich hab jetzt einen neuen kernel gebaut. Allerdings war VFAT schon aktiviert.
Der Eintrag in der fstab: /dev/hda2 /mnt/winxp-c msdos noauto,noatime 1 2
Es funktioniert also immer noch nicht. :(

devilz
10.04.2003, 17:43
Original geschrieben von g_eXx
Ich hab jetzt einen neuen kernel gebaut. Allerdings war VFAT schon aktiviert.
Der Eintrag in der fstab: /dev/hda2 /mnt/winxp-c msdos noauto,noatime 1 2
Es funktioniert also immer noch nicht. :(


ÄHEM !

du mountest als msdos und willst lange dateinamen ?

soll ich noch was dazu sagen ?

g_eXx
10.04.2003, 18:24
also ich dachte der parameter heist msdos aber jetzt wo dus sagst. ich idiot hatte in der
"man fs" nur das mit msdos gelesen. Sorry meine doofheit. :rolleyes: