PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : mythtv und mysql



Atum
24.10.2006, 18:37
Hallo,

ich habe wohl eine kleine Dummheit bei der Konfiguration von mythtv begangen. Während der Installation soll man für eine Datenbank ein Passwort vergeben oder es eben leer lassen. Ich habe keinen Eintrag gemacht.

Beim Starten von mythtv muss man dann noch einige Dinge eintragen. Unter anderem war ein Passwort für die Datenbank von Mythtv vergeben und das klang ungefähr so
w8qwlm11283

Also ich weiß nicht, was mich geritten hat, aber ich habe es geändert und nun kommt immer eine Fehlermeldung beim Starten von mythtv, daß keine Verbindung zur Datenbank hergestellt werden kann.
Da ich mich mit sowas überhaupt nicht auskenne, brauche ich eure Hilfe. Wie finde ich das ursprüngliche PW wieder heraus oder wie ändere ich das aktuelle?

Die Datenbank heißt übrigens mythconverg

ps: in der man mysql habe ich es nicht gefunden und im Board auch nicht (vielleicht falsch gesucht?)

Edit:

ich habe mal das hier versucht:
># rcmysql stop
># mysqld --user=mysql --skip-networking --skip-grant-tables --datadir=/var/lib/mysql &
># su - mysql -c "mysqladmin --user root password 'NEUESPASSWORT'"


aber es kommt folgender Fehler:
bla@bla:~$ su - mysql -c "mysqladmin --user root password 'blabla'"
Password:
su: Authentication failure
Entschuldigung.
bla@bla:~$ sudo - mysql -c "mysqladmin --user root password 'blabla' "
sudo: '-' requires an argument
usage: sudo -K | -L | -V | -h | -k | -l | -v
usage: sudo [-HPSb] [-p prompt] [-u username|#uid]
{ -e file [...] | -i | -s | <command> }


Warum su nicht funktioniert, weiß ich nicht. Ubuntu soll ja angeblich kein root haben und das gleiche PW funktioniert bei sudo.

rdg
24.10.2006, 18:49
Hi wenn du Mysqladmin hast dann diesen starten die datenbank herraussuchen und dort das passwort eingeben

rdg
24.10.2006, 18:53
Sorry heist phpmyadmin nicht mysqladmin.

In der Konsole kannst du auch
mysql
use mythconverg;
show tables from mythconverg;
update mythconverg set passwort (oder wie die Spalte haißt) = dein neues Passwort;

Atum
24.10.2006, 19:05
bla@bla:~$ mysql
ERROR 1045 (28000): Access denied for user 'iskender'@'localhost' (using password: NO)


Das klappt nicht. Und mit dem phpmyadmin komme ich nicht voran, weil ich den nicht starten kann. ( Also mit http://127.0.0.1/phpmyadmin kommt nur die Fehlermeldung Seiten-Ladefehler)

rdg
24.10.2006, 19:31
Na ja, dann musst du irgendwie dein passort zu mysql herraufinden, oder mysql nochmal neu installieren.
Wenn du mysql neu installierst pass auf, das du deine Datenbanken, befinden sich in var/lib/mysql sicherst und nach neuinstallation wieder dorthin installierst.
Dann müssten die Befehle die ich dir vorhin für die Kopnsole geschrieben haben funktionieren. Wahrscheinlich wird aber das Passwort ein string sein weshalb ="das passwort, welches du bei myth angegeben hast".

Atum
24.10.2006, 19:44
Gut, dann werde ich mich also für den Neuinstall entscheiden. Was ich noch gerne wissen würde ist, ob Linux irgendetwas in diese Datenbanken schreibt und ob ich mit dem Neuinstallieren von mysql etwas am System beschädigen könnte?
Die Tabellen, von denen du sprachst sind aber nicht zufällig auch im Verzeichnis /var/lib/mysql/mysql ? Muß ich aus diesem Verzeichnis auch noch ewtas sichern?

Danke schonmal bis hierhin.

rdg
24.10.2006, 19:56
Also, entweder du findest in myth eine Möglichkeit das Passwort zu löschen, wäre die einfachste, doch ich kenne mich mit dem Programm leider nicht aus, so das ich dir dabei nicht weiterhelfen kann.

Oder du findest eine Möglichkeit dein mysql passwort zu ändern. Ist mir auch schon häufig passiert weiß im moment nichtmehr wie das ging, wenn du mir ein wenig Zeit gibst finde ich es wieder heraus.

Oder du installierst mysql nocheinmal. Hab ich später immer so gemacht weil ich keine lust mehr hatte immer wieder runzufrigeln.

in /var/lib/mysql stehen die Datenbanken als Verzeichnisse aufgelistet. eines davon ist mysql, welches deine Einstellungen zu mysql speichert.

Atum
24.10.2006, 20:00
Nun, ich habe bisher mysql nicht wissentlich benutzt. Wenn also keine Systemprozesse von dieser Datenbank abhängen, dann deinstalliere ich die einfach und installiere es neu. Mal schauen, ob das klappt. Denn wie gesagt, die Passwörter finde ich bestimmt nicht mehr ;)

rdg
24.10.2006, 20:04
Generell gibt es dabei keine Probleme.
Sag mir aber bitte einmal welche Verzeichnisse du in /var/lib mysql findest.

P.S.: Wenn mysql neu installiert ist wird myth noch nicht laufen aber wir haben zugriff auf die mysql konsole wo wir dann dein passwort eintragen können. Und womit es dann eigentlich klappen müsste.

Atum
24.10.2006, 20:12
Hmm, ich war wohl zu schnell ;) Ich habe eben alles, was ich mit mysql und mythtv gefunden habe deinstalliert und neu installiert. Bei einigen Dateien wollte Synaptic gleich Amarok mit deinstallieren, von diesen Dateien habe ich die Finger gelassen.

Derzeit sind zwei Verzeichnisse in /var/lib/mysql nämlich mysql und mythconverg.
Mehr war aber vorher auch nicht drin.

rdg
24.10.2006, 20:14
So, dann installiere mysql noch einmal und kopiere mythconverg nochmal dorthin.

Atum
24.10.2006, 20:22
Mhh. Das hat nicht geklappt. Obwohl ich sowohl mythtv (meiner Meinung nach) und auch mysql incl. des Verzeichnisses /var/lib/mysql deinstalliert habe, hat mythtv die alten Settings behalten.

Die Konfigurationsseite für die Datenbank unter Mythtv sieht so aus:
Rechnername: localhost
Datenbank: mythconverg
Benutzername: mythtv
Passwort: (hatte ich leider editiert und das steht so noch immer da, trotz Neuinstall)
DB-Typ: mysql

Ginge es nicht einfach, wenn ich eine neue Datenbank erstelle und Mythtv auf die neue DB verweise? Oder ich muß halt doch irgendwie das PW für diese DB erhalten.

rdg
24.10.2006, 20:38
Das habe ich dir doch gesagt! Noch funktioniert myth nicht sondern wir haben zugriff auf die konsole. Hast du mysql neu installiert?

Atum
24.10.2006, 20:38
mysql ist neu installiert.

Also, was ich bisher rausgefunden habe:

mit sh-3.1$ mysql -u root mythconverg kann ich mich bei mysql einloggen.
mit SET PASSWORD FOR 'bob'@'%.loc.gov' = PASSWORD('newpass');
kann ich ein PW für einen User setzen. Allerdings muß ich den User angeben, wie er in mysql.user. table entry eingetragen ist. Und wie ich da reinschauen kann, habe ich in man mysql nicht finden können.

Das scheint irgendwie die Lösung des Problems zu sein, denn als root kann ich mich in die Datenbank einloggen, als user mythtv leider nicht.

rdg
24.10.2006, 20:43
quit
mysql
use mysql;
select * from mysql;

Atum
24.10.2006, 20:51
Das Problem ist, daß ich mich als user=mythtv gar nicht in mysql einloggen kann. Also wenn ich aus der Konsole heraus mysql eingebe, kommt als Antwort:
sh-3.1$ mysql
ERROR 1045 (28000): Access denied for user 'mythtv'@'localhost' (using password: NO)


Wenn ich mich einlogge als root, passiert folgendes:

sh-3.1$ mysql -u root mythconverg
Reading table information for completion of table and column names
You can turn off this feature to get a quicker startup with -A

Welcome to the MySQL monitor. Commands end with ; or \g.
Your MySQL connection id is 102 to server version: 5.0.22-Debian_0ubuntu6.06.2-log

Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

mysql> use mysql;
Reading table information for completion of table and column names
You can turn off this feature to get a quicker startup with -A

Database changed
mysql> select mythtv from mysql;
ERROR 1146 (42S02): Table 'mythconverg.mysql' doesn't exist


ich nehme an, der * war der usereintrag?

Atum
24.10.2006, 21:02
Sorry, daß ich mich etwas ungeschickt anstelle. Falls du noch nicht völlig die Lust verloren hast und gerade einen irc-Client zur Hand hast, kannst du mich ja im Quakenet im Channel #mysql-help besuchen kommen.

Server ist splatterworld.de.quakenet.org:6667

rdg
24.10.2006, 21:04
Nein nein überhaupt nicht, gib mir nur kurz Zeit muss nuss noch kurz was erledigen, dann bin ich gleich wieder bei deinem Probleem!

Atum
24.10.2006, 21:07
Klasse, vielen Dank!

rdg
24.10.2006, 21:26
Also, ich glaube du hast nicht die nötigen Erfahrungen mit mysql bzw Datenbanken um den nutzer anzulegen und zu bearbeiten. Denn wir wissen ja auch nicht welche Spalten und Werte er benötigt. Deshalb würde ich dir empfehlen welche mythtv nochmal zu installieren. Leider fällt mir auch keine bessere Idee ein. Ich weiß scheiße alles nochmal installieren und konfigurieren. Aber ich glaub es führt kein weg drum herrum.

Gruß rdg

theton
24.10.2006, 21:26
Hab den Thread nur mal überflogen, aber man muss MySQL nicht komplett neu installieren, nur weil man das DB-Passwort vergessen hat. Einfach die Datenbank mysql löschen und mit dem mysql_install_db-Skript, das in allen MySQL-Sources enthalten ist (man sollte natürlich die zur installierten Version nehmen), neu anlegen. Danach mit mysqladmin ein neues Passwort vergeben

mysqladmin -u root password 'meinneuespasswort'
und gut ist.

Atum
24.10.2006, 21:36
Gut, das Problem ist meiner Meinung nach eingegrenzt auf Folgendes:
a) ich habe Mythtv neu installiert, aber es behält dennoch die Konfiguration von vorher bei (obwohl ich es "total" entfernt habe)
b) der User Mythtv ist in der myaql Datenbank nicht angelegt, daher kann er auch nicht auf die Datenbank zugreifen. Dieses Problem wird offensichtlich auch nicht durch ein Neuinstall von mysql behoben, da dadurch ja nicht auf einmal neue User angelegt werden.
c) da Mythtv diesen User wohl trotz neuinstall nicht in der Datenbank anlegen kann, muß ich das von Hand machen.

Dieser User muß ja nur auf die eine Datenbank mit dem Namen mythconverg zugreifen. Diese Datenbank besteht auch schon (zumindest ist sie im mysql-Verzeichnis als Ordner vorhanden).

Nun, es muß doch mit ein paar einfachen Kommandos möglich sein, einen User anzulegen? Wäre schade, wenn ich den halben Tag für nichts verbraucht hätte.

@theton: damit hätte ich ein neues root-passwort erstellt. Ich brauche aber einen User und PW für den user mythtv.

theton
24.10.2006, 21:40
Für mythtv hat normalerweise jeder User in seinem Home eine eigene Konfiguration. Wenn du die löscht, sollte beim nächsten Programmstart eine neue angelegt werden.
Ansonsten User anlegen in MySQL:


mysql -u root -p
mysql> GRANT ALL PRIVILEGES on datenbank-von-mythtv.* to 'mythtv-user'@'%' IDENTIFIED BY 'passwort-fuer-mythtv-user';
mysql> FLUSH PRIVILEGES;

rdg
24.10.2006, 22:01
Also, ich glaube du hast nicht die nötigen Erfahrungen mit mysql bzw Datenbanken um den nutzer anzulegen und zu bearbeiten. Denn wir wissen ja auch nicht welche Spalten und Werte er benötigt. Deshalb würde ich dir empfehlen welche mythtv nochmal zu installieren. Leider fällt mir auch keine bessere Idee ein. Ich weiß scheiße alles nochmal installieren und konfigurieren. Aber ich glaub es führt kein weg drum herrum.

Gruß rdg

Also das war wirklich schwachsinn von mir ein Nutzer benötigt natürlich keine Spalten und Werte sondern nur tablen!