PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Wurzel in LaTeX mit \sqrt[x]{y}!?



aroetem
31.08.2006, 14:44
Hi,
ich habe gestern angefangen, LaTeX zu benutzen. Ich bin jetzt auf das Problem gestoßen, dass ich keine Wurzeln anzeigen kann, die einen höheren Grad als 2 haben.
Laut allen Tutorials, Referenzen und etc ist die Syntax

\sqrt[Grad]{Radikand}

aber wenn ich das eintippe, dann zeigt er nur eine normale Wurzel an, also ohne den Grad zu schreiben, egal ob ich mit \begin{equation}, mit $ oder mit \[ abtrenne.
Weiß jemand was ich falsch mache?

schwedenmann
31.08.2006, 15:00
Hallo

Ich glaube so wird es gemacht.

http://de.wikibooks.org/wiki/LaTex_f%C3%BCr_Mathematiker#Wurzeln


Mfg
schwdenmann

aroetem
31.08.2006, 20:37
Hmm, aber genauso tipp ich es ja ein. Weder $\sqrt[n]{x}$, noch \[\sqrt[n]{x}\] noch die anderen Formen gehen.. :-(

root1992
31.08.2006, 20:45
Bringt er dir einen Fehler???
Für Mattheformeln brauchst du sicher ein extra Paket.

Xanti
31.08.2006, 20:55
Das geht ohne Extra-Paket. Folgendes läuft bei mir fehlerfrei:



\documentclass{article}
\begin{document}
$\sqrt[n]{x}$
\end{document}


Gruss, Xanti

aroetem
31.08.2006, 21:40
Ne, er bringt keinen Fehler.
@Xanti: Wenn ich deinen Code eins zu eins kopiere, dann zeigt er einfach Wurzel x an. Ohne n.

rikola
31.08.2006, 21:58
Welche TeX Version hast Du denn, und welche Distribution? Schick doch mal die log Datei her.

aroetem
31.08.2006, 22:15
Die Version ist Version 3.141592. Distri ist Ubuntu 6.06.1

Log:


**test.tex
(./test.tex
LaTeX2e <2003/12/01>
Babel <v3.8d> and hyphenation patterns for american, french, german, ngerman, b
ahasa, basque, bulgarian, catalan, croatian, czech, danish, dutch, esperanto, e
stonian, finnish, greek, icelandic, irish, italian, latin, magyar, norsk, polis
h, portuges, romanian, russian, serbian, slovak, slovene, spanish, swedish, tur
kish, ukrainian, nohyphenation, loaded.
(/usr/share/texmf-tetex/tex/latex/base/article.cls
Document Class: article 2004/02/16 v1.4f Standard LaTeX document class
(/usr/share/texmf-tetex/tex/latex/base/size10.clo
File: size10.clo 2004/02/16 v1.4f Standard LaTeX file (size option)
)
\c@part=\count79
\c@section=\count80
\c@subsection=\count81
\c@subsubsection=\count82
\c@paragraph=\count83
\c@subparagraph=\count84
\c@figure=\count85
\c@table=\count86
\abovecaptionskip=\skip41
\belowcaptionskip=\skip42
\bibindent=\dimen102
)
No file test.aux.
\openout1 = `test.aux'.

LaTeX Font Info: Checking defaults for OML/cmm/m/it on input line 2.
LaTeX Font Info: ... okay on input line 2.
LaTeX Font Info: Checking defaults for T1/cmr/m/n on input line 2.
LaTeX Font Info: ... okay on input line 2.
LaTeX Font Info: Checking defaults for OT1/cmr/m/n on input line 2.
LaTeX Font Info: ... okay on input line 2.
LaTeX Font Info: Checking defaults for OMS/cmsy/m/n on input line 2.
LaTeX Font Info: ... okay on input line 2.
LaTeX Font Info: Checking defaults for OMX/cmex/m/n on input line 2.
LaTeX Font Info: ... okay on input line 2.
LaTeX Font Info: Checking defaults for U/cmr/m/n on input line 2.
LaTeX Font Info: ... okay on input line 2.
LaTeX Font Info: External font `cmex10' loaded for size
(Font) <7> on input line 3.
LaTeX Font Info: External font `cmex10' loaded for size
(Font) <5> on input line 3.
[1

] (./test.aux) )
Here is how much of TeX's memory you used:
200 strings out of 94501
2088 string characters out of 1175811
48348 words of memory out of 1000000
3457 multiletter control sequences out of 10000+50000
3640 words of font info for 14 fonts, out of 500000 for 2000
580 hyphenation exceptions out of 8191
23i,5n,17p,128b,107s stack positions out of 1500i,500n,5000p,200000b,5000s

Output written on test.dvi (1 page, 396 bytes).


Hoffe, dass hilft.

rikola
01.09.2006, 00:01
Das sieht bei mir nicht sehr anders aus, nur dass die ersten paar Zeilen


This is pdfeTeX, Version 3.141592-1.21a-2.2 (Web2C 7.5.4) (format=latex 2006.8.2
2) 31 AUG 2006 23:56
entering extended mode
**test.tex
(./test.tex
LaTeX2e <2003/12/01>

lauten. Mit welchem Befehl uebersetzt Du test.tex denn?

aroetem
01.09.2006, 14:54
Ich tippe einfach



latex test


Erschien mir am logischsten und hat bis jetzt auch immer funktioniert.

root1992
01.09.2006, 15:58
Läuft er ohne Fehler durch???
Versuchs mal mit pdflatex, der macht dir gleich eine PDF.

Die Formel vom Xanti funktioniert bei mir auch ohne Probleme und richtig, mit latex, pdflatex.

Poste mal den "Kopf" der Datei, ist vielleicht hilfreich.

aroetem
01.09.2006, 16:59
Mit pdflatex geht es(Juchuu.. DVI's brauch ich sowieso nur selten) Aber mich wundert immer noch warum es mit normalem latex nicht geht. Wie schon gesagt gibt es keine Fehlermeldung. Als Kopf der Datei hab ich meinen eigenen(Mit Autorangabe etc.) und auch mal den von Xanti verwendet, also sozusagen gar nichts reingeschrieben.

Xanti
01.09.2006, 17:08
Ich vermute, dass es nicht an LaTeX liegt, sondern an Deinem dvi-Viewer.

Gruss, Xanti

root1992
01.09.2006, 17:33
Der von Kile (glaub Kdvi) kann es.