PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Monodevelop startet nicht



hazelnoot
22.07.2006, 15:02
Hi!

ich moechte mich ein wenig in mono einarbeiten aber die IDE monodevelop startet nicht

waenn ich mono starte kommt der splashscreen und bei der meldung "Loadin MonoDevelop Workbench ..." im splashscreen haengt sich die IDE auf...

die fehlerausgabe in der konsole sieht folgendermasssen aus:


node `monohb' is not defined on the documentation map
2006-07-22 16:00:23,821 [1076161440] INFO MonoDevelop.Services.ILoggingService [(null)] - WARNING Could not find stock Icons.16x16.FindPrevIcon
2006-07-22 16:00:23,843 [1076161440] INFO MonoDevelop.Services.ILoggingService [(null)] - WARNING Could not find stock gtk-stop
2006-07-22 16:00:23,901 [1076161440] INFO MonoDevelop.Services.ILoggingService [(null)] - Creating DefaultWorkbench
Loading error, please reinstall :
System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.ApplicationException: Couldn't create a remote process.
in <0x000bf> MonoDevelop.Services.ProcessHostController:CreateI nstance (System.String assemblyPath, System.String typeName)
in (wrapper remoting-invoke-with-check) MonoDevelop.Services.ProcessHostController:CreateI nstance (string,string)
in <0x00028> MonoDevelop.Services.ProcessService:CreateExternal ProcessObject (System.String assemblyPath, System.String typeName, Boolean shared)
in <0x0004f> BooBinding.Gui.BooShellModel:GetRemoteShellObject ()
in <0x00022> BooBinding.Gui.BooShellModel:.ctor (System.String program_path, System.String socket_path)
in <0x00093> BooBinding.Pads.BooShellPadContent:CreateBooShell ()
in <0x00022> BooBinding.Pads.BooShellPadContent:.ctor ()
in <0x00000> <unknown method>
in (wrapper managed-to-native) System.Reflection.MonoCMethod:InternalInvoke (object,object[])
in <0x0006f> System.Reflection.MonoCMethod:Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture)--- End of inner exception stack trace ---

in <0x00104> System.Reflection.MonoCMethod:Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture)
in <0x00019> System.Reflection.MonoCMethod:Invoke (BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture)
in <0x00032> System.Reflection.ConstructorInfo:Invoke (System.Object[] parameters)
in <0x000e2> System.Activator:CreateInstance (System.Type type, Boolean nonPublic)
in <0x0000c> System.Activator:CreateInstance (System.Type type)
in <0x0003a> System.Reflection.Assembly:CreateInstance (System.String typeName, Boolean ignoreCase)
in <0x00012> System.Reflection.Assembly:CreateInstance (System.String typeName)
in <0x000b5> MonoDevelop.Core.AddIns.AddIn:CreateObject (System.String className)
in <0x00087> MonoDevelop.Core.AddIns.Codons.PadCodon:CreatePad ()
in <0x00014> MonoDevelop.Core.AddIns.Codons.PadCodon:BuildItem (System.Object owner, System.Collections.ArrayList subItems, MonoDevelop.Core.AddIns.Conditions.ConditionCollec tion conditions)
in <0x0014f> MonoDevelop.Core.AddIns.DefaultAddInTreeNode:Build ChildItems (System.Object caller)
in <0x00064> MonoDevelop.Gui.DefaultWorkbench:UpdateViews (System.Object sender, System.EventArgs e)
in <0x0003c> MonoDevelop.Commands.InitializeWorkbenchCommand:Ru n ()
in <0x007ac> MonoDevelop.SharpDevelopMain:Main (System.String[] args)


was hat es da?

mfg hazelnoot

theton
22.07.2006, 16:26
Loading error, please reinstall :
Steht doch da was du machen musst.

hazelnoot
22.07.2006, 16:48
hab mir von der mono homepage das ganze monozeugs nochmal runtergeladen und installiert und nun kommt beim start von monodevelop folgendes:



node `monohb' is not defined on the documentation map
2006-07-22 17:47:12,002 [1076161440] INFO MonoDevelop.Services.ILoggingService [(null)] - WARNING Could not find stock Icons.16x16.FindPrevIcon
2006-07-22 17:47:12,021 [1076161440] INFO MonoDevelop.Services.ILoggingService [(null)] - WARNING Could not find stock gtk-stop
2006-07-22 17:47:12,043 [1076161440] INFO MonoDevelop.Services.ILoggingService [(null)] - Creating DefaultWorkbench

================================================== ===============
Got a SIGSEGV while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries
used by your application.
================================================== ===============

Stacktrace:

in (wrapper managed-to-native) Gnome.Icon:gnome_icon_lookup_sync (intptr,intptr,intptr,intptr,int,int&) <0x4>
in (wrapper managed-to-native) Gnome.Icon:gnome_icon_lookup_sync (intptr,intptr,intptr,intptr,int,int&) <0xffffffaa>
in Gnome.Icon:LookupSync (Gtk.IconTheme,Gnome.ThumbnailFactory,string,strin g,Gnome.IconLookupFlags,Gnome.IconLookupResultFlag s&) <0x92>
in MonoDevelop.Gui.Utils.FileIconLoader:GetPixbufForF ile (string,int,int) <0x6a>in MonoDevelop.Gui.Widgets.FileBrowser:Populate () <0x1e8>
in MonoDevelop.Gui.Widgets.FileBrowser:set_CurrentDir (string) <0x29>
in MonoDevelop.Gui.Widgets.FileBrowser:.ctor () <0x6a3>
in MonoDevelop.Gui.Pads.FileScout:.ctor () <0x47>
in (wrapper runtime-invoke) System.Object:runtime_invoke_void (object,intptr,intptr,intptr) <0xc61c3657>
in (wrapper managed-to-native) System.Reflection.MonoCMethod:InternalInvoke (object,object[]) <0x4>
in (wrapper managed-to-native) System.Reflection.MonoCMethod:InternalInvoke (object,object[]) <0xfffffd7d>
in System.Reflection.MonoCMethod:Invoke (object,System.Reflection.BindingFlags,System.Refl ection.Binder,object[],System.Globalization.CultureInfo) <0x8d>
in System.Reflection.MonoCMethod:Invoke (System.Reflection.BindingFlags,System.Reflection. Binder,object[],System.Globalization.CultureInfo) <0x1c>
in System.Reflection.ConstructorInfo:Invoke (object[]) <0x35>
in System.Activator:CreateInstance (System.Type,bool) <0x105>
in System.Activator:CreateInstance (System.Type) <0xc>
in System.Reflection.Assembly:CreateInstance (string,bool) <0x3a>
in System.Reflection.Assembly:CreateInstance (string) <0x12>
in MonoDevelop.Core.AddIns.AddIn:CreateObject (string) <0xd9>
in MonoDevelop.Core.AddIns.Codons.PadCodon:CreatePad () <0x83>
in MonoDevelop.Core.AddIns.Codons.PadCodon:BuildItem (object,System.Collections.ArrayList,MonoDevelop.C ore.AddIns.Conditions.ConditionCollection) <0x14>
in MonoDevelop.Core.AddIns.DefaultAddInTreeNode:Build ChildItems (object) <0x14c>in MonoDevelop.Gui.DefaultWorkbench:UpdateViews (object,System.EventArgs) <0x64>in MonoDevelop.Commands.InitializeWorkbenchCommand:Ru n () <0x38>
in MonoDevelop.SharpDevelopMain:Main (string[]) <0x784>
in (wrapper runtime-invoke) System.Object:runtime_invoke_int_string[] (object,intptr,intptr,intptr) <0xc766f2af>

Native stacktrace:

/usr/bin/mono(mono_handle_native_sigsegv+0xbb) [0x814f88b]
/usr/bin/mono [0x813bc3f]
[0xffffe440]
/opt/gnome/lib/gnome-vfs-2.0/modules/libfile.so [0x424f1346]
/opt/gnome/lib/gnome-vfs-2.0/modules/libfile.so [0x424ece85]
/lib/ld-linux.so.2 [0x4000b9a4]
/lib/ld-linux.so.2 [0x4000bae1]
/lib/tls/libc.so.6 [0x4021fe91]
/lib/ld-linux.so.2 [0x4000b82f]
/lib/tls/libc.so.6(_dl_open+0x96) [0x40220506]
/lib/libdl.so.2 [0x4004bd68]
/lib/ld-linux.so.2 [0x4000b82f]
/lib/libdl.so.2 [0x4004c37e]
/lib/libdl.so.2(dlopen+0x41) [0x4004bdc1]
/opt/gnome/lib/libgmodule-2.0.so.0(g_module_open+0x13d) [0x4004954d]
/opt/gnome/lib/libgnomevfs-2.so.0 [0x419bdfd4]
/opt/gnome/lib/libgnomevfs-2.so.0 [0x419be340]
/opt/gnome/lib/libgnomevfs-2.so.0(gnome_vfs_transform_get+0x1e) [0x419be4ae]
/opt/gnome/lib/libgnomevfs-2.so.0(gnome_vfs_uri_new_private+0x16d) [0x419ce10d]
/opt/gnome/lib/libgnomevfs-2.so.0(gnome_vfs_uri_new+0x32) [0x419ce252]
/opt/gnome/lib/libgnomevfs-2.so.0(gnome_vfs_get_file_info+0x2a) [0x419c9bea]
/opt/gnome/lib/libgnomeui-2.so.0(gnome_icon_lookup_sync+0x39) [0x41100f19]
[0x424d314a]
[0x424d30bb]
[0x424d2f9b]
[0x424d2019]
[0x424d1c7a]
[0x424d037c]
[0x424ccbb8]
[0x41f784c1]
/usr/bin/mono [0x813baf0]
/usr/bin/mono(mono_runtime_invoke+0x27) [0x80d6827]
/usr/bin/mono(mono_runtime_invoke_array+0x1a6) [0x80d7c36]
/usr/bin/mono [0x80c6150]
[0x4106d372]
[0x4106d0c6]
[0x4106d02d]
[0x4106cfe6]
[0x41f62ab6]
[0x41f7846d]
[0x41f85093]
[0x42095f83]
[0x42095cda]
[0x424cc774]
[0x424cc6dd]
[0x420943ad]
[0x424cc5dd]
[0x424a5d09]
[0x40acd91d]
[0x40acc86c]
/usr/bin/mono [0x813baf0]
/usr/bin/mono(mono_runtime_invoke+0x27) [0x80d6827]
/usr/bin/mono(mono_runtime_exec_main+0xb1) [0x80d79a1]
/usr/bin/mono(mono_runtime_run_main+0x171) [0x80d7571]
/usr/bin/mono(strftime+0x1b8a) [0x805d112]
/usr/bin/mono(mono_main+0x841) [0x805dae1]
/usr/bin/mono(__fxstat64+0x133) [0x805c4db]
/lib/tls/libc.so.6(__libc_start_main+0xd0) [0x40143e60]
/usr/bin/mono(sinh+0x49) [0x805c431]



was muss ich da machen damit es startet?

ps: der splashscreen kommt noch!

theton
22.07.2006, 16:53
Das ist ein Segmentation-Fault (SIGSEGV). Da wirst du nicht viel machen koennen ausser dir den Quelltext zu greifen und den Fehler zu beheben. Schicke einfach mal einen Bug-Report an die Entwickler, wuerde ich sagen.

hazelnoot
24.07.2006, 11:36
das gibt es doch nicht das das ding nicht funzt... ich habs auf suse linux 10.0 installiert... kann es sein dass es daran liegt dass sich die GTK# rpms die ich mir von der monosite gesaugt habe wegen einer abhaengikeit nicht installieren lassen?

theton
24.07.2006, 11:56
Kann durchaus sein.

hazelnoot
27.07.2006, 17:55
//edit2
hat sich erlaedigt habs hinbekommen!! danke!

Boe
31.07.2006, 19:15
wie hast du es hinbekommen? ich habe das gleiche problem. bitte um hilfe!

hazelnoot
31.07.2006, 19:28
ich hab alles was mit mono zu tun gehabt hat geloescht und den installer hergenommen:
ftp://www.go-mono.com/archive/1.1.13.8/linux-installer/0/mono-1.1.13.8_0-installer.bin

und dann isses gegangen!

Boe
31.07.2006, 20:05
welche sachen hast du gelöscht? ich habe monodevelop über smart installiert (als rpm). ich habs deinstalliert und dann wieder installiert, aber der fehler bleibt. was muss man löschen?

EDIT: ich hab jetzt auch den installer probiert. wieder da gleiche problem.

hazelnoot
01.08.2006, 06:32
alles was mit mono zu tun hat... also mono gtk# usw waenn du suse hast(was ich glaube) dann mach yast auf und deinstalliere alle monopackete!!

dann muesste es eigentlich funktionieren...

Boe
01.08.2006, 09:55
ja, ich hab suse, aber eben 10.1 und da ist die hälfte des systems mit c# bzw. gtk# gemacht. wenn ich mono ganz raushaue, dann funktioniert womöglich nichts mehr. sogar der updatemanager (zmd, rug) ist in c#. sind mindestens 50 pakete die ich wieder nachinstallieren müsste. aber wahrscheinlich komme ich ich nicht daran vorbei.

hazelnoot
01.08.2006, 12:23
ich habs auf jeden fall so gemacht...

Boe
01.08.2006, 19:52
tja, es hilft nicht. gleiches problem wieder.
kann jemand mit dieser fehlermeldung was anfangen?

System.Runtime.Remoting.RemotingException: Unix transport error.

Server stack trace:
in <0x0008f> Mono.Remoting.Channels.Unix.UnixMessageIO:ReceiveM essageStatus (System.IO.Stream networkStream, System.Byte[] buffer)
in <0x0017c> Mono.Remoting.Channels.Unix.UnixClientTransportSin k:ProcessMessage (IMessage msg, ITransportHeaders requestHeaders, System.IO.Stream requestStream, ITransportHeaders responseHeaders, System.IO.Stream responseStream)
in <0x00252> Mono.Remoting.Channels.Unix.UnixBinaryClientFormat terSink:SyncProcessMessage (IMessage msg)

Exception rethrown at [0]:
---> System.Runtime.Remoting.RemotingException: Connection closed
in <0x0006c> Mono.Remoting.Channels.Unix.UnixMessageIO:StreamRe ad (System.IO.Stream networkStream, System.Byte[] buffer, Int32 count)
in <0x00044> Mono.Remoting.Channels.Unix.UnixMessageIO:ReceiveM essageStatus (System.IO.Stream networkStream, System.Byte[] buffer)--- End of inner exception stack trace ---

in <0x0008f> Mono.Remoting.Channels.Unix.UnixMessageIO:ReceiveM essageStatus (System.IO.Stream networkStream, System.Byte[] buffer)
in <0x0017c> Mono.Remoting.Channels.Unix.UnixClientTransportSin k:ProcessMessage (IMessage msg, ITransportHeaders requestHeaders, System.IO.Stream requestStream, ITransportHeaders responseHeaders, System.IO.Stream responseStream)
in <0x00252> Mono.Remoting.Channels.Unix.UnixBinaryClientFormat terSink:SyncProcessMessage (IMessage msg)

hazelnoot
02.08.2006, 14:23
was genau hast du bis jetzt gemacht?

Boe
02.08.2006, 16:00
ich habe mono deinstalliert mit allen c# und gtk# anwendungen, dann habe ich es neu installiert und der fehler blieb (ide lässt sich nicht starten). dann habe ich mir die neuste version von monodevelop von der mono-project seite runtergeladen und installiert. diese version bricht auch beim aufbau der ide, aber zumindest sehe ich eine fehlermedung. tja, soweit bin ich jetzt gekommen.

hazelnoot
02.08.2006, 17:23
hast du vl die moeglichkeit eine andere distro zu installieren :-) unter meinem debian system hat es auf anhieb geklappt... ich weis zwar nicht warum aber suse hat irgendwas installier/falsch installiert was monodevelop einfach nicht zum starten bewegt... also unter suse habs ich so zum laufen gebracht-> einfach ohne ruecksicht auf verluste alles mono was uff platt war geloescht-> mit dem monoinstaller das zeugs neu raufgespielt(aber nicht der neueste installer der 1.1.13ner oder so auf jeden fall nicht der neueste) und dann hats gefunkt frag mich nicht wieso es war halt nunmal so?( ?(

mfg hazelnoot

Boe
03.08.2006, 00:56
unter ubuntu gibt es keine probleme. nachdem nichts mehr unter suse geklappt hat, habe ich heute suse neu aufgesetzt und werde monodevelop wieder installieren mit der hoffnung, dass es wie bei ubuntu einwandfrei funktioniert.