PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Groundwork (Nagios)



manni45
08.07.2006, 11:54
Hi,
Kennt jemmand von euch Groundwork?
http://www.groundworkopensource.com/products/os-overview.html


Wer mit Nagios arbeiten möchte sollte sich dies ansehen.

Installation funzt ohne Probleme (einzige was vorher installiert werden muß ist Mysql) bekommt man alles unter oberen Webseite.
Sonst ist alles dabei Apache u.s.w klasse Tool.

gruß
manni45

devilz
08.07.2006, 14:25
http://www.unixboard.de/vb3/showthread.php?t=20878&highlight=nagios

Hatte ich dir doch geschrieben ;)

Aber bei uns kommt es nich in die Tüte, da wir am Nagios einige Modifikationen vorgenommen haben .... geht nix über eigene Configs ;)

theton
08.07.2006, 20:36
For advanced capabilities, including full support and upgrades, check out GroundWork Monitor Professional.
Wenn ich sowas lese, weiss ich, dass sowas bei mir auch nicht in Frage kommt. Dann bleib ich doch lieber beim guten alten Nagios in Verbindung mit nen paar Skripten fuer RRDTool.

honey
14.09.2006, 10:55
hallo
noch ein problem:
also ich habe apache installiert und bin jetzt dabei nagios zu konfigurieren, -->
nagios liegt unter
/export/nagios/nagios
httpd liegt unter
/export/httpd/httpd.2.2
und http://test:8080/ funktioniert,

$ ./configure --prefix=/export/nagios/ --with-htmurl=test:8080 --with-nagios-user=testperson
--> nach config: Web Interface Options:
------------------------
--->falsch HTML URL: http://localhosttest:8080/
CGI URL: http://localhost/nagios/cgi-bin/
denn jetzt kann ich kein make install machen, ich will das bei HTML URL nur http://test:8080 ausgegeben wird, wie muss ich das denn machen? :think:

mfg
honey

theton
14.09.2006, 11:02
Welche Distro hast du denn? Ist da kein Nagios dabei? Was gibt dir 'make install' als Fehler?

honey
14.09.2006, 11:07
$ make install

cd ./base && make install
make[1]: Entering directory `/export/nagios/nagios-2.5/base'
make install-basic
make[2]: Entering directory `/export/nagios/nagios-2.5/base'
/usr/bin/install -c -m 775 -o testperson -g nagios -d /export/nagios//bin
/usr/bin/install -c -m 774 -o testperson -g nagios nagios /export/nagios//bin
/usr/bin/install: kann Eigentümer von „/export/nagios//bin/nagios“ nicht ändern: Die Operation ist nicht erlaubt
make[2]: *** [install-basic] Fehler 1
make[2]: Leaving directory `/export/nagios/nagios-2.5/base'
make[1]: *** [install] Fehler 2
make[1]: Leaving directory `/export/nagios/nagios-2.5/base'
make: *** [install] Fehler 2

hab FC 5

theton
14.09.2006, 11:12
Hast du den User und die Gruppe angelegt und machst du das 'make install' als root?

devilz
14.09.2006, 11:35
Ne nette Anleitung für Einsteiger is auch -> http://www.novell.com/coolsolutions/feature/16723.html

honey
14.09.2006, 11:45
ja, group und user hab ich, und als user mit root rechte mache ich das

hab das jetzt so geändert:
./configure --prefix=/export/nagios/nagios-2.5/ --with-htmurl=test:8080 --with-nagios-user=testperson --with-nags--group=testgroup

make all geht, aber bei make install hab ich immer noch die selben fehlermeldungen :(

devilz
14.09.2006, 11:46
/export/nagios//bin/nagios


Da is ein / zuviel ;)

honey
14.09.2006, 12:35
hmm, ich hab aber /export/nagios/nagios...

wo ist denn ein / zu viel?

slasher
14.09.2006, 12:36
./configure --prefix=/export/nagios/nagios-2.5/ --with-htmurl=test:8080 --with-nagios-user=testperson --with-nags--group=testgroup
dort ist ein / zuviel, denn es muss heißen:


./configure --prefix=/export/nagios/nagios-2.5 --with-htmurl=test:8080 --with-nagios-user=testperson --with-nags--group=testgroup

honey
14.09.2006, 12:51
ja, danke, hab ich / ist jetzt weg, hab aber immer noch die selben fehlermeldungen....

theton
14.09.2006, 12:54
ja, group und user hab ich, und als user mit root rechte mache ich das

Machst du es als 'root' oder als Normaluser via sudo oder aehnliches?

supersucker
14.09.2006, 12:55
Jetzt mal langsam, du kriegst immer noch exakt die gleichen Fehlermeldungen?

Das kann eigentlich nicht sein.

Poste mal den aktuellen configure-Aufruf.

honey
14.09.2006, 13:05
also:
./configure --prefix=/export/nagios/nagios-2.5 --with-htmurl=test:8080 --with-nagios-user=testperson --with-nagios-grp=testgroup

General Options:
-------------------------
Nagios executable: nagios
Nagios user/group: testperson,nagios
Command user/group: testperson,nagios
Embedded Perl: no
Event Broker: yes
Install ${prefix}: /export/nagios/nagios-2.5
Lock file: ${prefix}/var/nagios.lock
Init directory: /etc/rc.d/init.d
Host OS: linux-gnu

Web Interface Options:
------------------------
HTML URL: http://localhosttest:8080/
CGI URL: http://localhost/nagios/cgi-bin/
Traceroute (used by WAP): /bin/traceroute
------------------------

make install:

cd ./base && make install
make[1]: Entering directory `/export/nagios/nagios-2.5/base'
make install-basic
make[2]: Entering directory `/export/nagios/nagios-2.5/base'
/usr/bin/install -c -m 775 -o testperson -g nagios -d /export/nagios/nagios-2.5/bin
/usr/bin/install -c -m 774 -o testperson -g nagios nagios /export/nagios/nagios-2.5/bin
/usr/bin/install: kann Eigentümer von „/export/nagios/nagios-2.5/bin/nagios“ nicht ändern: Die Operation ist nicht erlaubt
make[2]: *** [install-basic] Fehler 1
make[2]: Leaving directory `/export/nagios/nagios-2.5/base'
make[1]: *** [install] Fehler 2
make[1]: Leaving directory `/export/nagios/nagios-2.5/base'
make: *** [install] Fehler 2

übrigens, danke für die hilfe :)

supersucker
14.09.2006, 13:07
Und du führst make install als root aus?

honey
14.09.2006, 13:10
nein, ich mach das als "testperson", hab aber root rechte in /export/...

theton
14.09.2006, 13:10
Und du führst make install als root aus?
Das versuche ich auch schon die ganze Zeit herauszufinden. Die Fehlermeldung:

/usr/bin/install: kann Eigentümer von „/export/nagios/nagios-2.5/bin/nagios“ nicht ändern: Die Operation ist nicht erlaubt
deutet darauf hin, dass er es nicht tut.

@honey: Die vollen Lese und Schreibrechte reichen fuer testperson aber nicht, wenn die Gruppe auf eine Gruppe gesetzt werden soll, in der testperson nicht drin ist. Mache es daher einfach mal als root.

Nachtrag: Im uebrigen sind Lese- und Schreibrechte keine root-Rechte. Die bekommt der User nur ueber su oder sudo.

honey
14.09.2006, 13:13
heißt das also, dass ich make install nicht als testperson ausführen darf? keine berechtigung?

theton
14.09.2006, 13:14
heißt das also, dass ich make install nicht als testperson ausführen darf? keine berechtigung?
Genau das heisst es. 'make install' muss immer als root gemacht werden.

honey
14.09.2006, 13:20
ehm, und wenn man das nicht als root machen darf? und wenn ich der besitzer von /export... bin, sollte das trotzdem nicht gehen?

supersucker
14.09.2006, 13:26
Nochmal:

Nein.

make install muss als root ausgeführt werden.

honey
14.09.2006, 13:47
ich hab das nochmal gemacht, also alte nagios gelöscht. ... jetzt klappt das
habs aber nicht als root gemacht.

vielen dank :)

honey
26.09.2006, 14:41
hallo
ich habe gestern mein web-interface installiert, danach wurde die nagios startseite angezeit. kurz danach ist mein rechner abgestürzt, und seit heute läuft nichts mehr, apache nicht, nagios natürlich auch nicht!

habe folgendes gemacht:

ScriptAlias /nagios/cgi-bin/ /usr/local/nagios/sbin/
<Directory "/usr/local/nagios/sbin/">
AllowOverride AuthConfig
Options ExecCGI
Order allow,deny
Allow from all
</Directory>

Alias /nagios/ /usr/local/nagios/share/
<Directory "/usr/local/nagios/share">
Options None
AllowOverride AuthConfig
Order allow,deny
Allow from all
</Directory>

aus httpd.conf rausgenommen, apache lässt sich nicht starten. fehlermeldung:
# /usr/sbin/apachectl start
(13)Permission denied: make_sock: could not bind to address [::]:80
(13)Permission denied: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs

#/usr/sbin/apachectl stop
httpd (no pid file) not running

gestern hatte ich die selben fehlermeldungen, da hat apache aber noch funktioniert.
which apachectl: which: no apachectl in (/usr/lib/qt-3.3/bin:/usr/kerberos/bin:/usr/local/bin:/usr/bin:/bin:/usr/X11R6/bin)


hat jemand ne idee wo der fehler sein könnte?

mfg
honey

theton
26.09.2006, 19:14
Schau doch mal mit netstat welches Prozess da auf Port 80 haengt und stelle sicher, dass du den Webserver als root startest.

honey
27.09.2006, 07:58
ich hab port 8080 genommen,

# netstat
unix 3 [ ] STREAM VERBUNDEN 8080
ja und ich mach das als root

außerdem wenn ich ps -ef mache, läuft weder httpd noch apache, und in /logs/error sind keine fehlermeldungen, das letzte ist von montag, bevor nagios lief,

honey
27.09.2006, 14:38
Bitte Um Eine Antwort

theton
27.09.2006, 14:55
Auf Port 8080 laeuft normalerweise ein Proxy-Server. Dass der Port bei dir offenbar benutzt wird, ist ja wohl erkennbar. Schau mal mit

netstat -lanep
welches Programm da auf dem Port haengt.

PS: Und sei nicht so ungeduldig. ;) Gibt Leute hier, die arbeiten nebenbei und schauen nicht alle paar Minuten ins Board. :)

honey
27.09.2006, 15:10
also bei netstat -lanep krieg ich folgendes raus:
unix 3 [ ] STREAM VERBUNDEN 8080 2380/gnome-terminal /tmp/orbit-sev

aber warum sagt er:
/usr/sbin/apachectl start
(13)Permission denied: make_sock: could not bind to address [::]:80
(13)Permission denied: make_sock: could not bind to address 0.0.0.0:80
no listening sockets available, shutting down
Unable to open logs

/usr/sbin/apachectl stop
httpd (no pid file) not running

denn der apache läuft ja nicht mehr,

PS: ich werds mir merken und versuche geduldiger zu sein :D

devilz
27.09.2006, 15:46
Machst du das als root?

theton
27.09.2006, 15:50
Dein Problem liegt wahrscheinlich u.a. an

Unable to open logs
Offenbar hat dein Webserver-User keine Rechte um seinen Log-Dateien anzulegen bzw. darin zu schreiben. Das solltest du zuerstmal ueberpruefen. Dein Webserver versucht offenbar sich an Port 80 zu binden und nicht an 8080. Also solltest du mit dem oben genannten netstat-Befehl mal schauen, was auf diesem Port haengt.

supersucker
27.09.2006, 16:00
Wenn dein Server auf Port 80 lauscht und du den als nicht-root gestartet hast, kann das sowieso nicht klappen, weil Dienste die Ports < 1024 nutzen müssen immer als root gestartet werden.

honey
27.09.2006, 16:23
also, montag hatte ich das selbe problem, das war aber weil ich ./apachectl restart ansttat start geschrieben hatte.
danach ist mein rechner abgestürzt, und seitdem funktioniert das nicht mehr,
ich mach das als root, und hab port 8080 genommen.

#netstat -lanep
unix 3 [ ] STREAM VERBUNDEN 8080 2380/gnome-terminal /tmp/orbit-sev

theton
27.09.2006, 22:55
und hab port 8080 genommen.

Dein Apache wuerde nicht versuchen mit Port 80 zu verbinden, wenn du ihm Port 8080 in der Konfiguration eingestellt hast.

honey
28.09.2006, 08:09
httpd.conf-->

Listen 8080

theton
28.09.2006, 11:02
Dann schau mal in deiner Konfiguration, ob irgendwo noch ein anderer Port definiert ist (z.B. in einem VirtualHost-Eintrag oder ein 2. Listen). Auf jeden Fall wird dieser Wert offenbar nochmal irgendwo ueberschrieben, denn dein Apache meldet, dass er versucht zu Port 80 zu verbinden.

honey
28.09.2006, 13:30
es klappt jetzt
danke :)
und bis bald :p

supersucker
28.09.2006, 13:38
Ja, und woran lags?

honey
28.09.2006, 13:54
es lag daran, dass 2 mal apachectl gab, und er jedes mal das falsche genommen hatte

honey
26.10.2006, 13:30
hallo leute
hab wieder mal ein problem mit nagios :(

bei der Eingabe des Befehls:
/usr/local/nagios/bin/nagios /usr/local/nagios/etc/nagios.cfg
kommt:

Nagios 2.5
Copyright (c) 1999-2006 Ethan Galstad (http://www.nagios.org)
Last Modified: 07-13-2006
License: GPL

Nagios 2.5 starting... (PID=...)
Error: Could not open config directory '/usr/local/nagios/etc/checkcommands' for reading.
Bailing out due to one or more errors encountered in the configuration files. Run Nagios from the command line with the -v option to verify your config before restarting.

meine nagios.cfg sieht so aus:
log_file=/usr/local/var/nagios.log
cfg_file=/usr/local/nagios/etc/hosts.cfg
cfg_file=/usr/local/nagios/etc/services.cfg
cfg_file=/usr/local/nagios/etc/checkcommands.cfg

cfg_dir=/usr/local/nagios/etc/checkcommands
cfg_dir=/usr/local/nagios/etc/services
cfg_dir=/usr/local/nagios/etc/hosts

mein nagios.logs-->
Error: Could not open config directory '/usr/local/nagios/etc/checkcommands' for reading.
[5645478] Bailing out due to one or more errors encountered in the configuration files. Run Nagios from the command line with the -v option to verify your config before restarting.

Wäre dankbar für jede Hilfe.
MfG
honey

devilz
26.10.2006, 13:52
Na dann prüf dochmal die Rechte auf den Dateien ;)

theton
26.10.2006, 14:22
In deiner nagios.cfg sind 2 Einträge:


nagios_user=<dein-nagios-user>
nagios_group=<deine-nagios-gruppe>

Dieser User und diese Gruppe muss Lese- und Schreibrechte auf die zu Nagios gehörenden Verzeichnisse und Dateien haben.

honey
26.10.2006, 15:45
danke für die schnelle antwort :)
also ich habe checkcommands chmod 777 gegeben. das problem sind die:
cfg_dir=/usr/local/nagios/etc/checkcommands
cfg_dir=/usr/local/nagios/etc/services
cfg_dir=/usr/local/nagios/etc/hosts
Error: Could not open config directory '/export/nagios/etc/checkcommands' for reading.
und nicht die *.cfg

wenn ich die auskommentiere, bekomm ich:

Checking services...
Warning: Service 'PING' on host 'nagiosrechner' has no default contact group(s) defined!
Error: Check period '24x7' specified for service 'PING' on host 'nagiosrechner' is not defined anywhere!
Error: Notification period '24x7' specified for service 'PING' on host 'nagiosrechner' is not defined anywhere!
Checked 1 services.
Checking hosts...
Error: Check period '24x7' specified for host 'nagiosrechner' is not defined anywhere!
Error: Contact group 'nagiosadmins' specified in host 'nagiosrechner' is not defined anywhere!
Error: Notification period '24x7' specified for host 'nagiosrechner' is not defined anywhere!
Checked 1 hosts.
Checking host groups...
Error: There are no host groups defined!
Checked 0 host groups.
Checking service groups...
Checked 0 service groups.
Checking contacts...
Error: There are no contacts defined!
Checked 0 contacts.
Checking contact groups...
Error: There are no contact groups defined!
Checked 0 contact groups.
Checking service escalations...
Checked 0 service escalations.
Checking service dependencies...
Checked 0 service dependencies.
Checking host escalations...
Checked 0 host escalations.
Checking host dependencies...
Checked 0 host dependencies.
Checking commands...
Checked 16 commands.
Checking time periods...
Checked 0 time periods.
Checking extended host info definitions...
Checked 0 extended host info definitions.
Checking extended service info definitions...
Checked 0 extended service info definitions.
Checking for circular paths between hosts...
Checking for circular host and service dependencies...
Checking global event handlers...
Error: Global host event handler command 'log-host-event-to-db' is not defined anywhere!
Error: Global service event handler command 'log-service-event-to-db' is not defined anywhere!
Checking obsessive compulsive processor commands...
Error: Obsessive compulsive service processor command 'obsessive_service_handler' is not defined anywhere!
Error: Obsessive compulsive host processor command 'obsessive_host_handler' is not defined anywhere!
Checking misc settings...

Total Warnings: 1
Total Errors: 12

***> One or more problems was encountered while running the pre-flight check...

Check your configuration file(s) to ensure that they contain valid
directives and data defintions. If you are upgrading from a previous
version of Nagios, you should be aware that some variables/definitions
may have been removed or modified in this version. Make sure to read
the HTML documentation regarding the config files, as well as the
'Whats New' section to find out what has changed.
und wo soll ich dem benutzer und gruppe rechte geben?

theton
26.10.2006, 15:50
Ich sagte ja auch nicht, dass die Konfigs das Problem sind, sondern dass du dort ermitteln kannst, welches dein Nagios-User ist. Dieser User muss auf die Skripte und Programme Ausführrechte haben und auf Konfigurationen, Daten-Verzeichnisse etc. Lese- und Schreibrechte. Mach mal ein


chown -R deinnagiosuser:deinenagiosgruppe /export/nagios
chmod -R ug+rw /export/nagios

honey
26.10.2006, 16:07
ok, hab ich gemacht, die fehlermeldung ist aber noch nicht weg
Error: Could not open config directory '/local/usr/nagios/etc/checkcommands' for reading.
....

theton
26.10.2006, 16:18
Verzeichnisse müssen auf +x gesetzt sein, damit der User da überhaupt reinwechseln kann.

honey
26.10.2006, 16:57
alle verzeichnisse und die 3 cfg-dir haben alle rechte bekommen: nun:
Checking services...

Checking hosts...Error: Contact group 'nagios' specified in service 'PING' for host 'nagiosrechner' is not defined anywhere!
Error: Check period '24x7' specified for service 'PING' on host 'nagiosrechner' is not defined anywhere!
Error: Notification period '24x7' specified for service 'PING' on host 'nagiosrechner' is not defined anywhere!
Checked 1 services.

Error: Contact group 'nagiosadmins' specified in host 'nagiosrechner' is not defined anywhere!
Checked 1 hosts.
Checking host groups...
Error: There are no host groups defined!
Checked 0 host groups.
Checking service groups...
Checked 0 service groups.
Checking contacts...
Error: There are no contacts defined!
Checked 0 contacts.
Checking contact groups...
Error: There are no contact groups defined!
Checked 0 contact groups.
Checking service escalations...
Checked 0 service escalations.
Checking service dependencies...
Checked 0 service dependencies.
Checking host escalations...
Checked 0 host escalations.
Checking host dependencies...
Checked 0 host dependencies.
Checking commands...
Checked 16 commands.
Checking time periods...
Checked 0 time periods.
Checking extended host info definitions...
Checked 0 extended host info definitions.
Checking extended service info definitions...
Checked 0 extended service info definitions.
Checking for circular paths between hosts...
Checking for circular host and service dependencies...
Checking global event handlers...
Error: Global host event handler command 'log-host-event-to-db' is not defined anywhere!
Error: Global service event handler command 'log-service-event-to-db' is not defined anywhere!
Checking obsessive compulsive processor commands...
Error: Obsessive compulsive service processor command 'obsessive_service_handler' is not defined anywhere!
Error: Obsessive compulsive host processor command 'obsessive_host_handler' is not defined anywhere!
Checking misc settings...
____________________________________________
services.cfg
check_period 24x7
max_check_attempts 5
normal_check_interval 5
retry_check_interval 3
notification_options w,c,r
notification_interval 30
notification_period 24x7

honey
27.10.2006, 13:04
so, hab alle fehlermeldungen weggekriegt, nagios ist gestartet, hab trotzdem immer noch keine rechte irgendetwas zu machen,

@theton
hab das was du gesagt hattest, chmod -R... auch gemacht, alle .cfg's: chmod 750
und nun bekomm ich auch noch ständig diese meldung:

Nagios 2.5
Copyright (c) 1999-2006 Ethan Galstad (http://www.nagios.org)
Last Modified: 07-13-2006
License: GPL

Nagios 2.5 starting... (PID=..)
/usr/local/nagios/libexec/check_disk: Diese Option benötigt ein Argument -- »p««
/usr/local/nagios/libexec/check_disk: Diese Option benötigt ein Argument -- »p«

hab versucht, check_disk zu öffnen:
nagios/libexec/check_disk: Not a text file ********

naja, nun bin ich ratlos, bitte um hilfe!

theton
27.10.2006, 13:24
/usr/local/nagios/libexec/check_disk: Diese Option benötigt ein Argument -- »p««

Dann hast du in der services-Konfiguration das check_disk für irgendein Host falsch eingetragen, vermute ich mal.
Ein check_disk-Eintrag (im Beispiel für hda3) in der services.cfg sollte wie folgt aussehen:


define service{
use generic-service
host_name mein.server.de
service_description /dev/hda3 Free Space
is_volatile 0
check_period 24x7
max_check_attempts 3
normal_check_interval 5
retry_check_interval 1
contact_groups deine-kontakt-gruppe
notification_interval 120
notification_period 24x7
notification_options u,c
check_command check_local_disk!20%!10%!/dev/hda3
}

honey
06.11.2006, 09:50
Guten morgen
also service.cfg sieht bei mir so aus:

define service{
# use generic-service
host_name testrechner
service_description PING
check_period 24x7
max_check_attempts 5
normal_check_interval 5
retry_check_interval 3
contact_groups nagios
notification_options w,c,r
notification_interval 30
notification_period 24x7
check_command check_ping!100.0,20%!500.0,60%
}

Muss PING durch was anderes ersetzt werden?
Danke für die Hilfe
MfG
Honey

theton
06.11.2006, 10:30
Kommt drauf an was du monitoren willst. Mit dem ping-Plugin kannst du lediglich testen ob ein Host überhaupt erreichbar ist. Wenn du immer noch deinen HD-Space monitoren willst, findest du in meinem letzten Beitrag ein Beispiel für einen check_local_disk-Eintrag.

check_ping macht eh nur dann Sinn, wenn das Monitoring auf einem anderen Rechner läuft.

honey
06.11.2006, 11:47
hm, ok hab das jetzt so umgeschrieben:
define service{
# use generic-service
host_name testrechner
# service_description PING
service_description /dev/hda Free Space
check_period 24x7
max_check_attempts 5
normal_check_interval 5
retry_check_interval 3
contact_groups nagios
notification_options w,c,r
notification_interval 30
notification_period 24x7
# check_command check_ping!100.0,20%!500.0,60%
check_command check_local_disk!20%!10%!/dev/hda3
}

und minimal.cfg hab ich auch geändert, kriege aber immer noch: nagios/libexec/check_disk: Diese Option benötigt ein Argument -- »p«

honey
07.11.2006, 15:30
irgend welche Ideen?

devilz
07.11.2006, 15:40
irgend welche Ideen?

Ruf mal ../libexec/check_command check_local_disk mit deinen Werten auf (!20%!10%!/dev/hda3). Da stimmt der Syntax nicht.

honey
07.11.2006, 16:05
also, hda3 hatte ich schon in hda umgeändert
aber die fehlermeldung ist immer noch da

theton
07.11.2006, 16:09
hda ist eine Platte und keine Partition. check_disk kann nur auf Partitionen arbeiten.

honey
08.11.2006, 09:52
achso, ok. Aber wenn ich hda in hda2 umändere dann sollte es klappen, oder?
Tut es aber nicht. Alles ist ja in checkcommand.cfg definiert, Beispiel:
define command{
command_name check_ping
command_line $USER1$/check_ping -H $HOSTADDRESS$ -w $ARG1$ -c $ARG2$ -p 5
}
Wie soll ich denn /dev/hda2 definieren? denn das ist jetzt nur in service und minimal.cfg aber nirgendwo richtig definiert.

devilz
08.11.2006, 09:58
achso, ok. Aber wenn ich hda in hda2 umändere dann sollte es klappen, oder?
Tut es aber nicht. Alles ist ja in checkcommand.cfg definiert, Beispiel:
define command{
command_name check_ping
command_line $USER1$/check_ping -H $HOSTADDRESS$ -w $ARG1$ -c $ARG2$ -p 5
}
Wie soll ich denn /dev/hda2 definieren? denn das ist jetzt nur in service und minimal.cfg aber nirgendwo richtig definiert.

Schau dir dochmal die checkcommands.cfg-sample an, da sind schon schöne Beispiele dabei.
Nagios mußt du größtenteils für dich selbst anpassen, d.H. du mußt schauen welche Werte du für dein checkcommand brauchst, und wie du die übergibst.
Wie du nun ei check_ping mit einem check_disk vergleichst is mir schleierhaft ;)



Usage: check_disk -w limit -c limit [-p path | -x device] [-t timeout][-m] [-e] [-W limit] [-K limit] [-v] [-q]


Wenn du die check Scripte mal aufrufst, siehst du welche Optionen du übergeben mußt .. und dir fehlt wohl etwas ;D

honey
04.01.2007, 15:57
hallo ihr lieben
es geht wieder um nagios... meine frage ist, müssen die rechner und server die von nagios überwacht werden, auch was installiert werden?

mfg
honey

theton
04.01.2007, 16:03
Das kommt drauf an, was du überwachen willst.

honey
05.01.2007, 08:26
server, wie mailserver, terminal server, dhcp server und dienste wie smtp, pop3 und... müssen überwacht werden

theton
05.01.2007, 09:59
Wenn es nur um die Erreichbarkeit von Diensten geht, musst du auf dem zu überwachenden Rechner nichts installieren. Die Erreichbarkeit eines Server-Dienstes wird überprüft, indem Nagios eine Verbindung zum entsprechenden Dienst aufbaut und schaut, ob dieser erreichbar ist. Allerdings muss Nagios auf den zu überwachenden Rechnern installiert sein, wenn du lokale Dienste (Cron u.ä.) oder Sachen wie HD-Platz, Netzwerk-Durchsatz u.ä. monitoren willst.

honey
05.01.2007, 10:13
erstmal danke für die antwort :)
heißt das, dass nagios die verbindung auch zu rechnern aufbauen kann, wo nur root sich anmelden kann? also wenn an rechner x http und smb überprüft werden müssen, kann nagios die verbindung aufbauen, ohne sich anmelden zu müssen und ohne root-rechte?

mfg

theton
05.01.2007, 11:07
Jep, genau das heisst es. Nagios verbindet dann zum entsprechenden Port und überprüft lediglich, ob das erwartete Protokoll dort verfügbar ist.

honey
05.01.2007, 11:17
danke dir :)

honey
08.01.2007, 08:10
Guten Morgen.
Mit welchem Befehl baut Nagios denn die Verbindung auf? Per Plugins-Befehl?

mfg
honey

theton
08.01.2007, 08:15
Nagios nutzt seine Plugins um die Verbindungen aufzubauen. Evtl. solltest du einfach mal die Doku lesen.

honey
08.01.2007, 08:27
Ja, die Doku hab ich schon gelesen. Aber anscheinend gibts da bestimmte Befehle für eine Verbindungaufbau und diese Befehle find ich nicht :(

theton
08.01.2007, 08:35
Nein, es gibt bestimmte Plugins für den Verbindungsaufbau. Je nach überwachtem Service wird ein anderes Plugin benötigt und für jedes Plugin gibt es eine entsprechende Doku.

honey
08.01.2007, 08:48
Also, ich habe diese Fragen gestellt bekommen, und mein Ausbilder wollte nichts mit Plugins oder irgendwelche Ports wissen. Ich suche schon seit Freitag vergeblich nach irgendwelche Antworten!
wie kommt nagios an infos ran?
welche befehle werden benutzt?
wie kriegt nagios raus dass ein server oder dienst läuft? mit welchem befehl?
woher weiß nagios wie ein webserver läuft?

theton
08.01.2007, 09:07
Also nochmal... Für jeden zu überwachenden Service gibt es ein Plugin. Diese Plugins sind in der Lage aufgrund der Antwort, die sie bei der Anfrage an einen Server erhalten, herauszubekommen ob alles funktioniert. Beispiel:
Um zu überprüfen, ob ein SMTP-Server auf einem Host läuft, nutzt man das Plugin check_smtp und definiert dafür einen Service.


define service{
use generic-service
host_name meinserver.de
service_description SMTP
is_volatile 0
check_period 24x7
max_check_attempts 3
normal_check_interval 3
retry_check_interval 1
contact_groups linux-admins
notification_interval 120
notification_period 24x7
notification_options u,c
check_command check_smtp
}

Das check_command ist hier also das Plugin check_smtp. Das Plugin baut eine Verbindung zum Port 25 des Servers auf und überprüft, ob sich dort ein SMTP-Server meldet. Für das entsprechende Host muss es natürlich in der hosts.cfg eine entsprechende Definition geben. Wenn du wissen willst, welche Befehle von den Plugins genutzt werden, so wirst du also einen Blick in die Plugin-Quelltexte werfen müssen.

honey
08.01.2007, 09:16
Vielen Dank für deine ausführliche Antwort. Ja, Plugins hab ich mir auch schon angeguckt. Es hat mir aber auch nicht weiter geholfen.

theton
08.01.2007, 10:04
Tja, weil in den wenigsten Plugins Befehle genutzt werden, sondern entsprechende C-Funktionen. Daher ist mir unklar, von was für Befehlen dein Ausbilder da spricht, wenn es um Nagios geht. Nagios nutzt nunmal nur in den wenigsten Fällen Befehle.

honey
08.01.2007, 10:32
Ich weiß auch nicht was er für Befehele haben will. Jetzt muss ich mir die Plugins angucken und ihm daraus die Befehle sagen! Aber außer irgendwelche Anweisungen sehe ich da NIX!!!! :hilfe:

theton
08.01.2007, 10:39
Du wirst in diesen Plugins keine Befehle finden. Die meisten Plugins sind in C geschrieben und sie nutzen C-Funktionen und keine Befehle um ihre Checks durchzuführen.

honey
08.01.2007, 14:34
Danke für deine Hilfe :)

mfg
honey

honey
10.01.2007, 12:14
Hallo,
eine Frage, also Event-Handler werden doch automatisch gestartet, wie wid das gemacht? oder manuell per über ssh-Verbindung?

mfg
honey

theton
10.01.2007, 12:32
Die werden über event_handler_enabled in der Service-Definition aktiviert. Und ich sag's dir jetzt nochmal RTFM! :rtfm: Langsam hab ich das Gefühl, dass du einfach zu faul bist selbst nachzulesen.

honey
10.01.2007, 13:20
erstmal danke für deine hilfe. und nein das stimmt nicht, ich suche schon, und wie du es sagst, dass man sie definieren und aktivieren muss, weiß ich. da ist aber nicht erklärt, wie nagios das macht, wie nagios ein event-handler an server x schickt und sagt dass er rebooten soll, bei global-event-handler

theton
10.01.2007, 14:46
Ich nehme an, dass du dann http://nagios.sourceforge.net/docs/1_0/eventhandlers.html auch schon gelesen hast? Um z.B. einen Server zu rebooten schreibst du dir einen EventHandler, der per SNMP oder via SSH einen Reboot auslöst, wenn es sich um einen entfernten Server handelt. Wenn es um den Monitoring-Server selbst geht, reicht ein einfaches 'shutdown -r now' im EventHandler als Befehl.

honey
10.01.2007, 15:25
ja die seite hab ich schon paar mal gelesen, das was du geschrieben hast, hab ich da aber nicht gefunden, vielen dank für deine hilfe

theton
10.01.2007, 15:55
Naja, Nagios ist nunmal ein Monitoring-Tool und kein Server-Management. Event-Handler, die was mit dem zu monitorenden Server machen sollen, müssen daher mit Hilfe anderer Tools (SSH, SNMP, MySQL usw.) gelöst werden.