PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : SAMBA Server extrem langsam



Zico
25.05.2006, 01:04
Hi Leute.

Ganz fix: hab wieder ein Problem - mit dem SAMBA Server.
Version 3.0.22-11

Wenn ich von einem Windows Rechner Daten ziehe dauern 12MB Daten ca 4 Minuten.
Das Uplink Kabel scheint in Ordnung.
Hier die smb.conf:


[global]
workgroup = LOCAL
security = share
socket options = TCP_NODELAY

[marvin-data]
browseable = Yes
comment = Data Ordner
path = /media/data
read only = Yes
guest ok = Yes

[marvin-share]
available = Yes
browseable = Yes
comment = Share Ordner
create mask = 0777
directory mask = 0777
guest ok = Yes
path = /media/data/share
read only = No


Die Option "socket options = TCP_NODELAY" hab ich derzeit nur zum testen drin, da ich hörte, sie würde Speed-mäßig was bringen, doch geholfen hats nix. Zur Config:
Es handelt sich hier nur um ein kleines Familiennetz (Ich an Notebook und Freundin an PC) - daher die "laschen" Sicherheiten.
Hat jemand eine Idee an was das liegen könnte? Hatte schon die Festplatte im Auge, doch Daten lokal lesen und schreiben geht sehr fix.

Edit: Achja, SuSE 10.1 x86_64

theton
25.05.2006, 03:13
Leg mal die IP(s) fuer das(die) Interface(s) in der global-Sektion noch fest. *empfehl*

Bsp:
interfaces = 192.168.0.1/255.255.255.0

Edit: Achja, und setze mal die folgenden Socket-Optionen:
socket options = SO_KEEPALIVE IPTOS_LOWDELAY TCP_NODELAY

Zico
25.05.2006, 08:55
Hat leider auch noch nichts geholfen. :(
Auch eine Kombination der Optionen scheint nichts zu bringen.

EDIT:
Problem - HALBWEGS - gelöst.
Ich hab eben mal die Netzwerkkarte ausgetauscht. Hat das Problem gelöst. Vorher war meine Gigabit Karte (Yukon Gigabit Ethernet 10/100/1000Base-T Adapter) am HUB dran, doch anscheinend hat die ein kleines Kompatibilitätsproblem :(

damager
25.05.2006, 10:56
hast du ne option protocol in deiner smb.conf definiert?
versuche es mal mit der option:


protocol = NT1


btw: boardsuche hier mal benutzt?
(http://www.unixboard.de/vb3/showthread.php?t=19561)

Zico
25.05.2006, 10:58
Naja hat sich ja mittlerweile rausgestellt, dass die Netzwerkkarte schuld ist (NFS-Server war auch ewig langsam, habe ich dann noch herausgefunden).
Naja, hab nun die Kabel getauscht und nun macht die Gigabit Karte halt die schnittstelle zum DSL Modem... für DSL 1000 reichts locker aus.