PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Samba bricht Datenübertragung ab!



janhei
04.05.2006, 10:32
Hallo zusammen!

habe letzte Woche für unsere Studenten-WG einen neuen Server installiert! Es läuft Suse 10 mit Samba 3.0.20-4-SUSE.
Leider kommt es beim Datentransfer (zwischen Server und den Windows XP clients) regelmäßig zum Abbruch der übertragung. Fehlermeldung: "Netzwerkverbindung zurückgesetzt" "Medium nicht mehr verfügbar"... genauen Wortlaut der Fehlermeldung weiß ich grad leider nicht!
Habe schon einiges im Netz gesucht und diverse foren durchstöbert. Daraufhin habe ich ein paar Tipps gefunden, von denen mir aber keiner geholfen hat! Auf Grundlage der gefundenen Tipps habe ich vor einigen Tagen zum Test eine andere Netzwerkkkarte in den Server eingebaut (ohne Erfolg). Auch die Parameter die ich in der unten stehender smb.conf unter "Tuning" eingefügt ha be konnten das Problem nicht lösen!

Hat jemand ne Ahnung wie ich das Problem lösn kann? Liegt es an Samba 3? Wäre froh, wenn es eine Lösung des Problems ohne ein downgrade gäbe!



[global]
workgroup = TGWGKA
printcap name = cups
cups options = raw
map to guest = Bad User
include = /etc/samba/dhcp.conf
logon path = \\%L\profiles\.msprofile
logon home = \\%L\%U\.9xprofile
logon drive = P:
add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody -s /bin/false %m$
domain master = yes
restrict anonymous = no
null passwords = yes
guest ok = yes
max protocol = NT
ldap ssl = No
server signing = Auto
server string = Server TGwgKA
case sensitive = no
msdfs proxy = no
read only = no
wins support = yes
domain logons = yes
netbios name = server
security = user
os level = 68
local master = yes
preferred master = yes

# Tuning
max xmit = 16644
large readwrite = no
use sendfile = no
keepalive = 30
deadtime = 1
kernel oplocks = yes
oplocks = yes



Hier noch einauszug aus meiner log.smbd zu einigen Zeitpunkten, an denene ein Verbindungsabbruch erfolgte:


[2006/04/25 15:16:04, 0] lib/util_sock.c:write_data(554)
write_data: write failure in writing to client 192.168.123.20. Error Connection reset by peer
[2006/04/25 15:16:04, 0] lib/util_sock.c:send_smb(762)
Error writing 4 bytes to client. -1. (Connection reset by peer)


[2006/04/25 15:34:48, 0] lib/util_sock.c:get_peer_addr(1222)
getpeername failed. Error was Transport endpoint is not connected
[2006/04/25 15:34:48, 0] lib/util_sock.c:get_peer_addr(1222)
getpeername failed. Error was Transport endpoint is not connected
[2006/04/25 15:34:48, 0] lib/util_sock.c:write_data(554)
write_data: write failure in writing to client 0.0.0.0. Error Connection reset by peer
[2006/04/25 15:34:48, 0] lib/util_sock.c:send_smb(762)
Error writing 4 bytes to client. -1. (Connection reset by peer)

[2006/05/02 11:09:14, 0] lib/util_sock.c:write_data(554)
write_data: write failure in writing to client 192.168.123.20. Error Connection reset by peer
[2006/05/02 11:09:14, 0] lib/util_sock.c:send_smb(762)
Error writing 4 bytes to client. -1. (Connection reset by peer)
[2006/05/02 11:09:16, 1] smbd/service.c:make_connection_snum(662)
jan-nb (192.168.123.20) connect to service download initially as user nobody (uid=65534, gid=65533) (pid

10940)

[2006/05/02 23:30:06, 0] lib/util_sock.c:write_data(554)
write_data: write failure in writing to client 192.168.123.20. Error Connection reset by peer
[2006/05/02 23:30:06, 0] lib/util_sock.c:send_smb(762)
Error writing 4 bytes to client. -1. (Connection reset by peer)
[2006/05/03 07:29:06, 0] lib/util_sock.c:get_peer_addr(1222)
getpeername failed. Error was Transport endpoint is not connected
[2006/05/03 07:29:06, 0] lib/util_sock.c:get_peer_addr(1222)
[2006/05/03 23:07:05, 0] lib/util_sock.c:get_peer_addr(1222)
getpeername failed. Error was Transport endpoint is not connected
[2006/05/03 23:07:05, 0] lib/util_sock.c:get_peer_addr(1222)
getpeername failed. Error was Transport endpoint is not connected
[2006/05/03 23:07:05, 0] lib/util_sock.c:read_data(526)
read_data: read failure for 4 bytes to client 0.0.0.0. Error = Connection reset by peer
[2006/05/04 00:11:38, 0] lib/util_sock.c:read_data(526)
read_data: read failure for 4 bytes to client 192.168.123.20. Error = No route to host


Wenn ich schon dabei bin... noch was zu meinem Samba. Wenn ich den smbd starte sehe ich in der Netzwerkumgebung (bei XP client) alle Rechner die im Netz sind, nach einer gewissen Zeit. Minimiert sich die Anzahl auf den Server und einen Win 2000 client. Kann man da au was an den Einstellungen drehen? Habe schon viel am os-level rum gespielt, aber auch ohne Erfolg!

Also, dass wars jetzt aber!
Bin auf eure Antworten gespannt und danke auch schonmal für eure Bemühungen!

MfG
Jan

lordlamer
04.05.2006, 11:20
verwendest du einen hub oder switch?

janhei
04.05.2006, 11:39
Ja, ich verwende ein 3com Switch!

lordlamer
04.05.2006, 11:45
hi

hast du auf dem netzwerkinterface paketfehler?

kannst du mit ifconfig nachgucken

janhei
04.05.2006, 11:49
Hi!

Glaube ich habe keine Paketfehler! Sieht so aus:

Link encap:Ethernet HWaddr 00:01:02:99:0F:47
inet addr:192.168.123.1 Bcast:192.168.123.255 Mask:255.255.255.0
inet6 addr: fe80::201:2ff:fe99:df47/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:9152660 errors:0 dropped:0 overruns:0 frame:0
TX packets:11141894 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:434138325 (414.0 Mb) TX bytes:169929439 (162.0 Mb)
Interrupt:10 Base address:0x9000


... aber trotz dem Danke für den Tipp! Bin weiterhin für alle Vorschläge offen, nur her damit ;-)

Würde mich auch schon sehr freuen, wenn mir jemand sagen könnte, wie ich es hin bekomme, dass immer alle Rechner in der Win-Netzwerkumgebung zu sehen sind!

phurx
25.10.2006, 12:34
hallo, versuch mal die deadtime auf 10 oder 15 zu setzen.
lg, Gia Phu Liu