PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : NT 4.0 will nicht mit Samba 3.0.14!?



babbaa
02.05.2006, 11:08
Irgendwie habe ich mich auf "das schmale Brett" begeben, und einen neuen Server mit Ubuntu Breezy aufzusetzen. Hauptanwendung ist Samba. Der Server soll meinen gaaaanz alten Server ablösen, der noch unter Samba 1.9.x läuft. Da am Netz ein ganzes Arsenal von unterschiedlichen Kisten läuft, habe ich die verschlüsselten Passwörter kurzerhand abgeschalten. Mit dem alten Samba geht es sowie nicht ohne andere Schmerzen. Alles läuft über eine Workgroup, also nichts mit Domänen. Auch die restliche Konfiguration im global-Abschnitt ist Standard-Debian.

Nach dem Aufsetzen des neuen Servers habe ich einige Clients getestet, von denen ich glaubte, dass sie am ehesten Probleme bereiten würden. Windows 98/ME liefen ebenso unkompliziert wie Windows XP und Windows2000 oder Linux.

Erfreut über die klaglosen Migrationanfänge wollte ich nun die Server wechseln. Ich hatte schon alles vorbereitet, als ich an eine alte Windows-NT 4.0 (SP6a) Kiste gegangen bin, und voll auf die Nase fiel. Die Anmeldung von NT aus schlägt fehl. In den Logs steht, dass pam-auth fehlgeschlagen ist (NT_STATUS_LOGON_FAILURE).



[2006/04/28 11:10:44, 0] auth/pampass.c:smb_pam_passcheck(810)
smb_pam_passcheck: PAM: smb_pam_auth failed - Rejecting User mdb !



Leider kann ich damit nichts anfangen. Beim Googlen bin ich häufiger über das Problem gestolpert, aber nie war eine Lösung dabei. Lediglich im Migrations-Guide fand ich folgenden Hinweis:



Änderungen im Verhalten

Die folgenden Themen sind bekannte Veränderungen im Verhalten zwischen
Samba-2.2 und Samba-3, die manche Installationen beeinflussen können.

1. Wenn Samba-2.2 als Mitglied einer Windows-Domäne arbeitet, würde es
alle Benutzer, die vom entfernten DC authentifiziert wurden, dem
"guest account" zuordnen, wenn keine UID durch den Aufruf getpwnam()
erhalten werden kann. Samba-3 weist die Verbindung als
"NT_STATUS_LOGON_FAILURE" ab. Es gibt derzeit keine
Möglichkeit, das Verhalten von Samba-2.2 wiederherzustellen.


Da ich mich überhaupt nicht mit Domänen auskenne, befürchte ich, dass die Umstellung auf dieses Konzept mehr Probleme bereitet wie es löst.

Kurz um:

Wer kennt dieses Problem und kann (schnell) helfen.


PS: ich habe Samba 3.0.22 von Breezy zurückportiert. Aber auch die neue Version zeigt das Problem.

Problem gelöst:

Durch einige Hinweise zu anderen Problemen habe gestern Abend einfach die probehalber Passwortverschlüsselung eingeschaltet. Jetzt konnte ich mich von NT4 aus einloggen (musste erst ein neues Passwort mit smbpasswd vergeben). Ich weiss zwar nicht warum, aber es geht. Ich weiss nur noch nicht, welche anderen Seiteneffekte auftreten werden. ;)