PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Samba - WinXP Netzwerk zu langsam



christo79
02.05.2006, 09:46
Hallo alle zusammen,

ich habe mir einen Debian Router zusammen gebaut. Als Filserver läuft darauf ein Samba 3. Intern sind alle Rechner mit 100Mbit 3com karten bestückt auch der Router. Beim Router handelt es sich um einen P1 166Mhz mit ca. 200MB Ram und einer 200gb und 4gb Platte. Die 200gb Platte ist mit dem Samba als Netzlaufwerk für alle Clients zugänglich.

Mein Problem ist folgendes: Ich kann die 100Mbit nicht auslasten. Die maximale Datenrate zwischen Router und Clients beträgt ca. 2,5 MB, egal ob vom Windows oder Linux Client . Kopiere ich etwas auf das Netzlaufwerk springt auch die CPU Last des Routers auf 100%. Erst dachte ich die Platten laufen im Pio Mode, ist aber nicht der Fall. Ein Benchmark mit hdparm ergab einen Durchsatz von 12MB pro Sekunde. Ich müsste also das 100Mbit Netz voll auslasten können. Am Switch und an den Karten kann es nicht liegen, da die Clients untereinander die volle Bandbreite nutzen (ca. 10MB pro s).

Mir fällt langsam nichts mehr ein!

Vielleicht hab ihr ja noch ein paar Tipps für mich.

ToxXxic|Ger
02.05.2006, 13:41
Full Duplex aktiviert? Schau mal mit ethtool nach ob Full Duplex aktiviert ist.

damager
02.05.2006, 13:52
hast du ne option protocol in deiner smb.conf definiert?
versiche es mal mit der option:

protocol = NT1

sollt als protokoll am besten für xp angepasst sein :]
das sollte vieleicht etwas die performance verbessen...IMHO.

lordlamer
02.05.2006, 14:26
Hallo,

1. nicht immer so umherhantieren mit MByte und MBit. Das ist einfach ein gewaltiger unterschied!!! Das sollte man niemals vergessen.

2. Das die CPU-Last hoch geht ist normal. Dein kleiner armer Prozessor muss ja auch die IP Pakete bilden und verschicken. Hier könnte wirklich der Prozi eine bremse sein! Wenn du also wirklich große Datenmengen schieben willst solltest du etwas aufstocken.

Mfg Frank

christo79
02.05.2006, 20:04
Hallo,

danke für eure Antworten:

@ ToxXxic

wollte das überprüfen, aber ich bekomme keine Daten zurück geliefert „No data available“. Da ich zwei 3c59 er verbaut habe, bekomme ich bei beiden Karten die gleiche Antwort. Kann man das vielleicht auch noch anders prüfen?

@damager
Ja das Protokoll ist auf NT1 eingestellt.

@lordlamer

Sorry das ich mich vertippt habe, meinte natürlich MBit/s … du wurstest aber zum Glück was ich meine.


Auch wenn ich den kleinen Kerl auslaste, das müsste er eigentlich schaffen. Ich dachte auch erst, dass eine zu blöde Anordnung der iptables daran schuld wäre, aber jetzt lasse ich gleich in der ersten Regel den internen Verkehr zu. Das Pakete zusammenbauen müsste er aber trotzdem in der Zeit schaffen.

Habe noch mal nachgeschaut mein Die Interface ist ein Intel PIIX3 und unterstützt dma 2, also max. 16MBit/s, zwar nicht mehr als Pio4 aber nicht so CPU-lastig. Jetzt musste ich aber mit verwundern feststellen, das der dma mode auf null stand. Wenn ich ihn wieder setze hält er sich für eine Zeit und setzt es sich wieder zurück auf null. Ich glaube hier ist der Hund begraben. keepsettings ist gesetzt, warum behält er das nicht?


Viele Grüße