PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Samba - Problem mit Freigabe



Neo van Matix
19.04.2006, 09:14
Hallo,
Ich habs nun hingekriegt, den Samba Server zum laufen zu kriegen, und via Windows übers Netzwerk drauf zuzugreifen.

Nun, wo das geht, wollte ich mich etwas mit den mögl. Attributen und Einstellungen befassen.

Meine Konfig sieht wie folgt aus:


[global]
workgroup = sambaserver
netbios name = sambaserver
interfaces = 192.168.1.123/255.255.255.0
encrypt passwords = yes
security = share

[Freigabeshare]
comment = Samba-Freigabe
path = /etc/samba/fileshare
browseable = yes
writeable = yes
guest ok = yes
public = yes

[Privatshare]
comment = Beschraenkter Zugriff
path = /etc/samba/privatshare
valid users = basti
writeable = yes
browseable = no


Das Freigabeshare soll ein Buffer sein, also, Lese/Schreibrechte für alle. Das funktioniert auch gut.

Nun wollte ich zu Testzwecken aber auch ein nicht-sichtbares Share für explikte User anlegen (Privatshare). Zugriff soll nur der User "basti" haben.

Wenn ich via Explorer auf das privat-Share zugreifen will, poppt ein Anmeldefenster auf. Soweit, so gut... mein Problem ist, dass ich dort keinen Usernamen eingeben kann. Es ist vordefiniert \\sambaserver\gast - das bringt mir aber natürlich nichts, ich möcht mich ja mit "basti" anmelden.

Ich dachte zuerst, es läge an "Security = share" - wenn ich das auf User setz, kann ich mich ganz normal mit Username und Passwort anmelden.
Allerdings kann dann kein Gast mehr auf das Freigabeshare (Buffer) zugreifen, und das will ich ja nicht.

Dann dachte ich, ich nehm Security = Share aus [global] raus, und mach getrennte Einstellungen für das Freigabeshare und das Privatshare.
Im Privatshare also "Security = user" und im Freigabeshare "Security = share", aber das funktioniert so auch nicht...

Wie könnt ich das den lösen?

ColaMan
09.05.2006, 20:23
security = user

und bei der ersten freigabe:

guest ok = yes

bei der zwieten

guest ok = no

vllt bringts was

MfG

Cola

allos
10.05.2006, 13:07
Nachdem ich mir nochmal in man smb.conf den Abschnitt über den parameter security durchgelesen habe, meine ich, dass beides zusammen nicht geht. Entweder machst Du security = server, dann kannst Du Dich nicht als ein bestimmter User anmelden, oder Du machst security = user, dann musst Du in jedem Fall einen Usernamen angeben (der allerdings auch auf den guest gemappt werden kann). Lies am besten mal selber...