PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Servergespeicherte Profile



sambanewbie
03.03.2006, 23:26
Hallo alle zusammen,

habe ein wahrscheinlich ganz leichtes problem.

bei der benutzeranmeldung bekomme ich die Meldung das das profilverzeichniss nicht erstellt werden kann. :hilfe2:

Hier die smb.conf

# Global parameters
[global]
workgroup = TUX
interfaces = eth0
map to guest = Bad User
username map = /etc/samba/smbusers
printcap cache time = 750
printcap name = cups
add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody -s /bin/false %m$
logon path = \\%L\profiles\.msprofile
logon drive = P:
logon home = \\%L\%U\.9xprofile
domain logons = Yes
os level = 2
preferred master = Yes
domain master = Yes
idmap uid = 10000-20000
idmap gid = 10000-20000
printer admin = @ntadmin, root, administrator
cups options = raw
include = /etc/samba/dhcp.conf

[netlogon]
comment = Network Logon Service
path = /var/lib/samba/netlogon
write list = root

[homes]
comment = Home Directories
path = /home/%u
valid users = %S
read only = No
inherit acls = Yes
browseable = No

[profiles]
comment = Network Profiles Service
path = /profiles/profiles
read only = No
create mask = 0644
store dos attributes = Yes

[users]
comment = All users
path = /home
read only = No
inherit acls = Yes
veto files = /aquota.user/groups/shares/

[groups]
comment = All groups
path = /home/groups
read only = No
inherit acls = Yes

[printers]
comment = All Printers
path = /var/tmp
create mask = 0600
printable = Yes
browseable = No

[print$]
comment = Printer Drivers
path = /var/lib/samba/drivers
write list = @ntadmin, root
force group = ntadmin
create mask = 0664
directory mask = 0775

kann mir jemand helfen?

hopfe
04.03.2006, 10:03
Hat dein Benutzer genügend "linux"-Rechte um ein Unterverzeichnis unter "/profiles/profiles" erzeugen kann. Bist du dir sicher das der Pfad stimmt, oder hast du dich beim Pfad vertippt?

sambanewbie
04.03.2006, 22:17
war wirklich ein Tippfehler. Danke

die smb.conf sieht jetzt so aus.

# Global parameters
[global]
workgroup = TUX
interfaces = eth0
map to guest = Bad User
username map = /etc/samba/smbusers
printcap cache time = 750
printcap name = cups
add machine script = /usr/sbin/useradd -c Machine -d /var/lib/nobody -s /bin/false %m$
logon path = \\%L\profiles\.msprofile
logon drive = P:
logon home = \\%L\%U\.9xprofile
domain logons = Yes
os level = 2
preferred master = Yes
domain master = Yes
idmap uid = 10000-20000
idmap gid = 10000-20000
printer admin = @ntadmin, root, administrator
cups options = raw
include = /etc/samba/dhcp.conf

[netlogon]
comment = Network Logon Service
path = /var/lib/samba/netlogon
write list = root

[homes]
comment = Home Directories
path = /home/%u
valid users = %S
read only = No
inherit acls = Yes
browseable = No

[profiles]
comment = Network Profiles Service
path = /profiles
read only = No
create mask = 0644
store dos attributes = Yes

[users]
comment = All users
path = /home
read only = No
inherit acls = Yes
veto files = /aquota.user/groups/shares/

[groups]
comment = All groups
path = /home/groups
read only = No
inherit acls = Yes

[printers]
comment = All Printers
path = /var/tmp
create mask = 0600
printable = Yes
browseable = No

[print$]
comment = Printer Drivers
path = /var/lib/samba/drivers
write list = @ntadmin, root
force group = ntadmin
create mask = 0664
directory mask = 0775

allerding s kann ich mich mit nur einem user anmelden möchte aber mehrere. :think:

:hilfe2: hilfe wäre super

aspella
05.03.2006, 00:04
du kannst dich bei windows immer nur mit einem user anmelden, nicht so wie bei linux mit mehreren! lol

welche linux rechte hat den dein profil ordner? du solltest schon schreibrechte für die benutzer haben sonst kann ja kein profil erstellt werden.

sambanewbie
05.03.2006, 07:50
das ist mir schon klar das ich unter windows nicht mit mehreren usern gleichzeitig arbeiten kann. so war es auch nicht gemeint. da es ein pdc ist sollen sich mehrere user der domain zu unterschiedlichen Zeitpunkten von einem Rechner mit ihrem eigenen login anmelden können. und das klappt nicht sondern nur ein user kann sich anmelden.
hat es etwas damit zu tun das der besitzer des ordners .msprofiles mein angemeldeteter testuser ist? wenn ja wie ändere ich das? die Rechte auf den Ordner /profiles in dem der ordner liegt sind auf 777 gesetzt.

Habe das Problem selbst gelöst danke an alle.
Fehler lag hier:
logon path = \\%L\profiles\.msprofile
es muss heißen
logon path = \\%L\profiles\%u
:D :D :D :D :D :D