PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : loginproblem mit vsftp



Yonathan
22.01.2006, 23:10
hallo

ich habe nach etlichen howtos, faqs, mans und was nicht alles versucht zugriff vermittels ftp auf meinen rechner zu bekommen, sowohl über den localhost als auch über eine dyndns adresse, aber die passwörter werden einfach nicht akzeptiert.
hier mal meine vsftpd.conf

background=YES
listen=YES
anonymous_enable=NO
local_enable=YES
write_enable=YES
hide_ids=YES
pasv_min_port=50000
pasv_max_port=60000
dirmessage_enable=YES
connect_from_port_20=YES
xferlog_enable=YES
xferlog_std_format=YES
xferlog_file=/var/log/vsftpd.log
data_connection_timeout=300
idle_session_timeout=300
accept_timeout=60
connect_timeout=60
nopriv_user=nobody
async_abor_enable=YES
ascii_upload_enable=YES
ascii_download_enable=NO
ftpd_banner=Welcome to randirs FTP service.
ftp_username=ftp
ls_recurse_enable=NO
chmod_enable=YES
userlist_deny=NO
userlist_enable=YES
userlist_file=/etc/vsftpd/user_list
chroot_local_user=YES
chroot_list_enable=YES
chroot_list_file=/etc/vsftpd/chroot_list


user_list:

ftp
mirco

chroot_list:

mirco

/etc/xinet.d/vsftp schaut folgendermaßen aus:

# vsftpd is the secure FTP server.
service ftp
{
disable = no
socket_type = stream
wait = no
user = root
server = /usr/sbin/vsftpd
per_source = 5
instances = 200
no_access = 192.168.1.3
banner_fail = /etc/vsftpd/vsftpd.busy_banner
log_on_success += PID HOST DURATION
log_on_failure += HOST
}


/etc/passwd für diese beiden user:

ftp:x:500:100::/storage/ftp:/bin/false
mirco:x:1000:100::/home/mirco:/bin/bash

egal was ich mache, ob
ftp localhost
oder ftp randir.homelinux.org
jedesmal erhalte ich nach eingabe des passwortes:

ftp randir.homelinux.org
Connected to randir.homelinux.org.
220 Welcome to randirs FTP service.
Name (randir.homelinux.org:mirco): mirco
530 Please login with USER and PASS.
SSL not available
331 Please specify the password.
Password:
530 Login incorrect.
Login failed.
ftp> exit
221 Goodbye.


ich weiß net mehr weiter... hat irgendwer eine idee?

yona