PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Options werden immer überschrieben



ClixMaster
12.01.2006, 09:44
Nicht nur hier im Forum bin ich Newbee, sondern auch in Sachen Apache2, das auf meinem vServer unter SuseLinux9.3 und neben Confixx Premium Edition 1.0.4 läuft. Man möge mir also meine vielleicht laienhaften Fragen bitte etwas nachsehen :help:

1. Frage:
Da ich mit mod_rewrite per htaccess arbeite, habe ich in der confixx_vhost.conf
<Directory "/srv/www">
<Files ~ "^\.ht">
deny from all
</Files>
AllowOverride None
AllowOverride Indexes AuthConfig Limit FileInfo
Options None
Options +FollowSymLinks +SymLinksIfOwnerMatch +Includes
</Directory>
eingefügt. Das funktioniert auch, jedoch werden die Options von Zeit zu Zeit vom Server selbst mit
Options -FollowSymLinks -SymLinksIfOwnerMatch +Includesüberschrieben, was dann immer einen 403 verursacht. Wo kann ich die Ursache für das Überschreiben suchen?

2. Frage
Auf meinem Server ist der safe_mode standardmäßig OFF. Für einzelne Domans soll er aber ON gesetzt werden, habe deshalb versucht, die Option in der confixx_vhost.conf mit
php_value safe_mode Onspeziell im vhost-Abschnitt der Domain anzugeben. Habe auch
php_flag safe_mode Onversucht. Funktioniert aber beides nicht. Webserver wurde natürlich neu gestartet. Was mache ich falsch?

Mario

wired
12.01.2006, 11:55
Hallo,

was das überschreiben angeht. Also soweit ich weiß, überschreibt SuSE, bzw. Yast die Standardkonfig.-Files gerne und änderungen werden in zusätzlichen Konfig.-Files gespeichert. Deswegen reden auch immer "alle" von so einem verwindowsten OS. ;) Daher muss man änderungen im Idealfall über das entsprechende Konfig.-Tool machen, sofern vorhanden.
Bin mir aber nicht sicher in wieweit das auch auf Apache unter SuSE 9.3 zutrifft.