PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : CUPS - Probleme beim Drucken über Windows



aydin
03.01.2006, 16:25
Hallo Leute,

ich habe folgendes Problem.

Ich habe 4 Drucker auf CUPS angelegt. Die Drucker können auf Windows-Rechnern installiert werden, jedoch bekomme ich beim Ausdruck die Fehlermeldung: "Zugriff verweigert".

Meine smb.conf ist so konfiguriert:


[global]
...
printcap name = cups
printer admin = operator, Administrator
use client driver = no
disable spoolss = No
printing = cups
print command = lpr -o media=a4 -P%p %s;
...
[printers]
comment = alle Drucker
path = /var/spool/samba
printer admin = operator, Administrator
#create mask = 0777
#force create mode = 0777
# guest only = Yes
guest ok = Yes
writeable = no
printable = Yes
browseable = No
# public = yes


Mit testparm wird folgendes ausgespuckt:


[root@intra1 /]# testparm
Load smb config files from /etc/samba/smb.conf
WARNING: The "printer admin" option is deprecated
Processing section "[home]"
Processing section "[profile]"
Processing section "[profileTS]"
Processing section "[netlogon]"
Processing section "[printers]"
WARNING: The "printer admin" option is deprecated
Processing section "[tools]"
Loaded services file OK.
WARNING: passdb expand explicit = yes is deprecated
Server role: ROLE_DOMAIN_PDC


Ein ls -l /var/spool gibt folgendes aus:
drwx--x--- 3 root sys 4096 Jan 3 15:58 cups

Was mache ich eigentlich falsch????

ProxYa
03.01.2006, 20:05
Wenn du über CUPS druckst, dann hat das nichts mit Samba zu tun!
Wie genau bindest du die Drucker über Windows ein?

Greets, ich

aydin
03.01.2006, 20:59
Ich binde die Drucker folgendermassen ein:
1. Start - ausführen - \\Servername
2. Drucker auswählen: Rechte Maustaste - Drucker verbinden - das funktioniert ja
3. Allerdings, wenn ich z.B. eine Testseite ausdrucken möchte, bekomme ich die Meldung: "Die Testseite konnte nicht gedruckt werden. Soll die Druckproblembehandlung angezeigt werden? Zugriff verweigert".
4. Wenn ich die Sicherheitseinstellungen des Druckers mir anschaue, ist "Jeder" berechtigt zu drucken.

ProxYa
04.01.2006, 01:34
Wenn du das so machst, gehst du tatsächlich über Samba, dann hat es logischerweise nix mehr mit Cups direkt zu tun!

Was mir glaube ich geholfen hat ist folgende Zeile in [printers]-Abschnitt:


write list = proxya

Ansonsten: Hast du schon mit

cupsaddsmb -a
die Drucker an Samba übergeben

Greets, ich

aydin
04.01.2006, 17:39
Danke für die Info.

Habe das Problem anders gelöst. Habe im LDAP die Benutzer als Druckeroperatoren aufgenommen und die Berechtigung für die Ordner /var/spool/samba und /var/spool/cups geändert.

Seitdem funktioniert das Drucken wieder.