PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Apache2+PHP5+LDAP+SSL



ProxYa
01.01.2006, 14:30
Hi!

Genau das sind die Komponenten, die ich für eine Seite benötige!

UNter Windows und einer XAMPP installatiopn funktioniert das ganze auch wunderbar...
Bei dem Teil mit LDAP hab ich allerdings ein Problem auf meinem Linux-Server:

Anfangs wurde schon der Befehl

ldap_connect(LDAP_SERVER)
nicht ausgeführt, aber das lag grundlegenderweise daran, das ldap noch nicht installiert war. Das hab ich jetzt über apt-get nachgeholt.
allerdings verlagert sich das Problem nur nach hinten, denn jetzt stoppt das Script bei dem Aufruf
ldap_start_tls($this->connection);

Allerdings meine ich mittlerweile alles konfiguriert und installiert zu haben!
Mit
phpinfo() bekomme ich:


PHP Version 5.0.5-3
System Linux Alpha 2.6.8-2-386 #1 Thu May 19 17:40:50 JST 2005 i586
...
LDAP Support enabled
RCS Version $Id: ldap.c,v 1.154.2.7 2005/07/09 01:00:11 sniper Exp $
...
OpenSSL support enabled
OpenSSL Version OpenSSL 0.9.8a 11 Oct 2005
...


Hat da jemand eine Idee, die mich weiterbringen könnte?

Vielen Dank im Voraus

Greets, ich

thorus
01.01.2006, 16:06
Kommt wenigstens ne sinnvolle Fehlermeldung?

ProxYa
01.01.2006, 16:15
Sorry:
Klar kommt die!

Fatal error: Call to undefined function ldap_start_tls() in /var/www/re/include/ldap.php on line 27

Die Funktion wird also einfach nicht gefunden.

Sie ist aber laut allem was ich gefunden habe ab PHP-Ver. 4.2.x enthalten

Greets, ich

sono
01.01.2006, 17:24
Da su apt verwendest hast du vermutlich debian oder Ubuntu .

Es gibt für Debian / Ubuntu das Packet php5-ldap .

Hast du das auch installiert ?

Gruß Sono

ProxYa
02.01.2006, 12:08
Abhängigkeitsbaum wird aufgebaut... Fertig
php5-ldap ist schon die neueste Versio


Ja, ist installiert

Danke für die antwort

Greets, ich