PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Apache 2 lässt sich nicht mehr starten



brahma
28.12.2005, 11:48
Mein Webserver (SuSE 9.0) hat sich in der Nacht vom 23. auf den 24. verabschiedet, es lief morgens nichts mehr, weder der mailserver, der apache, noch der BNC oder der Eggdrop die eigentlich alle 10 min per cron getestet und neu gestartet werden. nach einem reboot lief soweit alles wieder normal, nur der Apache will nicht mehr starten, Fehlermeldung:


h46675:/etc # ./init.d/apache start
Starting httpd [ Python ]

Syntax error on line 113 of /etc/apache2/server-tuning.conf:
Invalid command 'BrowserMatch', perhaps mis-spelled or defined by a module not included in the server configuration failed
h46675:/etc #

Die betreffenden Zeilen sind:


#
# The following directives modify normal HTTP response behavior to
# handle known problems with browser implementations.
#
BrowserMatch "Mozilla/2" nokeepalive
BrowserMatch "MSIE 4\.0b2;" nokeepalive downgrade-1.0 force-response-1.0
BrowserMatch "RealPlayer 4\.0" force-response-1.0
BrowserMatch "Java/1\.0" force-response-1.0
BrowserMatch "JDK/1\.0" force-response-1.0

#
# The following directive disables redirects on non-GET requests for
# a directory that does not include the trailing slash. This fixes a
# problem with Microsoft WebFolders which does not appropriately handle
# redirects for folders with DAV methods.
# Same deal with Apple's DAV filesystem and Gnome VFS support for DAV.
#
BrowserMatch "Microsoft Data Access Internet Publishing Provider" redirect-carefully
BrowserMatch "^WebDrive" redirect-carefully
BrowserMatch "^WebDAVFS/1.[012]" redirect-carefully
BrowserMatch "^gnome-vfs" redirect-carefully

wobei Zeile 113 natürlich die erste ist.

Google sagte mir als Lösungsvorschlag nur "updaten", laut Yast und You gibt es aber keine updates dafür.

Jemand nen Vorschlag was zu tun ist?

ragnar
28.12.2005, 14:20
auf den ersten blick stimmt alles. kommentier mal die sachen erstmal aus um zu überprüfen ob der indianer überhapt richtig "tickt". wenn dem so ist dann kannst du dann so nach und nach den fehler einkreisen.

brahma
28.12.2005, 15:18
Also wenn ich das auskommentier, bekomm ich ne andere Fehlermeldung, komm nur leider net ran weil der Proxy bei der Arbeit nix ausser 8080 zulässt.... :(

Wolfgang
28.12.2005, 16:22
Hallo
Hast du die Datei seit dem letzten erfolgreichen Start editiert?
Kann es sein, dass die Datei oder eine weitere includete sogar leidliche Wintendow CRLF enthält?
-> unter einem M$ editiert und nicht bereinigt?
Sowas ist unsichtbar, aber manche Unix-apps kommen damit nicht klar.

Die richtige Syntax kannst du mit der Option -t testen.

Gruß Wolfgang

brahma
28.12.2005, 16:49
Das werde ich nachher mal machen, aber editiert hab ich da eigentlich nix, wie gesagt, bin abends zu hause abgehauen, da lief noch alles, als ich morgens meinen rechner wieder gestartet hatte lief ausser der hardware nix mehr, erst ein reboot über das webinterface von strato brachte den rechner wieder in fast normalen zustand.

dmaphy
28.12.2005, 21:36
kommst du nicht an die logfiles vom indianer? ich würd die error_log doch ganz gerne mal sehn...

brahma
29.12.2005, 09:40
So, bin gestern abend nicht mehr dazu gekommen mich darum zu kümmern. An die logfiles komm ich ran ja, guck da gleich mal rein.

Strato konnte mir nicht weiterhelfen, die haben mir nu einen link zur apache-seite gegeben wo "browsermatch" angejündigt würde bei version 2.0.51, was mir natürlich nicht wirklich weiterhilft, also muss ich nachher selber ran :D

---------

So, nu gehts:

Also, wenn ich den Apachen mit "apache start -t" starten will kommt die gleiche fehlermeldung.

Im error_log steht folgendes:

[Sat Dec 24 10:07:01 2005] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
[Sat Dec 24 10:07:01 2005] [warn] RSA server certificate CommonName (CN) `www.visas.de' does NOT match server name!?
[Sat Dec 24 10:07:01 2005] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
[Sat Dec 24 10:07:04 2005] [warn] RSA server certificate CommonName (CN) `www.visas.de' does NOT match server name!?
[Sat Dec 24 10:07:07 2005] [notice] Apache/2.0.48 (Linux/SuSE) configured -- resuming normal operations
[Sat Dec 24 10:20:27 2005] [notice] caught SIGTERM, shutting down
[Sat Dec 24 10:22:22 2005] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
[Sat Dec 24 10:22:22 2005] [warn] RSA server certificate CommonName (CN) `www.visas.de' does NOT match server name!?
[Sat Dec 24 10:22:22 2005] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
[Sat Dec 24 10:22:23 2005] [warn] RSA server certificate CommonName (CN) `www.visas.de' does NOT match server name!?
[Sat Dec 24 10:22:25 2005] [notice] Apache/2.0.48 (Linux/SuSE) configured -- resuming normal operations
[Sat Dec 24 12:46:36 2005] [warn] child process 1144 still did not exit, sending a SIGTERM
[Sat Dec 24 12:46:36 2005] [warn] child process 1145 still did not exit, sending a SIGTERM
[Sat Dec 24 12:46:36 2005] [warn] child process 1146 still did not exit, sending a SIGTERM
[Sat Dec 24 12:46:36 2005] [warn] child process 1147 still did not exit, sending a SIGTERM
[Sat Dec 24 12:46:36 2005] [warn] child process 1148 still did not exit, sending a SIGTERM
[Sat Dec 24 12:46:36 2005] [notice] caught SIGTERM, shutting down
[Sat Dec 24 12:48:32 2005] [warn] Init: Session Cache is not configured [hint: SSLSessionCache]
[Sat Dec 24 12:48:32 2005] [warn] RSA server certificate CommonName (CN) `www.visas.de' does NOT match server name!?
[Sat Dec 24 12:48:32 2005] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec2)
[Sat Dec 24 12:48:33 2005] [warn] RSA server certificate CommonName (CN) `www.visas.de' does NOT match server name!?
[Sat Dec 24 12:48:35 2005] [notice] Apache/2.0.48 (Linux/SuSE) configured -- resuming normal operations

der letzte eintrag im access_log ist:

[23/Dec/2005:23:43:51 +0100] "GET /robots.txt HTTP/1.0" 404 1054 "-" "TheSuBot/0.1 (www.thesubot.de)"

dmaphy
29.12.2005, 21:04
wenn das dein error_log ist, sollte der apache aber jetzt wenigstens laufen? oO
das mit den zertifikaten ist ein anderes problem, das musst du irgendwie mal neu generieren, oder der rechnername stimmt nicht mehr o.O

brahma
29.12.2005, 21:20
Nö, der läuft immer noch net, und unter /var/log/apache2/error_log kommt auch kein neuer Eintrag dazu, das da oben ist alles was da drin steht.

Wolfgang
29.12.2005, 22:01
Hallo
Was lädst du denn für Module?
Stimmen die Pfade überhaupt
apache2 -E filename =>erstellt ein Error start file
Im normalen Logfile kann nix stehen, da er ja nicht startet.
Über welches Script startest du den denn?

Gruß Wolfgang

brahma
29.12.2005, 22:48
Also normalerweise starte ich den mit "./etc./init.d/apache start"

die module die geladen werden stehen in "/etc/apache2/modules" oder? Dann sinds nur "mod_python" und "public_html"

dmaphy
29.12.2005, 23:38
auf suse würde ich den apache2 mit


rcapache2 start


starten. irgendwo muss der ein aktuelles error_log ablegen, wenn er das nicht macht musst du es eben erzwingen wie wolfgang es geschrieben hat^^

brahma
29.12.2005, 23:45
Aha, da gibts auch schon ne andere Meldung:


h46675:/usr/sbin # rcapache2 start
Starting httpd2 (prefork) httpd2-prefork: Syntax error on line 110 of /etc/apache2/httpd.conf: Syntax error on line 22 of /etc/apache2/sysconfig.d/loadmodule.conf: API module structure `suphp_module' in file /usr/lib/apache2/mod_suphp.so is garbled - perhaps this is not an Apache module DSO?

The command line was:
/usr/sbin/httpd2-prefork -f /etc/apache2/httpd.conf
failed

dmaphy
30.12.2005, 18:26
dann zeig doch bitte mal zeile 110 der httpd.conf und zeile 22 der loadmodule.conf
dir muss man ja alles aus der nase ziehen :D dass du das gleich mal postest da hätteste auch mal selber drauf kommen können ;)

brahma
30.12.2005, 22:38
Jo, ruhig an, wollte erstmal selber sehen (lerneffekt), aber irgendwann ging bei mir gestern garnix mehr, rechenr aus -> pennen 8)

So, httpd.conf:

109 # generated from APACHE_MODULES in /etc/sysconfig/apache2
110 Include /etc/apache2/sysconfig.d/loadmodule.conf

/etc/apache2/sysconfig.d/loadmodule.conf:

21 LoadModule suexec_module /usr/lib/apache2-prefork/mod_suexec.so
22 LoadModule suphp_module /usr/lib/apache2/mod_suphp.so
23 LoadModule php4_module /usr/lib/apache2-prefork/libphp4.so

die Datei "/usr/lib/apache2/mod_suphp.so" existiert aber....

Nachtrag:
das die einzige Datei in dem Verzeichnis die nicht aktuell ist:

-rwxr-xr-x 1 root root 7790 Dec 15 13:42 mod_suexec.so
-rwxr-xr-x 1 root root 34171 May 11 2004 mod_suphp.so
-rwxr-xr-x 1 root root 9706 Dec 15 13:42 mod_unique_id.so

dmaphy
31.12.2005, 02:32
hast du irgendwie ein update im system gemacht?
ich kann mir nur vorstellen, dass es mit einem update zusammenhängen könnte oO

die einfachste lösung des problems ist es, wenn du in der loadmodule.conf vor die zeile 22 erstmal ein # schreibst und das abspeicherst, das mod_suphp braucht man eh in selteneren fällen, also würde es evtl. nix machen, wenn du es nicht hast. (:

du könntest nochmal im yast online update schauen ob für das mod_suphp evtl. eine aktuellere version vorhanden ist..

damager
31.12.2005, 11:08
hmmm...HIER (http://www.serversupportforum.de/forum/perl-php-python-bash/4862-installation-von-suphp-0-5-2-a.html) hat bei strato einer ein ähnliches problem. evtl. hilft dir das neuinstallieren von suphp weiter. scheint ja am modul selber zu liegen.

brahma
31.12.2005, 13:24
Hm, schonmal danke für den link, aber auch das klappt so net:


./configure --with-apxs=/usr/sbin/apxs2 --prefix=/usr/local --with-logfile=/var/log/apache2/suphp_log

liefert:

checking for a BSD-compatible install... /usr/bin/install -c
checking for dynamic Apache module support (via APXS)... apxs:Error: /usr/bin/apu-1-config not found!.
apxs:Error: /usr/bin/apu-1-config not found!.
found at /usr/sbin/apxs2 (version 2.2.0)
checking for set-UID/set-GID mode... ok - using owner

und bei make kommt dann logischerweise:

h46675:~/suphp-0.5.2 # make
make[1]: Entering directory `/root/suphp-0.5.2/src'
*** INFO: Building mod_suphp for Apache 1.3 ***
make[2]: Entering directory `/root/suphp-0.5.2/src/apache'
/usr/sbin/apxs2 -c -DHAVE_CONFIG_H -DPATH_TO_SUPHP=\\\"/usr/local/sbin/suphp\\\" -I../../src -Wc,"-g -O2" mod_suphp.c
apxs:Error: /usr/bin/apu-1-config not found!.
make[2]: *** [suphp.mod] Error 1
make[2]: Leaving directory `/root/suphp-0.5.2/src/apache'
make[1]: *** [suphp.mod] Error 2
make[1]: Leaving directory `/root/suphp-0.5.2/src'
make: *** [all] Error 2

*EDIT*
So, hatte gestern keinen Bock mehr, habn Backup gemacht und neu installiert....