PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Apache - Virtual Hosts?



tessen
25.11.2005, 11:13
Ich möchte einen Apache richtig aufsetzen. Momentan habe ich SUSE 9.3 und
unter meiner "192.x.x.x:80" bzw. "192.x.x.x:81" sind zwei meiner Seiten im
eigenen Netz erreichbar, doch dies ist nicht sinnvoll, weil ich will doch eine
einfachere Bezeichnung haben! Sowas wie "test.de" soll auf eine Seite führen.

Kann mir jemand helfen?

unter /srv/www/htdocs habe ich die Verzeichnisse der Seiten samt index.html
/test.de
/seite.de
/sport.de

in der listen.conf steht
Listen 80
Listen 81

NameVirtualHost *:80
NameVirtualHost *:81

und unter /etc/apache2/vhost.d
gibt es nun eine test.conf

<VirtualHost *:80>
....
DocumentRoot /srv/www/htdocs/test.de
....
</VirtualHost>

und die zweite .conf ist auch so geschrieben.

Kann mir jemand helfen
Tessen

sono
25.11.2005, 12:01
Erstelle ne 2te Datei in dem Ordner /etc/apache2/sites-enabled/deinedatei.inc

Inhalt der Datei sollte dann ungefähr so aussehen



<VirtualHost *>
ServerAdmin support@music-provider.de
ServerName music-provider.de
DocumentRoot /var/www/music-provider.de
</VirtualHost>

Nur mit deinen Daten halt.

Mehr dazu gibts bei apache.org in den Dokus . http://httpd.apache.org

Kann sein dass wenn du Suse hast , du diesen Eintrag auch einfach ans ende deiner apache Confdatei setzen muss, Unter Debian gehts so.

Gruß Sono

tessen
25.11.2005, 12:42
Hmm, das verstehe ich noch nicht ganz.
Also ich will doch mehrere Webseiten ansprechen und deshalb habe ich die momentan durch die verschiedene Ports angesprochen

test.conf

<VirtualHost *.80>
Servername MeinRechner
DocumentRoot /srv/www/htdocs/test.de/
ServerAdmin name@gmx.de
</VirtualHost>

sport.conf

<VirtualHost *.81>
Servername MeinRechner
DocumentRoot /srv/www/htdocs/sport.de/
ServerAdmin name@gmx.de
</VirtualHost>

Bei Suse 9.3 werden die .conf-Dateien aus /etc/apache2/vhost.d/
in die httpd.conf included und stellen daher die
/etc/apache2/sites-enabled/deinedatei.inc von Debian dar oder?

Wie kann ich eine Seite im Browser mit sport.de aufrufen und die andere mit test.de????

Ich weiß nicht weiter
Tessen

dmaphy
25.11.2005, 20:59
<VirtualHost *>
ServerName test.de
DocumentRoot /srv/www/htdocs/test.de/
ServerAdmin name@gmx.de
</VirtualHost>

<VirtualHost *>
Servername sport.de
DocumentRoot /srv/www/htdocs/sport.de/
ServerAdmin name@gmx.de
</VirtualHost>


wenn das dann immernoch nicht geht, solltest du die /etc/hosts auf jedem rechner in deinem netz bearbeiten oder einen nameserver aufsetzen...

tessen
01.12.2005, 13:43
@all Danke für die Hinweise!!!

Erstmal habe ich mehrere IPs für meine Netzwerkkarte angelegt.


ifconfig eth1:31 192.xxx.xxx.31 netmask 255.255.255.0 up
ifconfig eth1:32 192.xxx.xxx.32 netmask 255.255.255.0 up

Dann habe ich diese NameVirtualHosts in die 'listen.conf' eingetragen


NameVirtualHost 192.xxx.xxx.31
NameVirtualHost 192.xxx.xxx.32

desweiteren in der 'httpd.conf'


<VirtualHost 192.xxx.xxx.31>
Servername www.test.test
DocumentRoot /srv/www/htdocs/test.de/
ServerAdmin name@gmx.de
</VirtualHost>

In /etc/hosts habe ich folgendes geschrieben


192.xxx.xxx.xxx pc1.site pc1

#Virtual Hosts

192.xxx.xxx.31 www.test.test.site www.test.test
192.xxx.xxx.32 www.sport.test.site www.sport.test


ping auf www.test.test war erfolgreich
Das Problem ist gelöst!

wish a happy day