PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Problem bei ausführen von Javaprogramm in eclipse



munuel
24.08.2005, 02:19
hallo ich hab folgendes Problem:

Ich bin neu unter debian und möchte dort mit ecllipse programmieren.
Ich habe mir mit apt-get eine Javaversion installiert!
Und eclipse, dieser lässt sich auch starten, ginge ja ohne Java auch nicht!
Beim ausführen eines Javaprogrammes bekomme ich nun folgende Fehlermeldung:

>Specified VM install not found: type Standard VM, name jdk15002<

das heisst die VM ist nicht installiert worden oder liegt nicht am richtigen Ort, denke ich!
weiss einer wo sie normal liegen sollte bzw. wo sie liegt wenn ich sie mit apt-get installiert habe,
vielleicht sucht der eclipse am falschen Ort oder sie wurde nicht installiert.

oder es liegt an was ganz anderem!

Vielleicht jemand ne Idee :hilfe2:
Viele grüsse munuel

bytepool
23.01.2006, 01:11
hi,
die Frage ist zwar schon ziemlich alt, aber der Vollstaendigkeit halber antworte ich trotzdem mal ;)
In eclipse 3.1 findest du unter

window-->preferences-->java-->installed jre's

eine liste der in eclipse bekannten jre's (ich meine in eclipse 3.0 war das aehnlich). D.h. wenn du z.b. so wie ich ein jre unter /opt/java/jre liegen hast, kannst du das dort einfach mit add... hinzufuegen, und dann nur noch das haekchen richtig setzen ;)

edit:
ich seh grad, das ich deine frage gar nicht wirklich beantwortet hab... :/
Wo genau apt-get den kram hinschreibt weiss ich so auf anhieb auch nicht, ich installiere meinen ganzen java kram immer ueber die sun packages, nicht mit apt-get...
Andererseits wird bei eclipse eigentlich auch immer ein jre mitgeliefert, und im eclipse ordner installiert um eclipse zu starten. Deswegen ist die fehlermeldung schon etwas komisch.
mfg,
bytepool