PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Nexuiz lässt sich nicht starten



redlabour
12.07.2005, 23:57
Habe heute AA, Cube und einiges anders von Hand installiert.

Nur Nexuiz lässt sich nicht starten. Habe alle Files durch die für GNU/Linux vorhanden sind. Immer das gleiche Ergebniss.


redlabour@ubuntu:~/nexuiz$ sh nexuiz-linux-x86-sdl
nexuiz-linux-x86-sdl: nexuiz-linux-x86-sdl: cannot execute binary file


Hat wer eine Idee ?

sono
13.07.2005, 02:33
hab dasselbe Problem.

Dachte schon ich wäre zu doof , aber wenn das bei dir auch so ist dann bin ich beruhigt .

redlabour
13.07.2005, 09:53
Danke geht mir nun genauso. ;)

Hatte das Problem sogar ähnlich vor dem 1.1 Patch unter Windows. Unter Linux allerdings auch mit 1.1.

Zero
13.07.2005, 11:18
chmod +x nexuiz-linux-x86-sdl
./nexuiz-linux-x86-sdl

ansonsten kannst du ja noch die glx version testen.

sono
13.07.2005, 20:02
Oh man wenns das war dann stell ich mich jetzt 5 minuten zum schämen vor die ecke.

redlabour
14.07.2005, 00:28
chmod +x nexuiz-linux-x86-sdl
./nexuiz-linux-x86-sdl

ansonsten kannst du ja noch die glx version testen.


redlabour@ubuntu:~/nexuiz$ chmod +x nexuiz-linux-x86-glx
redlabour@ubuntu:~/nexuiz$ sh nexuiz-linux-x86-glx
nexuiz-linux-x86-glx: nexuiz-linux-x86-glx: cannot execute binary file
redlabour@ubuntu:~/nexuiz$



Kein Erfolg ! @Sono - so blöde sind wir doch nicht. ;)

redlabour@ubuntu:~/nexuiz$ ./nexuiz-linux-x86-sdl :s

UND ES FUNZT ! :D

Die GLX Version ist buggy und liefert mit OSS stotternden Sound. Die SDL nutzt ALSA und funzt einwandfrei bei mir. ;)

BTW - das Icon unter KDE funzt aber immer noch nicht.

Muss ich das ändern ?

Befehl : nexuiz-linux-x86-sdl :s
Arbeitsordner : /home/redlabour/nexuiz und /home/redlabour funzen nicht.

Zero
14.07.2005, 08:47
versuch den Befehl mit dem kompletten Pfad anzugeben,
also anstatt nur "nexuiz-linux-x86-sdl", die wahrscheinlich in /usr/local/bin oder /usr/bin
liegt, mal "/pfad/zu/nexuiz/nexuiz-linux-x86-sdl" wenn das so nicht klappt, müsste es noch
eine Möglichkeit geben den Link im Terminal auszuführen, irgendeine checkbox müsste
bei den Eigenschaften des Links existieren.

Viele Links Funktionieren nur, wenn man sie im Terminal ausführt.


Ach und:


Original geschrieben von Zero
chmod +x nexuiz-linux-x86-sdl
./nexuiz-linux-x86-sdl

ansonsten kannst du ja noch die glx version testen.




redlabour@ubuntu:~/nexuiz$ chmod +x nexuiz-linux-x86-glx
redlabour@ubuntu:~/nexuiz$ sh nexuiz-linux-x86-glx
nexuiz-linux-x86-glx: nexuiz-linux-x86-glx: cannot execute binary file
redlabour@ubuntu:~/nexuiz$


Was fällt dir auf?

Genau, ich schrieb "./nexuiz-linux-x86-sdl" und nicht "sh nexuiz-linux-x86-sdl"
Das hat einen Unterschied und der ist, weil man mit sh keine binarys ausführen kann.
"sh" dient dazu scripts auszuführen und keine binarys. Mit den *run files funktioniert "sh"
nur, weil der erste Teil aus einem script besteht, der wiederrum eine gepackte binary
aufruft.

redlabour
14.07.2005, 09:34
Hat sich erledigt. Ich sehe nicht ein meine Zeit unter Linux zu verschwenden wenn ich Nexuiz unter Windows nur entpacke und die *.exe doppelklicken muss damit es läuft.