PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : et-linux-2.60.x86.run lässt sich nicht installieren



redlabour
12.07.2005, 23:39
Hi,

habe jetzt schon 3* von diversen Quellen Enemy Territory gesaugt.

Jedesmal beim Start des Skriptes jedoch :


redlabour@ubuntu:/media/win_d/Downloads/Linux$ sh et-linux-2.60.x86.run
Verifying archive integrity...Error in MD5 checksums: 513e80e087457b655f29a3c406e04f5c is different from b8b59bc515d86cc845fb52f5d2c14423

Nicht wundern - auf win_d liegt es derzeit weil ich beim letzten Mal unter Ubuntu es mit GetRight! unter Win gesaugt habe.

Wie kann ich diese Prüfung denn umgehen ? Das File stimmt garantiert ausser die 3 grössten Fileprovider für ET haben alle einen Hau. ;)

Mit AA klappt es übrigens problemlos :


redlabour@ubuntu:/media/win_d/Downloads/Linux$ sh armyops230_linux.run
Verifying archive integrity... All good.
Uncompressing ArmyOps 2.3.0 for GNU/Linux.....
Second stage unpacker running...
Starting actual installer...

Zero
13.07.2005, 11:25
versuche es von einer Linux Partition zu starten.

Ich weiß es nicht, ob es bei WinXP immer noch so ist, allerdings hatte Windows früher
das verlange *run Datein im falschen Modus runterzuladen, wodurch viele Dateien
unbrauchbar wurden. Seltsamerweiße wurde es nicht bei allen Daten so gemacht.
Damals gab es auch noch Probleme, wenn man ne Linux ISO über Windows ziehen
wollte.

Ansonsten zieh es unter linux runter und starte es von da aus.

redlabour
13.07.2005, 18:22
Sagte ja - das war der 3´te Versuch. Die wget Versuche sind ja auch alle gescheitert !

Factory
13.07.2005, 18:50
Sagte ja - das war der 3´te Versuch. Die wget Versuche sind ja auch alle gescheitert !
Ja momentan is der wurm drine selbst bei der AAO version waren einige drine wo dann so ein error kamm und das sogar bei windows !

redlabour
13.07.2005, 19:53
Keiner eine Idee ob man mit einem Zusatzbefehl die Checksum Prüfung umgehen kann ?

Muss ja nicht zwangsläufig heissen das das File defekt ist.

Zero
13.07.2005, 20:31
Ich kann mich eigentlich nicht erinnern, dass es diese Option gibt.
Das sind hier soweit ich weiß alle Parameter für ne *run Datei.

[options] [--] [additional arguments to embedded script]
with following options (in that order)
--confirm Ask before running embedded script
--noexec Do not run embedded script
--keep Do not erase target directory after running
the embedded script
--nox11 Do not spawn an xterm
--nochown Do not give the extracted files to the current user
--target NewDirectory Extract in NewDirectory
--tar arg1 [arg2 ...] Access the contents of the archive through the tar command

sono
13.07.2005, 20:41
--noexec Do not run embedded script

wie wäre es damit , vielleicht is es ja ein script dass die checksum prüft .

Kann man Rundateien nicht einfach entpacken ? Das ist doch nichts anderes als ein ausführbares archiev.

Das mit dem tar sah auch interessant aus.

Zero
13.07.2005, 21:05
--noexec überprüft ja trotzdem die checksum.

Die einzige Möglichkeit wäre es wirklich mit tar zu machen,
allerdings müsste man dann die Files selbst per hand kopieren:

z.B.:
dateiname.run --tar xvf

redlabour
13.07.2005, 21:24
Na danke dann starte ich lieber Win und spiele es da. ;)

Fusselbär
13.07.2005, 22:26
Hallo,

zufälligerweise habe ich gestern gerade Enemy Territory
völlig problemlos installiert, mit portupgrade auf FreeBSD.

Aber das ist die ganz normale Linux ET Version.
(Linux Kompatibilität ist eingeschaltet)

Die Quellen der Ports für FreBSD müssten
sich doch auch für Linux nutzen lassen.. :think:

Auf Freshports.org (http://www.freshports.org/games/linux-enemyterritory/) nach den master sites gucken,
dort kann man das downloaden (oder fetchen). :devil:
Das Ports System macht dann immer erst einen md5 Check,
da war gestern alles in Ordnung.

Mir ist aber auch schon aufgefallen,
das es wohl ungünstig ist, z. B. eine gepackte Source Datei
auf eine FAT Partition zu entpacken,
danach konnte ich nicht mehr configure,
(g)make und (g)make install damit machen.
Da fehlt wohl die Unixoide Rechteverwaltung. :think:
Glaube auch md5 ging darauf schief, bin mir aber nicht mehr ganz sicher.
Solange es noch ein gepacktes Archiv ist ging es aber,
nur bevor man etwas damit macht besser auf eine native Unix Partition kopieren,
wenn es schon unbedingt auf eine FAT Partition gefetcht werden muß.
So eine *.run Datei würde ich auch sicherheitshalber
auch direkt auf eine native Unixpartition fetchen. ;)

Wenn ET dann läuft, kann mich ja mal jemand darin einweisen,
kanns zwar installieren, es läuft auch prima,
bin aber irgendwie zu blöd es zu spielen, wie ich leider merken mußte. :D

Update:
So, hab es gerade mal mit einem Suse Linux 9.3 ausprobiert,
ging wunderbar, ganz einfach, keine Probleme.
Das einzige ist, ich stehe mit meiner Spielfigur vor diesem "Escape Truck",
da sind so zwei rot leuchtende halbtransparente Kisten drauf,
und ich denke mal,
die müssten irgendwie zum Tor um dieses damit zu "öffnen".
Aber ich weiß nicht wie es geht. :think:
Und was ist dieses Punk Buster?


Gruß, Fusselbär

Factory
13.07.2005, 23:20
Na danke dann starte ich lieber Win und spiele es da. ;)
würde ich auch sagen :D habe alle meine games auf win und linux wenn ichs wieder drauf habe nur zum arbeiten :)

redlabour
14.07.2005, 00:26
Update:
So, hab es gerade mal mit einem Suse Linux 9.3 ausprobiert,
ging wunderbar, ganz einfach, keine Probleme.
Das einzige ist, ich stehe mit meiner Spielfigur vor diesem "Escape Truck",
da sind so zwei rot leuchtende halbtransparente Kisten drauf,
und ich denke mal,
die müssten irgendwie zum Tor um dieses damit zu "öffnen".
Aber ich weiß nicht wie es geht. :think:
Und was ist dieses Punk Buster?


Gruß, Fusselbär

Hi,

danke der Download läuft gerade werde berichten. Hatte allerdings im Vorfeld das andere Paket auch bei den ersten 2 Versuchen auf meine Linuxpartition gesaugt.
Daran liegt es schonmal nicht.

1. Der Truck - keine Ahnung. Das Tor sprengst Du als Engineer.

2. Punkbuster ist eine Software die für fast jedes MP Game mittlerweile eingesetzt wird. Es überwacht (keine Ahnung wie) den Spielablauf und blockt (?) Cheater.

UPDATE : FUNZT !!!! THX !!! :D

CMW
14.07.2005, 00:50
So, hab es gerade mal mit einem Suse Linux 9.3 ausprobiert,
ging wunderbar, ganz einfach, keine Probleme.
Das einzige ist, ich stehe mit meiner Spielfigur vor diesem "Escape Truck",
da sind so zwei rot leuchtende halbtransparente Kisten drauf,
und ich denke mal,
die müssten irgendwie zum Tor um dieses damit zu "öffnen".
Aber ich weiß nicht wie es geht. :think:
Und was ist dieses Punk Buster?[/I]


Gruß, Fusselbär
Du musst dem Gegner etwas klauen und dahin packen. Das beste ist: ausprobieren und den andern zuschauen was die machen. Ansonsten mal im Netz nach Seiten über ET suchen. Da sind die Ziele der verschieden Karten bestimmt beschrieben.

liquidnight
11.08.2005, 23:47
Hi,
habe jetzt schon 3* von diversen Quellen Enemy Territory gesaugt.
Jedesmal beim Start des Skriptes jedoch :
Nicht wundern - auf win_d liegt es derzeit weil ich beim letzten Mal unter Ubuntu es mit GetRight! unter Win gesaugt habe.
Wie kann ich diese Prüfung denn umgehen ? Das File stimmt garantiert ausser die 3 grössten Fileprovider für ET haben alle einen Hau. ;)

zunächst mal ein bissle werbung für meine lieblingsdistro :-) : die lädt die datei runter (und weiß auch, wo sie liegt) und prüft die Datei mit md5-Summen.

So nun zu Deinem Prob: Du müsstest die Datei auch mit Hilfe der md5-Prüfsumme vergleichen mit dem original auf dem Server. Andere prüfsumme ---> wegwerfen.

Optional: hier der Inhalt der digest-Datei unter gentoo:


# cd /usr/portage/games-fps/enemy-territory
# cat files/digest-enemy-territory-2.60

MD5 2d2373f29f02e18d365d7f1860eee435 et-linux-2.60.x86.run 270965248
MD5 579373e28984be9e9f86d6e0730473d5 enemy-territory-all-0.1.tar.bz2 876


in der zugehörigen ebuild-datei stehen auch die download-urls drin ...

liquidnight
11.08.2005, 23:54
Das einzige ist, ich stehe mit meiner Spielfigur vor diesem "Escape Truck",
da sind so zwei rot leuchtende halbtransparente Kisten drauf,
und ich denke mal,
die müssten irgendwie zum Tor um dieses damit zu "öffnen".
Aber ich weiß nicht wie es geht.


Was Du gesehen hast, war der radar level als allies.
Mir hat am Anfang RTFM sehr geholfen :) . Gas gilt besonders bei ET, weil man das Spiel ein bissle kennen sollte, um zu wissen was man machen soll. Wenn man es aber mal gecheckt hat, macht es um so mehr spaß, weil sich doch oft ein vernünftiges team herausbildet, mit dem man gemeinsam agieren kann.

per sprachdurchsage hörtest du mindestens: haupttor sprengen, radar kisten holen. --> engineer muss das tor sprengen, dann können die allies rein, die 2 kisten holen und sie auf den laster bringen. das halbtransparente ist also der punkt, wo man mit den kisten hin muss.

have fun :-)

Greenleon
27.09.2007, 12:29
Wenn ich bei meinem openSUSE 10.2 ET installieren will kommen folgende Fehlermeldungen in der Konsole!




Warning: kbuildsycoca is unable to register with DCOP.
kbuildsycoca running...
kbuildsycoca running...
Reusing existing ksycoca
KWrited überwacht Gerät /dev/pts/2
kio (KService*): WARNING: The desktop entry file /opt/gnome/share/applications/DefaultPlugins.desktop has Type=Link instead of "Application" or "Service"
kio (KService*): WARNING: Invalid Service : /opt/gnome/share/applications/DefaultPlugins.desktop
kio (KService*): WARNING: The desktop entry file /opt/gnome/share/applications/DefaultPlugins.desktop has Type=Link instead of "Application" or "Service"
kio (KService*): WARNING: Invalid Service : /opt/gnome/share/applications/DefaultPlugins.desktop
kio (KService*): WARNING: The desktop entry file /opt/gnome/share/applications/DefaultPlugins.desktop has Type=Link instead of "Application" or "Service"
kio (KService*): WARNING: Invalid Service : /opt/gnome/share/applications/DefaultPlugins.desktop
kio (KSycoca): ERROR: No database available!
Installing symlink /usr/local/bin/etded -> /usr/local/games/enemy-territory/etded
Removing existing et symlink
Installing symlink /usr/local/bin/et -> /usr/local/games/enemy-territory/et


Wenn ich dann das Spiel starte, oeffnet sich kurz das Fenster, verschwindet dann, und in der Startleiste steht noch ca. 1 Minute ET, was dann aber auch verschwindet...

Hat jemand ne idee?