PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : apache und php4 index.php problem



sono
27.06.2005, 14:47
Moin.

ich hab ein problem mit meiner apacheinstallation:

wenn ich meine seite mit 127.0.0.1/sono aufrufe dann will meine browser etwas herunterladen.

wenn ich meine seite per 127.0.0.1/sono/index.php aufrufen dann wird die seite angezeigt.

im https server wird die seite ohne probleme angezeigt. wo hängts da denn ?

nikster77
27.06.2005, 15:35
hast du index.php den "startseiten" (DirectoryIndex) hinzugefuegt?

sono
27.06.2005, 18:29
Öhm , eigentlich einfach per apt installiert.

das ging bisher immer ohne probleme.
Wie gesagt schein nur bisher.

Wie mach ich das ? in der apache conf schätz ich ich mal.
Mal schaun ob ich das rausfinde wie es geht sollte ja ned zu schwer sein.

dmaphy
27.06.2005, 23:25
entweder in der httpd.conf in /etc/httpd/conf/ oder in der php.conf in /etc/httpd/conf.d/ , je nachdem, wo eine ist.
in der httpd.conf lässt sich die stelle relativ einfach finden, wenn du deinen texteditor nach "index.html" suchen lässt, dort brauchst du index.php nur mit dazu zu schreiben,
vorrausgesetzt es steht nicht schon da.
in der php.conf sollte das auch schon dastehen...
und wenn es bei beiden dasteht, und das problem immernoch besteht, kann ich dir auch nich helfen o.O

sono
28.06.2005, 02:08
Hab schlau wie ich bin ein dpkg-reconfigure phpmyadmin gemacht und apache mit angebenen .

Nun geht alles so wie ich das will :devil:

Ok das war ne faule lösung aber he , es ging problemlos :devil: :devil:

nikster77
28.06.2005, 09:16
dann schau mal nach ob es jetzt in der commonapache2.conf drinsteht.

Gruss

Niels