PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Problem Apache und den Seiten



SethGecko
09.06.2005, 05:24
Moin,

Ich habe seit dem reboot meines Servers Probleme... und zwar:

Wenn ich die Domain im Browser eingebe, dann wird mir das index-File zum Download angeboten.
Bei PHP-Files ist es so, dass das File zum Download angeboten wird, auch wenn man es direkt aufruft... also www.name.tld/index.php.
Bei HTML-Files sieht es etwas anders aus... wird das File nur über www.name.tld angesprochen, wird es wie bei PHP zum Download angeboten... ruft man es aber direkt im Browser auf, wird es angezeigt.

Ich habe schon gegooglt... aber das Problem tritt ständig auf und nicht nur sporadisch wie bei anderen... und den Apache habe ich mit apt-get install apache2 apache2-common apache2-doc apache2-mpm-prefork apache2-dev installiert.

Kann mir jemand sagen, wo ich noch schauen könnte?

Aapache ist 2.0.54 und PHP 4.3.10 OS is Debian 3.0

SethGecko
09.06.2005, 15:16
also... ein rechte problem kann es nicht sein... und in der apache2.conf
habe ich gerade die kommentarzeichen vor...
AddType application/x-httpd-php .php
AddType application/x-httpd-php-source .phps

entfernt... die dateien werde aber immernoch zum download angeboten...


edit: problem gelöst...

Snok
26.08.2005, 20:16
'n Abend!

Ok... Ich habe das gleiche (bzw. ein ähnliches) Problem.
Ich benutze einen Apache 2.0.52 und PHP 4.3.4 (Zend Engine 1.3) und Debian Sarge (Debian 3.1 stable).

Es scheint so, als würden mit steigender Laufzeit immer mehr PHP-Dateien mit einem Header "application/x-httpd-php" zum Download gesandt. Interessanterweise sind die Dateien fertig geparst. Ein Neustart des Apache ändert an der Situtation nichts, ein Neustart des gesamten Servers hingegen schon. Ich bin mir ziemlich sicher, dass die Konfiguration in Ordnung ist. Da es anfangs funktioniert, gehe ich davon aus, dass mir beim Überprüfen der wichtigsten Konfigurationseinstellungen ("DirectoryIndex", /mods-enabled/php4.*, usw.) kein Lesefehler unterlaufen ist.

Ist es möglich, dass sich irgendwo temporäre Dateien ansammeln, die diesen Fehler verursachen, die beim Neustart des Systems gelöscht werden?

Vielleicht könntest du, SethGecko, auch unabhängig davon, ob es mir weiterhelfen könnte, deine Problemlösung posten?

Danke schon im Vorraus für die Hilfe
Grüße
Snok

Woody-Komoro
16.06.2006, 13:08
Edit: Problem gelöst..

Es wäre ziemlich cool, wenn auch eine Problemlösung dort stehen würde.

Ich habe mit meinem Indianer das selbe Problem. Es werden sporadisch .php Files als Download angeboten. An sonsten funktioniert alles wunderbar, php Seiten funktionieren einwandfrei.
Safemode ist ebenfalls an.

Besten Dank schon einmal für Lösungsvorschläge

mfg Woody

supersucker
16.06.2006, 13:15
Es wäre ziemlich cool, wenn auch eine Problemlösung dort stehen würde.

Ja, das wäre es.


Edit: Problem gelöst..

Ja, und wo ist deine Problemlösung? Du monierst das andere nicht ihre Lösung posten und machst es dann 5 Minuten selber nicht, oder wie?

Woody-Komoro
16.06.2006, 16:01
Sorry, das sollte keinerlei Angriff sein.

ich habe nur vergessen das " Edit: Problem gelöst.. " von dir zu quoten:(

Snok
18.06.2006, 09:51
Das Problem hab ich damals so gelöst, dass ich die Module für SSL und Perl deaktiviert habe (entsprechende Dateien aus mods-enabled/ gelöscht). Keine blitz-saubere Lösung, aber es funktioniert bei mir.

Hoffe geholfen zu haben
Snok

StyleWarZ
18.06.2006, 12:23
Also bei mir war es der /etc/hosts eintrag. Dieser muss mit dem Servernamen in der Apache Conf übereinstimmen sonst tut sich da nix ;)

Woody-Komoro
18.06.2006, 17:39
Vielen Dank für die Mühen.

Perl und SSL waren aktiv.

Problem ist nun behoben. Es lag am php Modul.

Die PHP Version 4.3.3 in Verbindung mit Apache 2.0.48 führt mitunter zu den Fehlern, dass zwar PHP ausgeführt wird, allerdings passiert es ab und an, dass PHP Files zum Download angeboten werden. Dies ist auf einen Bug im PHP zurückzuführen.

Ich habe nun auf PHP 4.4.2 umgestellt und seitdem sind die Fehler weg.

Bevorzugt tritt dies wohl bei Stratoservern auf.