PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Samba Share erstellen ?!



LordIcon
16.04.2005, 18:01
Hey und Hallo,

hab ein bissel mit dem Samba probiert aber ich bekomm irgendwie es nicht hin was ich will. Ich möchte das Rootverzeichnis von meinem lokalen Fedora3 Server in das Netzwerk sharen, so das ich von jedem Rechner darauf zugreifen kann und an den Scripten da arbeiten kann. ABer irgendwie bekomm ich das nicht so hin, wie ich es will. Hab einiges im Netz mitlerweile auch schon dazu gelesen aber so wirklich weiter geholfen hat mir nichts. Und bevor ich jetzt das System ganz versaue hoffe ich auf eure Hilfe jetzt !?

Also die smb.conf schaut so im Moment aus



#======================= Global Settings =====================================
[global]
netbios name = Linux
workgroup = ARBEITSGRUPPE
server string = Linux Server
hosts allow = 192.168.0. ,127.
log file = /var/log/samba/%m.log
max log size = 50
security = share
username map = /etc/samba/smbusers
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=819

#============================ Share Definitions ==============================
idmap uid = 16777216-33554431
idmap gid = 16777216-33554431
template shell = /bin/false
winbind use default domain = no

[homes]
comment = Home Directories
browseable = no
writeable = yes

[htdocs]
path = /var/www/html
guest only = yes
writeable = yes
printable = no
browseable = yes
create mask = 0777
valid users = nobody


Erreicht habe ich damit schonmal das ich auf meinem WIndows 2000 Rechner den Share angezeigt bekomme und auch darauf zugreifen kann. Schreibende Rechte habe ich irgendwie nicht, warum weiß ich leider nicht. Was muss ich dafür denn nun noch angeben ?! Das ganze soll denn auch so erfolgen, das ich einen Komplettzugriff sofort habe und ich mich nicht noch anmelden muss erst, wenn ich auf den Share zugreifen will. Gesichert soll dies über die erlaubten IP-Adressen werden.


Achso, das oben beschriebene funktioniert aber auch nur auf meinem Laptop (Windows 2000 Pro), wenn ich das gleiche mit meinem Windows XP MCE2005 versuche, denn bekomm ich schon bei Eingabe \\IP-Adresse eine Fehlermeldung.
Wo ist da das Problem oder wie bekomm ich das gelöst ?!

Der 2000'er läuft normalerweise in einer Domain, aber hier zu hause natürlich ohne. Der XP läuft in der Arbeitsgruppe "ARBEITSGRUPPE".

dramen
16.04.2005, 19:22
also ich habe meinen share-abschnitt folgendermaßen "konfiguriert":

[share]
path = /windows/D
read only = no
create mask = 0666
force create mode = 0666
directory mask = 0777
force directory mode = 0777


Achso, das oben beschriebene funktioniert aber auch nur auf meinem Laptop (Windows 2000 Pro), wenn ich das gleiche mit meinem Windows XP MCE2005 versuche, denn bekomm ich schon bei Eingabe \\IP-Adresse eine Fehlermeldung.
Wo ist da das Problem oder wie bekomm ich das gelöst ?!
achte auf deine rechnernamen!
versuche mal in der /etc/hosts folgendes einzutragen.
192.168.0.1 rechner1.arbeitsgruppe
192.168.0.2 rechner2.arbeitsgruppe

... ich hoffe aber auch dass dein xp-rechner richtig konfiguriert ist (statische ip DNS usw.)

LordIcon
16.04.2005, 19:27
Wie meinst du das mit den Rechnernamen jetzt?! Wenn ich \\Ip-Adresse in die Adresszeile eingebe, denn meldet mir Windows das diese überprüfen sollte da sie nicht gefunden wurde. http://Ip-Adresse dagegen liefert mir die Startseite des Apache Servers.

Ich weiß das dies ein Linux Forum ist, aber vielleicht kann mir dabei auch einer helfen! WIe gesagt, vom Windows 2000 Laptop funktioniert das einwandfrei ....


Den Share habe ich jetzt mittels des Tut's hier http://www.unixboard.de/vb3/showthread.php?t=3714 auch endöich hinbekommen. Ist vielleicht so nicht das sicherste, aber es läuft auf jedenfall schonmal.

LordIcon
16.04.2005, 19:49
So, auch der XP Rechner funktioniert jetzt glaub ich soweit, wie es sollte. Der Tipp mit der Netzwerkkonfiguration war nicht schlecht und vor allem peinlich für mich :-( Sollte ja auch den Client für die Microsoftnetzwerke auch auf der Netzwerkkarte aktivieren *ups*

Meine Konfiguration schaut jetzt folgendermassen aus:



[global]
workgroup = Arbeitsgruppe
guest account = nobody
keep alive = 30
os level = 2
kernel oplocks = false
security = share
interfaces = 192.168.0.4/255.255.255.0
bind interfaces only = yes
socket options = TCP_NODELAY

[htdocs]
comment = htdocs
browseable = yes
path = /var/www/html
writeable = yes
public = yes
guest only = no
directory mask = 0777
create mask = 0777

Wie "sicher" ist diese oder wo könnte man noch ein bissel optimieren?!

dramen
16.04.2005, 19:59
Wie meinst du das mit den Rechnernamen jetzt?! Wenn ich \\Ip-Adresse in die Adresszeile eingebe, denn meldet mir Windows das diese überprüfen sollte da sie nicht gefunden wurde. http://Ip-Adresse dagegen liefert mir die Startseite des Apache Servers.

also bei mir geht das ganze nicht über die adresszeile, sondern über netzwerkumgebung -> arbeitsgruppencomputer anzeigen (im windows). dass die apache-seite angezeigt wird beduetet nur, dass dein web-server läuft.

weiß nicht ob du schon hier geschaut hast: www.linuxbu.ch

LordIcon
16.04.2005, 20:37
Hättest meinen letzte Beitrag auch gelesen, denn hättest schon gesehen das ich das Problem gelöst habe und es sehr sher einfach war ;-) Der Client für Microsoftnetzwerke war schlichtweg auf der Netzwerkkarte nicht aktiviert gewesen ....