PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : ET ohne Sound



/home/Tux
12.03.2005, 15:41
hi,

hab mir eben et und das normale rtcw installiert. nur ich hab kein sound :hilfe2:
mp3 geht, filme gehen nur nicht sounds bei games

Zero
12.03.2005, 15:44
hi,

versuch es mal mit:
artsdsp -m et

zu starten.

/home/Tux
12.03.2005, 16:10
immer noch kein sound

Zero
12.03.2005, 16:18
starte mal et in der konsole und poste den output hier

/home/Tux
12.03.2005, 17:31
artsdsp -m et
ET 2.56 linux-i386 Sep 10 2003
----- FS_Startup -----
Current search path:
/home/tux/.etwolf/etmain
/usr/local/games/enemy-territory/etmain/pak1.pk3 (10 files)
/usr/local/games/enemy-territory/etmain/pak0.pk3 (3725 files)
/usr/local/games/enemy-territory/etmain/mp_bin.pk3 (4 files)
/usr/local/games/enemy-territory/etmain

----------------------
3739 files in pk3 files
execing default.cfg
couldn't exec language.cfg
execing profiles/tux/etconfig.cfg
couldn't exec autoexec.cfg
Hunk_Clear: reset the hunk ok

------- Input Initialization -------
Joystick is not active.
------------------------------------
Bypassing CD checks
----- Client Initialization -----
----- Initializing Renderer ----
-------------------------------
----- Client Initialization Complete -----
----- R_Init -----
...loading libGL.so.1: Initializing OpenGL display
...setting mode 6: 1024 768
Using XFree86-VidModeExtension Version 2.2
XF86DGA Mouse (Version 2.0) initialized
XFree86-VidModeExtension Activated at 1024x768
Using 4/4/4 Color bits, 24 depth, 0 stencil display.
GL_RENDERER: GeForce4 Ti 4200/AGP/SSE2
Initializing OpenGL extensions
...using GL_S3_s3tc
...ignoring GL_EXT_texture_env_add
...using GL_ARB_multitexture
...using GL_EXT_compiled_vertex_array
...ignoring GL_NV_fog_distance
XF86 Gamma extension initialized

GL_VENDOR: NVIDIA Corporation
GL_RENDERER: GeForce4 Ti 4200/AGP/SSE2
GL_VERSION: 1.5.2 NVIDIA 66.29
GL_EXTENSIONS: GL_ARB_depth_texture GL_ARB_imaging GL_ARB_multisample GL_ARB_multitexture GL_ARB_occlusion_query GL_ARB_point_parameters GL_ARB_point_sprite GL_ARB_shadow GL_ARB_shader_objects GL_ARB_shading_language_100 GL_ARB_texture_border_clamp GL_ARB_texture_compression GL_ARB_texture_cube_map GL_ARB_texture_env_add GL_ARB_texture_env_combine GL_ARB_texture_env_dot3 GL_ARB_texture_mirrored_repeat GL_ARB_texture_rectangle GL_ARB_transpose_matrix GL_ARB_vertex_buffer_object GL_ARB_vertex_program GL_ARB_vertex_shader GL_ARB_window_pos GL_S3_s3tc GL_EXT_texture_env_add GL_EXT_abgr GL_EXT_bgra GL_EXT_blend_color GL_EXT_blend_minmax GL_EXT_blend_subtract GL_EXT_compiled_vertex_array GL_EXT_Cg_shader GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_multi_draw_arrays GL_EXT_packed_pixels GL_EXT_paletted_texture GL_EXT_pixel_buffer_object GL_EXT_point_parameters GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_shadow_funcs GL_EXT_shared_texture_palette GL_EXT_stencil_wrap GL_EXT_texture3D GL_EXT_texture_compression_s3tc GL_EXT_texture_cube_map GL_EXT_texture_edge_clamp GL_EXT_texture_env_combine GL_EXT_texture_env_dot3 GL_EXT_texture_filter_anisotropic GL_EXT_texture_lod GL_EXT_texture_lod_bias GL_EXT_texture_object GL_EXT_vertex_array GL_HP_occlusion_test GL_IBM_rasterpos_clip GL_IBM_texture_mirrored_repeat GL_KTX_buffer_region GL_NV_blend_square GL_NV_copy_depth_to_color GL_NV_depth_clamp GL_NV_fence GL_NV_fog_distance GL_NV_light_max_exponent GL_NV_multisample_filter_hint GL_NV_occlusion_query GL_NV_packed_depth_stencil GL_NV_pixel_data_range GL_NV_point_sprite GL_NV_register_combiners GL_NV_register_combiners2 GL_NV_texgen_reflection GL_NV_texture_compression_vtc GL_NV_texture_env_combine4 GL_NV_texture_rectangle GL_NV_texture_shader GL_NV_texture_shader2 GL_NV_texture_shader3 GL_NV_vertex_array_range GL_NV_vertex_array_range2 GL_NV_vertex_program GL_NV_vertex_program1_1 GL_SGIS_generate_mipmap GL_SGIS_multitexture GL_SGIS_texture_lod GL_SGIX_depth_texture GL_SGIX_shadow GL_SUN_slice_accum
GL_MAX_TEXTURE_SIZE: 4096
GL_MAX_ACTIVE_TEXTURES_ARB: 4

PIXELFORMAT: color(16-bits) Z(24-bit) stencil(0-bits)
MODE: 6, 1024 x 768 fullscreen hz:N/A
GAMMA: hardware w/ 0 overbright bits
CPU:
rendering primitives: single glDrawElements
texturemode: GL_LINEAR_MIPMAP_LINEAR
picmip: 0
texture bits: 16
multitexture: enabled
compiled vertex arrays: enabled
texenv add: disabled
compressed textures: enabled
NV distance fog: disabled
Initializing Shaders
----- finished R_Init -----

------- sound initialization -------
/dev/dsp: Input/output error
Could not mmap /dev/dsp
------------------------------------
Sound memory manager started
Sys_LoadDll(/home/tux/.etwolf/etmain/ui.mp.i386.so)...
Sys_LoadDll(/home/tux/.etwolf/etmain/ui.mp.i386.so) failed:
"/home/tux/.etwolf/etmain/ui.mp.i386.so: cannot open shared object file: No such file or directory"
Sys_LoadDll(/usr/local/games/enemy-territory/etmain/ui.mp.i386.so)... ok
Sys_LoadDll(ui) found **vmMain** at 0xeddb1bfc
Sys_LoadDll(ui) succeeded!
--- Common Initialization Complete ---
Opening IP socket: localhost:27960
Hostname: localhost.localdomain
Alias: localhost
IP: 127.0.0.1
Started tty console (use +set ttycon 0 to disable)
^5PunkBuster Client: PunkBuster Client (v1.013 | A0) Enabled
^5PunkBuster Client: Game Version [ET 2.56 linux-i386 Sep 10 2003]
^5PunkBuster Client: Not Connected to a Server
----- CL_Shutdown -----
RE_Shutdown( 1 )
-----------------------
----- CL_Shutdown -----
-----------------------
Shutdown tty console

Zero
12.03.2005, 18:51
versuch das hier erstmal, als root:

echo "et.x86 0 0 direct" > /proc/asound/card0/pcm0p/oss

sollte das nicht funktionieren, dann versuch folgendes:

artsshell terminate
et

nachdem zocken:
artswrapper &

/home/Tux
13.03.2005, 14:52
ok es geht

thx

/home/Tux
13.03.2005, 15:30
kommando zureuck, bei et geht es aber bei rtcw und d3 nicht

Adridon
14.03.2005, 18:22
Ich denke mal, die ausführbaren Dateien von RTCW und D3 heißen nicht et.x86. Probier doch mal, den Dateinamen in dem obigen Befehl zu ersetzen ;)

/home/Tux
15.03.2005, 15:09
doch die heissen .x86, du fuehrst sie nur mit "et" z.b aus :) doch sound hab ich trotzdem irgendwie nicht :)

/home/Tux
19.03.2005, 15:34
hat keiner mehr ne idee woran es liegen kann

Zero
19.03.2005, 22:16
was für eine soundkarte hast du eigentlich?
EDIT: Achja, mach bei Doom3 ein Update auf die neuste Version, falls du dies nicht gemacht hast, dass gleiche gilt für rtcw.

/home/Tux
20.03.2005, 08:55
hab keine soundkarte drin, nutze die onboard und die geht ja auch, mp3 usw laeuft nur halt spiele nicht. rtcw, et und d3 sind auf dem neusten stand

Zero
20.03.2005, 11:51
lspci | grep audio

poste diese Ausgabe, bitte.
Sollte keine Ausgabe erfolgen, führe nur ein lspci aus und poste das dann.

/home/Tux
20.03.2005, 15:04
[tux@localhost ~]$ ls
ls lsattr lsb_release lsdiff lshal lspgpot
[tux@localhost ~]$ lspci
bash: lspci: command not found
[tux@localhost ~]$ lspci | grep audio
bash: lspci: command not found
[tux@localhost ~]$

das war nichts :hilfe2:

Zero
20.03.2005, 15:29
dann installiere es doch ?

/home/Tux
20.03.2005, 15:30
dumme frage... was? :think:

.eg
20.03.2005, 17:22
lspci als root ausführen oder /sbin/lspci als normaler User.

Zero
22.03.2005, 10:14
lspci befindet sich im pciutils packet, dass einfach nach installieren.

Poste aber noch die Ausgabe von "lsof /dev/dsp"
und /proc/asound/card0/pcm0p/oss

Achja, hast du das packet alsa-oss installiert?

/home/Tux
26.03.2005, 13:02
hab garkein oss install, der hat meine karte so erkannt

buttermaker
20.05.2005, 14:55
Jetzt brauch ich auch kein WINDOOF mehr um ET zu spielen.
Wieder eine Partion die frei wird !

DANKE