PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : hilfe! mein webserver geht nicht mehr!



dramen
25.02.2005, 08:20
hallo!

ich weiß jetzt nicht genau warum aber jedenfalls funktioniert mein webserver nicht mehr. habe den apache neu installiert und die /etc/apache/httpd.conf soweit angepasst. die benutzerrechte im verzeichnis /var/www/htdocs sind auch so angepasst, dass sie jeder lesen kann.

wenn ich in die url-zeile localhost eintrage kommt folgendes heraus:
Beim Laden von http://localhost ist folgender Fehler aufgetreten:
Keine Verbindung zu Rechner localhost

klar ... denn der apache webserver lässt sich ganz einfach nicht starten:
root@dramen:~# /usr/sbin/apachectl start
/usr/sbin/apachectl start: httpd could not be started

warum?

vielen dank!

devilz
25.02.2005, 11:02
Was sagen die Logs ? - Der Fehler ist ja so wohl kaum zu Identifizieren !
(Welche Distro, Welche Apache Version?)

dramen
25.02.2005, 15:08
apache-1.3.33-i486-1
slackware 10.1

/var/log/apache/error_log:
[Fri Feb 25 16:02:46 2005] [alert] mod_unique_id: unable to gethostbyname("dramen")

das ist das einzige was ich an fehlermeldungen herauskitzeln kann!

/etc/apache/httpd.conf:
DocumentRoot "/var/www/htdocs/"
<Directory "/var/www/htdocs/">

avaurus
25.02.2005, 15:19
erzähl mal mehr von deinem System. Hast du eventuell einen SELinux-Kernel ?

dramen
25.02.2005, 15:25
was ist ein SE-Linux-Kernel?
habe den 2.6.10 kernel

wrath_of_god
25.02.2005, 16:34
altbekanntes problem, einfach mod_unique_id aus der config aus commenten, das braucht sowieso kein schwein und macht nur probs :)

dramen
25.02.2005, 16:55
vielen dank, amigo!!

funktioniert wieder!!

:)