PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : mod_rewrite...



crypt
21.02.2005, 15:33
hi...
ich hab mal wieder ein kleines prob...mit dem apache...
hab mir die neueste version als source gezogen...hab ihn mehrere mal compiliert, einmal mit mysql + php, was ohne probs ging und auch läuft...einmal ohne nur, um mod_rewrite zu testen...und da ist auch das problem...


mod_rewrite.h:90:18: ndbm.h: No such file or directory
mod_rewrite.c: In function `lookup_map_dbmfile':
mod_rewrite.c:3034: error: `DBM' undeclared (first use in this function)
mod_rewrite.c:3034: error: (Each undeclared identifier is reported only once
mod_rewrite.c:3034: error: for each function it appears in.)
mod_rewrite.c:3034: error: `dbmfp' undeclared (first use in this function)
mod_rewrite.c:3035: error: `datum' undeclared (first use in this function)
mod_rewrite.c:3035: error: parse error before "dbmkey"
mod_rewrite.c:3043: error: `dbmkey' undeclared (first use in this function)
mod_rewrite.c:3046: error: `dbmval' undeclared (first use in this function)
make[4]: *** [mod_rewrite.so] Error 1
make[3]: *** [all] Error 1
make[2]: *** [subdirs] Error 1
make[2]: Leaving directory `/usr/src/apache_1.3.33/src'
make[1]: *** [build-std] Error 2
make[1]: Leaving directory `/usr/src/apache_1.3.33'
make: *** [build] Error 2


er meint eine datei nicht finden zu können...ich hab das jetz mehrmals mit verschiedenen optionen compiliert und auch unterschiedliche fehler erhalten...dieser fehler kommt wenn ich folgene config ausführ...

./config --enable-module=so --enable-module=rewrite --enable-shared=max --enable-rule=SHARED_CORE --prefix=/usr/local/apache

villeicht hat ja jemand schonma ein ähnliches problem gehabt...ich hab google schon gefüttert, wo nur ein result zu einer japanischen seite kam....auf der seite hab ich auch ein paar parameter gefunden, die ich auch probiert hab aber leider auch nicht zum erfolg führten....


ich bedanke mich schonmal im voraus....

Zico
21.02.2005, 20:43
Hmmm genau weiss ich da jetz auch ned weiter, weil ich bisher noch kein Apache compiliert habe.
Schau mal, ob die fehlende Datei
ndbm.h
überhaupt auf der Platte vorhanden ist. Vllt. fehlt nochn zusatzpaket, welches unabhängig fungiert.
vllt. liegt denn auch mit dem prefix zusammen. Dies verweist evt. nicht auf das Verz. (+ Unterverz.) in welchem die Datei zu finden ist.
Nur mal als Vorschlag.so würd ichs mal versuchen anzupacken. Ansonsten setzen wir uns morgen früh um 7:30 mal zusammen ran ;)

Sir Auron
21.02.2005, 20:46
hi...
ich hab mal wieder ein kleines prob...mit dem apache...
hab mir die neueste version als source gezogen...hab ihn mehrere mal compiliert, einmal mit mysql + php, was ohne probs ging und auch läuft...einmal ohne nur, um mod_rewrite zu testen...und da ist auch das problem...


mod_rewrite.h:90:18: ndbm.h: No such file or directory
mod_rewrite.c: In function `lookup_map_dbmfile':
mod_rewrite.c:3034: error: `DBM' undeclared (first use in this function)
mod_rewrite.c:3034: error: (Each undeclared identifier is reported only once
mod_rewrite.c:3034: error: for each function it appears in.)
mod_rewrite.c:3034: error: `dbmfp' undeclared (first use in this function)
mod_rewrite.c:3035: error: `datum' undeclared (first use in this function)
mod_rewrite.c:3035: error: parse error before "dbmkey"
mod_rewrite.c:3043: error: `dbmkey' undeclared (first use in this function)
mod_rewrite.c:3046: error: `dbmval' undeclared (first use in this function)
make[4]: *** [mod_rewrite.so] Error 1
make[3]: *** [all] Error 1
make[2]: *** [subdirs] Error 1
make[2]: Leaving directory `/usr/src/apache_1.3.33/src'
make[1]: *** [build-std] Error 2
make[1]: Leaving directory `/usr/src/apache_1.3.33'
make: *** [build] Error 2


er meint eine datei nicht finden zu können...ich hab das jetz mehrmals mit verschiedenen optionen compiliert und auch unterschiedliche fehler erhalten...dieser fehler kommt wenn ich folgene config ausführ...

./config --enable-module=so --enable-module=rewrite --enable-shared=max --enable-rule=SHARED_CORE --prefix=/usr/local/apache

villeicht hat ja jemand schonma ein ähnliches problem gehabt...ich hab google schon gefüttert, wo nur ein result zu einer japanischen seite kam....auf der seite hab ich auch ein paar parameter gefunden, die ich auch probiert hab aber leider auch nicht zum erfolg führten....


ich bedanke mich schonmal im voraus....
Hast du die Berkeley Database 4 installiert?

pacman -Sii apache
[...]
Abhängig von : db expat gdbm glibc openssl
[...]



# $Id: PKGBUILD,v 1.55 2005/02/07 19:18:18 judd Exp $
# Maintainer: judd <jvinet@zeroflux.org>
pkgname=apache
pkgver=2.0.53
pkgrel=1
pkgdesc="A high performance Unix-based HTTP server (with SSL)"
backup=(etc/httpd/conf/httpd.conf home/httpd/html/index.html \
etc/conf.d/httpd etc/httpd/conf/ssl.conf)
depends=('glibc' 'gdbm' 'db' 'openssl' 'expat')
provides=('apr' 'apr-util')
conflicts=('apr' 'apr-util')
source=(http://www.apache.org/dist/httpd/httpd-$pkgver.tar.gz \
httpd index.html mod_ssl.txt httpd.logrotate httpd.conf.d \
httpd.conf ssl.conf)
md5sums=('b089bdc7065c3be166bcc516b0d92416' '077b2d9dcb7914600f5b1a3de1dec8f7'\
'64206bf5da4daf4b962186ded0a3d20a' '2e68c9508d21e98c4503dcb159d22890'\
'a13925eef67108cf22f6bd1b2b8decb1' '62dba8077401cb5515ecb79fe29c2a52'\
'8747daec5196bdb6221f7dc334504f90' '7adfc868a67f9b16d63a9f3b074f3efa')

build() {
cd $startdir/src/httpd-$pkgver
# fix the suexec user
sed -i 's|^#define AP_HTTPD_USER.*$|#define AP_HTTPD_USER "nobody"|' \
support/suexec.h
./configure --prefix=/usr --enable-layout=RedHat --datadir=/home/httpd \
--enable-modules=all --enable-mods-shared=all --enable-ssl --enable-so \
--enable-proxy --enable-proxy-connect --enable-proxy-ftp \
--enable-proxy-http --enable-suexec
make || return 1
make DESTDIR=$startdir/pkg install
rm -f $startdir/pkg/usr/include/fnmatch.h
rm -rf $startdir/pkg/home/httpd/html/* $startdir/pkg/home/httpd/manual
install -D -m755 ../httpd $startdir/pkg/etc/rc.d/httpd
install -D -m644 ../httpd.logrotate $startdir/pkg/etc/logrotate.d/httpd
install -D -m644 ../index.html $startdir/pkg/home/httpd/html/index.html
install -D -m644 ../mod_ssl.txt $startdir/pkg/etc/httpd/conf/mod_ssl.txt
install -D -m644 ../httpd.conf.d $startdir/pkg/etc/conf.d/httpd
install -D -m644 ../httpd.conf $startdir/pkg/etc/httpd/conf/httpd.conf
install -D -m644 ../ssl.conf $startdir/pkg/etc/httpd/conf/ssl.conf
# move suexec to the right place
mv $startdir/pkg/usr/sbin/suexec $startdir/pkg/usr/bin/suexec
}

Genau so manuell nach machen!

crypt
21.02.2005, 21:33
ok problem hat sich gelöst dank zico...

für alle anderen...man brauch das

gdbm-devel

paket

@sir..
das was du alles installieren lässt is für meinen geschmack schonwieder zu viel...sprich einfach alles auf ALL zu setzen...dann kann man zwar sicher sein das es funzt aber je mehr druff is desto mehr angriffsfläche für kiddis denen irgendn witziges programm in die hände fällt is geboten...und da ich den server für ne schule wo netzwerker ausgebildet werden aufbau, und ich als administrator dafür verantwortlich bin sollte er schon sehr gut abgeschottet sein...

aber trotzdem danke für dein script...