PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Config Bind 9



StyleWarZ
14.02.2005, 21:46
N´abend

bin daran Bind 9 auf meinem Serverchen zu konfigurieren. Jetzt alles was ich gefunden habe war das von meinem Lehrer

http://www.snizek.ch/philipp_snizek/linux/bind/index.htm

Jetzt, mein Prob. Ich finde named.conf nicht. Wo waere diese unter Gentoo?
Wisst ihr per Zufall wo man ein gutes HowTo finden kann?

Gruss Philip

stefan
15.02.2005, 04:51
Hallo Phillip,

ich kenne gentoo nicht, aber vielleicht versuchst du es mal mit

find / -name named.conf

oder, falls du die findutils installiert hast mit

locate named.conf

Gruss Felix

daniel.h
15.02.2005, 10:31
Die named.conf wird wohl unter /etc/ liegen, also /etc/named.conf.
Hier gibts ein HowTo, ist zwar für redhat, aber wird schon passen :)
http://www.redhat.com/docs/manuals/linux/RHL-9-Manual/ref-guide/s1-bind-namedconf.html
Ich habe gerade kein zugriff auf meine gentoo maschine, (bin in der Schule), um selbst zu gucken.

StyleWarZ
15.02.2005, 12:59
also named.conf habe ich in /etc/bind/named.conf gefunden unter gentoo.. und den rest in /var/bind/....

jetzt. alles eingetragen.. meiner meinung nach richtig aber poste mal die files um kontrollieren zu lassen. mein problem jetzt ist das wenn ich auf switch.ch meinem domain 2 nameserver zuteilen möchte folgende meldung beim test erscheint:



Der Nameserver ns1.leitstelle511.ch [213.3.17.237] antwortet nicht auf Anfragen nach seinen eigenen IP-Adressen.
Nameserver ns1.leitstelle511.ch [213.3.17.237] antwortet nicht auf Anfragen nach dem SOA (Start of Authority) für die Zone leitstelle511.ch.
Der Nameserver ns2.leitstelle511.ch [213.3.17.237] antwortet nicht auf Anfragen nach seinen eigenen IP-Adressen.
Nameserver ns2.leitstelle511.ch [213.3.17.237] antwortet nicht auf Anfragen nach dem SOA (Start of Authority) für die Zone leitstelle511.ch.


mein serverchen ist hinter einer firewall! muss man da was freischalten und wenn ja was genau.

meine zweite frage wäre ob es was ausmacht das ns1.leitstelle511.ch und ns2.leitstelle511.ch auf dem server laufen wo www.leitstelle511.ch laufen soll? muss das ganze auf eine andere ip? werde zu einem spätern zeitpunkt sicherlich noch 1-2 backup dns server irgendwo haben (bei kollegen oder so).

Danke für irgendwelche anregungen links lösungen usw.



/etc/bind/named.conf

#### leitstelle511.ch forward ZONE ####
############################

zone "leitstelle511.ch" IN {
type master;
file "leitstelle511/leitstelle511.ch";
allow-query { any; };
};

##### reverse lookup zone for 213.3.17.237#####
###################################
zone "17.3.213.in-addr.arpa" in {
type master;
file "reverse/213.3.17";
notify yes;
allow-query { any; };
};
--------------------------------------------------------------------------

/var/bind/leitstelle511/leitstelle511.ch

$TTL 1D
@ IN SOA ns1.leitstelle511.ch. ns2.leitstelle511.ch. info.leitstelle511.ch. (
00 ;Serial
8H ;Refresh
2H ;Retry
4W ;Expire
8H) ;TTL

NS ns1.leitstelle511.ch. ; name server
NS ns2.leitstelle511.ch. ; name server
MX 9 mail.leitstelle511.ch. ; mail server

mail A 213.3.17.237
www CNAME mail
ns1 A 213.3.17.237
ns2 A 213.3.17.237

--------------------------------------------------------------------------

/var/bind/reverse/213.3.17

$TTL 1D
@ IN SOA ns1.leitstelle511.ch. ns2.leitstelle511.ch. info.leitstelle511.ch. (
00 ; serial
6H ; refresh
2H ; retry
1W ; expiry
1D ) ; minimum TTL

NS ns1.leitstelle511.ch.
NS ns2.leitstelle511.ch.
11 PTR mail.leitstelle511.ch.
12 PTR ns1.leitstelle511.ch.
13 PTR ns2.leitstelle511.ch.

StyleWarZ
16.02.2005, 12:20
kann es sein das der "test" fehler kommt weil ich port 53 nicht geöffnet und im nat eingetragen habe? bin etwas am googlen gewesen, hatte abr bis jetzt noch keine möglichkeit das ganze zu probieren da ich bei der arbeit bin :(

StyleWarZ
17.02.2005, 08:22
Error: Name server ns1.leitstelle511.ch [213.3.17.237] didn't respond to a query for its own IP addresses.
Error: Name server ns1.leitstelle511.ch [213.3.17.237] doesn't respond to queries for the SOA (Start of Authority) of zone leitstelle511.ch.
Warning: At least two nameservers are needed.

bin ich wirklich der einzige mit einem eigenen dns hier? :(

habe jetzt port 53 geöffnet und ge"nat"et. jetzt bin ich der meinung das etwas mit meinen configs nicht stimmt. kann mir da jemand zeigen was nicht stimmt. sitze jetzt schon 2 abende hintereinander an dem ding und es will einfach nicht :hilfe2:

wäre riesig dankbar

Stylie

devilz
17.02.2005, 08:23
Nein, aber wohl der einzige der den "Ändern" Button nicht nicht gefunden hatt !

- Bitte keine Mehrfachpostings ! - Nutze die ändern Funktion ! -

StyleWarZ
17.02.2005, 08:27
nöö, aber was wäre nicht aufgefallen! ;) sorry musste sein

an was liegt den mein prob?
meine domain: leitstelle511.ch
meine stat. ip: 213.3.17.237
domainanbieter: switch.ch

ich finde zu diesen 2 fehlern einfach keine schlaue erklährung/doku oder so was.

leni
25.03.2005, 08:04
Hast Du eine Lösung zu Deinem Problem gefunden? Ich hab dasselbe...
Grüsse
Daniel

leni
25.03.2005, 08:08
Ich hab den DNS von einer statischen IP auf eine andere gezügelt. Nun hab ich dieses Problem...
Grüsse,
Daniel

codc
27.03.2005, 23:29
Also Port 53 kannst du dicht machen. Dein DNS soll ja nicht aussen hin dein Netz auflösen. Macht bei NAT auch keinen Sinn. Ansonsten wird die Anfrage deines DNS auf einem unpriviligierten Port >1023 ausgeführt da er ja dann zum Client wird.

Ansonsten schaue hier --> http://www.chupame.ch/file.php?file=dns.txt und http://wiki.debcenter.org/index.php/Configration_Files#DNS_-_Domain_Name_Service