PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : emerge nedit bringt ein fehler!



DOS
12.02.2005, 17:47
Hallo ich bekomme beim versuch nedit zu emergen ein fehler und weiss nicht wieso, da mein englisch auch nicht das beste is :)

hier die Ausgabe.
>>> emerge (1 of 1) app-editors/nedit-5.4 to /
>>> md5 src_uri ;-) nedit-5.4-source.tar.gz
>>> Unpacking source...
>>> Unpacking nedit-5.4-source.tar.gz to /var/tmp/portage/nedit-5.4/work
>>> Source unpacked.
(cd util; \
make -f Makefile.linux verify_config && \
make -f Makefile.linux libNUtil.a)
make[1]: Entering directory `/var/tmp/portage/nedit-5.4/work/nedit-5.4/util'
gcc -O -I/usr/X11R6/include -DUSE_DIRENT -DUSE_LPR_PRINT_CMD -o check_lin_tif check_lin_tif.c
./check_lin_tif
Open Motif or OSF Motif detected.
@(#)Motif Version 2.2.3
ERROR: Bad Open Motif Version:
@(#)Motif Version 2.2.3

This version of Open Motif is known to be broken and is
thus unsupported by the NEdit developers. It will probably
cause NEdit to crash frequently. Check these pages for a more
detailed description of the problems with this version:
http://www.motifdeveloper.com/tips/tip22.html
http://www.motifdeveloper.com/tips/Motif22Review.pdf

NEdit is known to work with LessTif versions:
0.92.32
0.93.0
0.93.12
0.93.18
and is known to be very stable with Open Motif version 2.1.30,
which is freely available from several sources, including:
http://www.opengroup.org/openmotif/
http://www.metrolink.com/products/motif/open_motif2-1-30.html
http://www.ist.co.uk/DOWNLOADS/motif_download.html

Also, unless you need a customized NEdit you should STRONGLY
consider downloading a pre-built binary from http://www.nedit.org,
since these are the most stable versions.

If you really want to build a known-bad version of NEdit you
can override this sanity check by adding -DBUILD_BROKEN_NEDIT
to the CFLAGS variable in your platform's Makefile (e.g.
makefiles/Makefile.linux)
make[1]: *** [check_tif_rule] Error 1
make[1]: Leaving directory `/var/tmp/portage/nedit-5.4/work/nedit-5.4/util'
make: *** [linux] Error 2

!!! ERROR: app-editors/nedit-5.4 failed.
!!! Function src_compile, Line 23, Exitcode 2
!!! (no error message)
!!! If you need support, post the topmost build error, NOT this status message.

root@tux dos #

und hier meine USE

USE="3dnow 3dnowex qt alsa icewm xmms -java -kde -gnome"

thx 4 help schonmal.

wrath_of_god
12.02.2005, 18:02
hatte ich auch gestern
ganz einfach zu lösen
1. weg mit der version von openmotif
2. in /etc/portage/package.mask "=x11-libs/openmotif-2.2.3" eintragen (ohne ")
2.1. für den extra l33tnes faktor kann mans auch mit "echo =x11-libs/openmotif-2.2.3 >> /etc/portage/package.mask" machen ;)
3. emerge nedit
4. sich an nedit erfreuen :D

DOS
12.02.2005, 18:06
hmm hab in die /etc/portage/package.mask =x11-libs/openmotif-2.2.3 geschrieben gespeichert und dann emerge nedit und leider wieder gleiche fehler ausgabe :(

wrath_of_god
12.02.2005, 18:09
du musst openmotif vorher unemergen (bevor du nedit emerged)

DOS
12.02.2005, 18:49
ha dank dir hat geklappt und wieso ist nun dieser fehler da? beim letzten mal hatte ich net solche probs. kommt der von was bestimmten?

wrath_of_god
12.02.2005, 19:11
naja steht doch eh in der fehler meldung :) die version von openmotif macht in der version probleme, in den foren steht etwas davon das die versucht haben support für openmotif (oder irgendeiner lib ka mehr) 1 und 2 einzubaun was aber mehr probleme gemacht hat als es geholfen hätte also haben sie es gelassen, da du die neueste version jetzt gemasked hast installiert er eine niedrigere version von openmotif die keine probleme mit nedit macht