PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : restrictet Zugriff auf webserver



levada
21.12.2004, 12:59
Moin,

habe apache 2. Webserver läuft. Kriege bloß den Zugriff mit .htaccess auf ein Verzeichnis nicht zum laufen.

Meine .htaccess:

AuthType Basic
AuthName "runbooks"
AuthUserFile /srv/www/passwords
Require user suntech

http.conf:
# forbid access to the entire filesystem by default
<Directory />
Options None
AllowOverride AuthConfig
Order deny,allow
Deny from all
</Directory>

# use .htaccess files for overriding,
AccessFileName .htaccess
# and never show them
<Files ~ "^\.ht">
Order allow,deny
Deny from all
</Files>


HAb ich was vergessen??


ciao

levada

khs
21.12.2004, 13:31
HAb ich was vergessen??


Die aussagekraeftige Fehlermeldung aus $ACCESS_LOG oder $ERROR_LOG?

Beim ueberfliegen deiner Config und Vergleichen mit meiner konnte ich keine wesentlichen Unterschiede (gut, ich hab andere allows und denys, obs daran liegt?) feststellen, daher waere interessant, was apache selber spricht, warums nicht geht.

-khs

levada
21.12.2004, 14:03
Fehler gefunden:
[error] [client 127.0.0.1] Symbolic link not allowed

Habe im Verz. ein symbolic link zu einem Verz. angelegt.
Hast Du für mich ne Lösung?


ciao

levada

khs
21.12.2004, 15:07
Habe im Verz. ein symbolic link zu einem Verz. angelegt.
Hast Du für mich ne Lösung?


Options SymLinksIfOwnerMatch

-khs