PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Knoppix 3.7 und WLAN?



Lumma
16.12.2004, 17:31
Also, ich habe heute das neue Knoppix 3.7 auf meine Festplatte installiert! Jetzt möchte ich meine WLAN Karte (RTL 8180 von gericom) in meinem Gericom Blockbuster 2 Notebook zum laufen bringen! Ich habe die Treiber für linux heruntergeladen nur hab ich überhaupt keine ahnung was ich mit denen anfangen soll, es sind viele verschiedene files drinnen und die readme check ich schon gar net! Wie kompiliert man dass?

die treiber hab ich unter

http://www.realtek.com.tw/downloads/downloads1-3.aspx?Keyword=8180

heruntergeladen! Kann sich einer die mal anschauen und mir sagen wie ich vorgehen muss? ich hab schon unter google alles abgesucht und bin jetzt nur noch mehr verwirrt! +g+ Danke im Voraus für jede Hilfe! ;)

devilz
16.12.2004, 17:35
Hast du hier mal geschaut ? -> http://www.unixboard.de/vb3/search.php?searchid=190378

Bitte immer erst die Forensuche verweden - dann fragen :)

Lumma
16.12.2004, 17:42
hab ich schon! ich bräuchte ne genaue beschreibung wie ich sowas machen kann, wie kompilier ich das? wo muss ich die befehle eingeben? in der konsole oder wie? bitte schau dir mal das readme an und sag mir kurz was zu tun ist! :))

zB dass hier


Please try to load linux_24x.o first by "insmod -f rtl8180_24x.o".

WO? Wie? Womit? :think:

BITTE!

Sir Auron
16.12.2004, 18:04
2.6 oder 2.4 Kernel? Bei 2.6 keine Chance (entwickle gerade Treiber) bei 2.4 gehts wohl.

lazarusz
16.12.2004, 18:12
das
insmod -f rtl8180_24x.o

heist soviel wie, du sollst zuerst den befehl eingeben alls root, das läd den treiber der beim kernel dabei "grob" gesagt wenn das ned funktioniert sollst du erst den reltek treiber installieren !

Lumma
16.12.2004, 18:28
danke für eure hilfe ABER

@azarusz wo muss ich das eingeben?
aja, dass sind die treiber von realtek

@Sir Auron is der 2.4er

:hilfe2:

lazarusz
16.12.2004, 18:42
eingeben tust du befehle fast ausschlisslich in der konsole deiner wahl !

zb. eterm, xterm, konsole - bei kde <--- schaut das icon symbol aus wie ein kleiner computer monitor !

Lumma
16.12.2004, 18:48
muss ich zB bei


insmod -f rtl8180_24x.o

den pfad angeben oder kann ich das einfach so in die konsole eingeben?

und wie kompilier ich die treiber? mit einem kompiler? :think:

lazarusz
16.12.2004, 18:49
hihi - wenn du das so reinschreibst in die konsole und es funkt brauchst ausser dem nix mehr machen ;.-)

Lumma
16.12.2004, 18:50
hihi - wenn du das so reinschreibst in die konsole und es funkt brauchst ausser dem nix mehr machen ;.-)

jo, funzt aber nicht! :D

lazarusz
16.12.2004, 18:52
noch was befor du anfängst du installieren
mach mal

gcc --version den wenn du die 3.x hast brauchst den anderen treiber wie für die 2.x

lazarusz
16.12.2004, 18:55
jo, funzt aber nicht!

wie schreibst du es rein alls user du musst das alls root machen ;-)

Lumma
16.12.2004, 18:55
ich habe die geladen


Linux kernel 2.4.18 (gcc version 2.96)

und was mach ich jetzt mit die?
wie kompiliert man?
und da sind so dateien drin wie wlanup, wlandown!
wie startet man die??

lazarusz
16.12.2004, 19:02
soweit ich das sehe kannst die wieder löschen, den knoppix liefert den " Kernel 2.4.27" aus !

sorry wenn ich das jetzt sage, aber bist du dir sicher du willst das machen magst ned mal etwas linux basics lesen damit du mal grob weist was du tust !

aber ich sags dir

1. konsole öffnen
2. su -p
3. welchsle mittels cd in das entpackte verzeichniss welches die treiber enthält
4. folge den install anweisungen die in der readme stehen.
5 . die wlan up und down geschichte machst auch über die konsole
6. du brauchst noch einen zusatz befehl "iwconfig"
7. ifconfig brauchst auch !

lazarusz
16.12.2004, 19:06
so hab schnell mal nachgelesen "iwconfig" brauchst für deinen treiber nicht das machst du dann mit

./wlanup {ap|infra|adhoc}

Lumma
16.12.2004, 19:24
hmm! soll das heißen dass ich es vergessen kann und ich meine WLAN Karte nie zum laufen bringe?

lazarusz
16.12.2004, 19:45
hmm! soll das heißen dass ich es vergessen kann und ich meine WLAN Karte nie zum laufen bringe?


nein aber etwas linux grundlagen währen ned schlecht allso ich schreib hier nochmal alles zusammen wies laut anleitung gehen sollte

1. konsole auf
2. gcc -v damit findest du raus welchen der beiden treiber du verwenden sollst
dann treiber downloaden entpacken
3. su -p
4. mit cd in den ordner gehen der die treiber enthält
5. insmod -f rtl8180_24x.o <-- versuchen ob du es so zum laufen bringts
6. make
7. make install <-- make und make install installieren die treiber in die
maschine
8. /wlanup {ap|infra|adhoc}
./wlandown

infra bedeudet netzwerk mit accspoint
adhoc bedeudet sowas mit 2 computer mittel overcross cabel zusammen hängen.

so probier das mal ich hoffe das hilft dir !

lazarusz
16.12.2004, 19:48
so das ist auch sehr wichtig !
da musst dich noch etwas einlesen in die wlan configuration !


< Set wireless lan MIBs >
This driver uses Wireless Extension as an interface allowing you to set
Wireless LAN specific parameters.
Current driver supports "iwpriv", manipulate driver private ioctls, to set MIBs.

iwpriv wlan0 wlan_para [parameters]=[val]
where

parameter explaination [parameters] [val] constraints
----------------------- ------------- ------------------
Set beacon interval bcnint {20~1000} msec
Set channel number channel {1~14}
Set basic rates basicrates {bit0 = 1Mbps, bit1 = 2Mbps, bit2 = 5.5Mbps, bit3 = 11 Mbps}
Set operational rates oprates {bit0 = 1Mbps, bit1 = 2Mbps, bit2 = 5.5Mbps, bit3 = 11 Mbps}
Set authentication type authtype {opensystem, sharedkey, both<only AP mode>}
Set desired ssid to scan ssid2scan {0~z, less than 32 characters}
Set RTS threshold rtsthres {256~2304}
Set fragment threshold fragthres {256~2304}
Set preamble mode preamble {short,long,auto}
Set network type networktype {infra,adhoc,auto}
Set WEP mode wepmode {off,wep40,wep104}
Set WEP default key ID wepdkeyid {0~3}
Set 1st WEP40 key value wepkey40_1 {0~f, total 10 characters}
Set 2st WEP40 key value wepkey40_2 {0~f, total 10 characters}
Set 3st WEP40 key value wepkey40_3 {0~f, total 10 characters}
Set 4st WEP40 key value wepkey40_4 {0~f, total 10 characters}
Set 1st WEP104 key value wepkey104_1 {0~f, total 26 characters}
Set 2st WEP104 key value wepkey104_2 {0~f, total 26 characters}
Set 3st WEP104 key value wepkey104_3 {0~f, total 26 characters}
Set 4st WEP104 key value wepkey104_4 {0~f, total 26 characters}
Set AP ssid ssid {0~z, less than 32 characters}
Set Mac address macaddr {0~f, total 6 characters}
Set DTIM period dtimperiod {1~255}
Set hidden AP hiddenAP {true,false}
Set mac filter policy addmac {0~f, total 6 characters}
Delete mac filter policy delmac {0~f, total 6 characters}
Set deny mac filter policy denymacaddr {0~f, total 6 characters}
Delete deny mac filter deldenymacaddr {0~f, total 6 characters}
Set sta expired time expired_time {1~100000} *10 msec
Set rate adaptive autorate {true,false}
Print help message help

For example:

iwpriv wlan0 wlan_para bcnint=100
iwpriv wlan0 wlan_para channel=1
iwpriv wlan0 wlan_para basicrates=0xf
iwpriv wlan0 wlan_para oprates=0xf
iwpriv wlan0 wlan_para authtype=opensystem
iwpriv wlan0 wlan_para ssid2scan=testssid
iwpriv wlan0 wlan_para fragthres=512
iwpriv wlan0 wlan_para preamble=long
iwpriv wlan0 wlan_para wepmode=off
iwpriv wlan0 wlan_para wepdkeyid=0
iwpriv wlan0 wlan_para wepkey40_1=0123456789
iwpriv wlan0 wlan_para wepkey104_1=01234567890123456789012345
iwpriv wlan0 wlan_para networktype=infra
iwpriv wlan0 wlan_para ssid=apssid
iwpriv wlan0 wlan_para macaddr=00e04c8180ff
iwpriv wlan0 wlan_para hiddenAP=true
iwpriv wlan0 wlan_para addmac=00e04c8180ff
iwpriv wlan0 wlan_para denymacaddr=00e04c8180ff
iwpriv wlan0 wlan_para help;


Also, you could set parameters as follow:

iwpriv wlan0 wlan_para bcnint=100,channel=1,basicrates=0xf,authtype=opens ystem,ssid2scan=testssid






< Driver status >
The driver status is reported by /proc filesystem.

/proc/rtl8180/status (link status for client mode)
/proc/rtl8180/ap_status (link status for ap

damit stellst du den kannal, verschlüsselung etc.. ein

Lumma
16.12.2004, 20:51
naja, zuerst will ich mal die treiber installieren, danke dir ;)