PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Andauernd Fehler beim Emerge



Flamesword
12.12.2004, 10:44
Hi,

ich hab ein Problem mit meinem Gentoo.
In 5% aller Versuche mit emerge etwas zu installieren, kommt ein ominöser "Error", der angeblich ein "hardware or os problem" ist.
Letztens war es so, also ich z.B. Wine oder Koffice emerge wollte.
Woran kann das liegen?

Grüße

Havoc][
12.12.2004, 10:50
Interessant wäre die genaue Fehlermeldung *g* ;).

Havoc][

Flamesword
12.12.2004, 11:03
msg.c: In function `test_accelerators':
msg.c:3270: internal compiler error: in ix86_address_cost, at config/i386/i386.c:5264
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugs.gentoo.org/> for instructions.
gcc -c -I. -I. -I../../../include -I../../../include -DWINE_NO_DEBUG_MSGS -DWINE_NO_TRACE_MSGS -D_REENTRANT -fPIC -Wall -pipe -mpreferred-stack-boundary=2 -fno-strict-aliasing -gstabs+ -Wpointer-arith -O2 -pipe -march=athlon-xp -o resource.o resource.c
gcc -c -I. -I. -I../../../include -I../../../include -DWINE_NO_DEBUG_MSGS -DWINE_NO_TRACE_MSGS -D_REENTRANT -fPIC -Wall -pipe -mpreferred-stack-boundary=2 -fno-strict-aliasing -gstabs+ -Wpointer-arith -O2 -pipe -march=athlon-xp -o sysparams.o sysparams.c
gcc -c -I. -I. -I../../../include -I../../../include -DWINE_NO_DEBUG_MSGS -DWINE_NO_TRACE_MSGS -D_REENTRANT -fPIC -Wall -pipe -mpreferred-stack-boundary=2 -fno-strict-aliasing -gstabs+ -Wpointer-arith -O2 -pipe -march=athlon-xp -o text.o text.c
gcc -c -I. -I. -I../../../include -I../../../include -DWINE_NO_DEBUG_MSGS -DWINE_NO_TRACE_MSGS -D_REENTRANT -fPIC -Wall -pipe -mpreferred-stack-boundary=2 -fno-strict-aliasing -gstabs+ -Wpointer-arith -O2 -pipe -march=athlon-xp -o win.o win.c
The bug is not reproducible, so it is likely a hardware or OS problem.
make[3]: *** [msg.o] Error 1
make[3]: *** Waiting for unfinished jobs....
../../tools/winebuild/winebuild -D__WINESRC__ -DWINE_NO_DEBUG_MSGS -DWINE_NO_TRACE_MSGS -D_USER32_ -D_WINABLE_ -D_REENTRANT -fPIC -o user.exe.spec.c --heap 65520 --main-module user32.dll --res resources/version16.res --dll ./user.exe.spec
gcc -c -I. -I. -I../../include -I../../include -D__WINESRC__ -DWINE_NO_DEBUG_MSGS -DWINE_NO_TRACE_MSGS -D_USER32_ -D_WINABLE_ -D_REENTRANT -fPIC -Wall -pipe -mpreferred-stack-boundary=2 -fno-strict-aliasing -gstabs+ -Wpointer-arith -O2 -pipe -march=athlon-xp -o user32.dll.dbg.o user32.dll.dbg.c
gcc -c -I. -I. -I../../include -I../../include -D__WINESRC__ -DWINE_NO_DEBUG_MSGS -DWINE_NO_TRACE_MSGS -D_USER32_ -D_WINABLE_ -D_REENTRANT -fPIC -Wall -pipe -mpreferred-stack-boundary=2 -fno-strict-aliasing -gstabs+ -Wpointer-arith -O2 -pipe -march=athlon-xp -o display.drv.spec.o display.drv.spec.c
gcc -c -I. -I. -I../../include -I../../include -D__WINESRC__ -DWINE_NO_DEBUG_MSGS -DWINE_NO_TRACE_MSGS -D_USER32_ -D_WINABLE_ -D_REENTRANT -fPIC -Wall -pipe -mpreferred-stack-boundary=2 -fno-strict-aliasing -gstabs+ -Wpointer-arith -O2 -pipe -march=athlon-xp -o mouse.drv.spec.o mouse.drv.spec.c
gcc -c -I. -I. -I../../include -I../../include -D__WINESRC__ -DWINE_NO_DEBUG_MSGS -DWINE_NO_TRACE_MSGS -D_USER32_ -D_WINABLE_ -D_REENTRANT -fPIC -Wall -pipe -mpreferred-stack-boundary=2 -fno-strict-aliasing -gstabs+ -Wpointer-arith -O2 -pipe -march=athlon-xp -o user.exe.spec.o user.exe.spec.c
make[3]: Leaving directory `/var/tmp/portage/wine-20041019/work/wine-20041019/dlls/user/tests'
make[2]: *** [tests] Error 2
make[2]: *** Waiting for unfinished jobs....
make[2]: Leaving directory `/var/tmp/portage/wine-20041019/work/wine-20041019/dlls/user'
make[1]: *** [user] Error 2
make[1]: Leaving directory `/var/tmp/portage/wine-20041019/work/wine-20041019/dlls'
make: *** [dlls] Error 2

!!! ERROR: app-emulation/wine-20041019 failed.
!!! Function src_compile, Line 79, Exitcode 2


Aufeinmal ist es kein "hardware or os problem" mehr sondern ein "internal compiler error".
Langsam geht mir Gentoo aufn Sack.

devilz
12.12.2004, 11:47
Poste mal bitte deine CFLAGS und deine USE Flags ....

Eventl. solltest du auch mal Memtest laufen lassen .... Ramfehler sind häufiger als man denkt :)

Flamesword
12.12.2004, 11:50
CFLAGS="-O2 -pipe -march=athlon-xp -fomit-frame-pointer"
USE="-gnome -gtk kde qt cups foomaticdb ppds samba"

devilz
12.12.2004, 11:55
CFLAGS="-O2 -pipe -march=athlon-xp -fomit-frame-pointer"
USE="-gnome -gtk kde qt cups foomaticdb ppds samba"


Hmmm ok nix außergewöhnliches ....

Mal nen Memtest gemacht ?

khs
12.12.2004, 13:31
Langsam geht mir Gentoo aufn Sack.

Wetten, mit einer anderen Distribution wird deine kaputte Hardware auch nicht besser laufen?

-khs

Havoc][
12.12.2004, 15:35
Wetten, mit einer anderen Distribution wird deine kaputte Hardware auch nicht besser laufen?
Noch steht ja gar nicht fest obs wirklich an der Hardware liegt. Ausserdem kennst du sicher auch das es Probleme gibt die dich zur Weissglut treiben. Immerhin kann man da zwar sagen: "boa, idiot. Du hast doch vergessen hier xyz einzustellen". Aber das sind ja manchmal so doofe kleine Fehler, die man kaum zurückverfolgen kann. Da wäre dann bessere Fehlertoleranz und bessere/nervigere Fehlermeldungen (vor allem für Neulinge) schon angebracht.

Havoc][

Atomara
12.12.2004, 17:08
Wetten, mit einer anderen Distribution wird deine kaputte Hardware auch nicht besser laufen?

-khs


seltsam wie häufig unter linux die hardware kaputt ist :rolleyes:


in den seltesten fällen ist bei solchen problemen die hardware deffekt , es lieg meistens einfach an den abhängigkeiten

beispiel : msg.o braucht die xyz.o , die ist aber nicht da , deshalb streikt die msg.o

bestes beispiel ist : Speicherzugriffsfehler parachute deployed , bei sdl , niemand weiß warum er auf einmal einen fallschirm abwirft , durch strace konnte ich erfahren dass arts die ursache war .

soundserver abgeschaltet voila , alles geht

Cyber
12.12.2004, 17:23
@Flamesword:

Wie sieht denn dein verfügbarer Plattenplatz aus ? Insbesondere von /var ?
Hast Du zufällig /var/tmp/portage auf ner sep. Partition und diese nicht korrekt eingebunden ?

Flamesword
12.12.2004, 18:03
Habe nur drei Partitionen (/boot, swap und /), bei / sind noch 40% frei, das dürfte genug sein.

devilz
12.12.2004, 18:16
seltsam wie häufig unter linux die hardware kaputt ist :rolleyes:


in den seltesten fällen ist bei solchen problemen die hardware deffekt , es lieg meistens einfach an den abhängigkeiten

beispiel : msg.o braucht die xyz.o , die ist aber nicht da , deshalb streikt die msg.o

bestes beispiel ist : Speicherzugriffsfehler parachute deployed , bei sdl , niemand weiß warum er auf einmal einen fallschirm abwirft , durch strace konnte ich erfahren dass arts die ursache war .

soundserver abgeschaltet voila , alles geht


Magst du so sehen - nur is das Speicherhandling unter Windows anders als unter Linux !

Unter Windows rennt vieles selbst mit defektem RAM noch .... unter Linux nicht (jedenfalls wenn du alles selber baust !)

Havoc][
12.12.2004, 19:33
Magst du so sehen - nur is das Speicherhandling unter Windows anders als unter Linux !

Unter Windows rennt vieles selbst mit defektem RAM noch .... unter Linux nicht (jedenfalls wenn du alles selber baust !)
hm, also ich stimme dir zu, devilz. Der oben genannte Fall kann tatsächlich an einem Speicherfehler hängen. Und das diese zur genüge auftauchen, sollte wohl klar sein. Aber (ohne Windows wieder schlecht zu machen) ich habe eher Probleme unter Windows wenn der RAM defekt ist. Linux umgeht sowas (bis jetzt) ziemlich souverain. Vielleicht hatte ich auch nur Glück aber Windows hängt dann bei mir bei jedem klick auf irgendeinen Button oder kommt einfach nimmer ausm Ruhezustand.

Linux auf Konsole gebootet und funktionierten zumindest Essentielle Programme zum Sichern (wobei, neuer RAM rein und fertig)...

Havoc][

devilz
12.12.2004, 19:38
@Havoc][
Soweit so gut, aber wenn er die Pakete bauen will und die Fehler bekommt isses ja das erste was er testen sollte.

@Flamesword
Hast du nunmal getestet ?

Havoc][
12.12.2004, 19:42
Soweit so gut, aber wenn er die Pakete bauen will und die Fehler bekommt isses ja das erste was er testen sollte.
Jupp. Türlich. Seh ich eigentlich auch so. Wollte nur sagen das ich schon Gegenteiliges bei Windows erlebt habe *g*.

Havoc][

khs
13.12.2004, 12:09
seltsam wie häufig unter linux die hardware kaputt ist :rolleyes:


Wenn der Make-Lauf im Verzeichnis [...]/tests abbricht, und das ohne undefined references und dergleichen, naja, dann wird mein Tip auch weiterhin in Richtung Hardware gehen.

Dass Win sowas toleranter behandelt, ist bekannt. Die Folgen davon auch.

-khs

Flamesword
13.12.2004, 16:33
Hi,

also ich habe heute morgen mal einen Memtest gemacht und es sieht aus als wäre alles in Ordnung.
Also am RAM liegts anscheinend nicht.

Cyber
13.12.2004, 17:35
Hast Du mal parallel zum emergen die /var/log/messages ausgeben lassen ? Vielleicht sind einige Blöcke Deiner Platte im eimer.

Flamesword
18.12.2004, 18:27
Hi,

ich glaube ich habe das Problem gelöst.
Es lag an der Hardware. Sie war nicht beschädigt, aber zu warm!
Ich hatte anscheinend immer so 65-75°C CPU-Temperatur, was zu viel ist.
Nach einigen Umbauten komme ich nun auf 30-45°C max. 50°C bei mehrstündiger Vollbelastung.
Die hohe Temperatur erklärt auch die häufigen Einfrierungen vom System.

Grüße,
Flamesword

Atomara
21.12.2004, 01:33
wie kann man die temperatur abfragen ?

Flamesword
21.12.2004, 12:27
Mit Programmen wie z.B. mbmon:
http://freshmeat.net/projects/xmbmon/

khs
21.12.2004, 14:25
Mit Programmen wie z.B. mbmon:
http://freshmeat.net/projects/xmbmon/

Wenn man uebrigens mbmon im Daemon-Modus startet und ihm einen Port mitgibt, kann man ihn mit netcat auch scriptgesteuert zum Beispiel aus superkaramba heraus abfragen.

-khs, superkaramba-Fan