PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Gentoo + Grub Error #13



Ph0eNiX
07.11.2004, 20:56
hi hab gentoo Stage 1 installation mit grub bootloader. ich konfigurierte ihn so wie es im manual steht. Beim boot: Error #13....

Mit lilo wenn ich /sbin/lilo mache kommt der Kernel sei zu gross!!!

Kernel: gentoo-dev-sources (kernel-2.6.7)

ich machs unter VMWare. Partitioniert wie im manual.

PLZ help

thx Ph0eNiX

devilz
07.11.2004, 21:28
Mit welchen Befehlen hast du grub installiert ?
Wo liegt deine /boot und wo deine / Partition ?

Ph0eNiX
08.11.2004, 10:59
hi,

hatt nicht so viel zeit gehabt desshalb so ner dumme erklärung :)

mit: emerge grub und nano -w /boot/grub/grub.conf

meine grub.conf (hab gentoo-dev-sources Kernel 2.6.7):

default 0
timeout 5
splashimage=(hd0,0)/grub/splash.xpm.gz
title=Gentoo Linux 2.6.7
root (hd0,0)
kernel (hd0,0)/kernel-2.6.7 root=/dev/hda3




Einträge in /etc/fstab:

/dev/hda1 /boot ext2 noauto,noatime 1 2
/dev/hda2 none swap sw 0 0
/dev/hda3 / ext3 noatime 0 1
/dev/cdroms/cdrom0 /mnt/cdrom auto noauto,user 0 0

none /proc proc defaults 0 0
none /dev/shm tmpfs nodev,nosuid,noexec 0 0


Meine Partitionen:

/dev/hda1 ext2 32M Boot Partition
/dev/hda2 (swap) 512M Swap Partition
/dev/hda3 ext3 Rest der Festplatte Root Partition

khs
08.11.2004, 16:03
Error 13 ist offenbar ein "falsches Binaerformat"-Fehler. Welche Datei hast du nach /boot/kernel-2.6.7 kopiert? ~/arch/i386/boot/bzImage? Oder vielleicht doch die Datei vmlinux aus diesem Verzeichnis? Wenn ja, probiers mit bzImage nochmal.

-khs

PS: ext2 ist fest einkompiliert?