PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : mldonkey-Installation bricht ab



BiBe
25.10.2004, 22:16
Hallo,

ich bin, wie mein Forumstitel schon sagt, ein absoluter Linux Grünschnabel. Ein bekannter Linuxprofi hat mir ein gentoo-System eingerichtet, auf welchem ich derzeit ein wenig bastele.

Eben wollte ich das Programm "mldonkey" installieren. Bei der Konfiguration mit "./configure" wollte das Skript zwei weitere Programme ("lablgtk" und "Caml") herunterladen. Das hat auch beides gut geklappt, nur konnte leider die Konfiguration von mldeonkey nicht abgeschlossen werden. Sie endete mir folgenden Zeilen:



Building dependencies fails: try: 'make depend' or 'gmake depend'
./configure: line 4574: /sbin:/bin:/usr/sbin:/usr/bin: No such file or directory
./configure: line 4575: syntax error near unexpected token `do'
./configure: line 4575: `do'
root@gentoo1 mldonkey-2.5.28 #


Kann mir irgendjemand sagen, was mir das sagt? Ist wirklich das Quellscript von mldonkey fehlerhaft oder funktioniert es nur mit gentoo nicht korrekt?

Bin für jeden Tipp dankbar.

Viele Grüße

Birger

devilz
25.10.2004, 22:21
Probier doch mal ein "emerge net-p2p/mldonkey"

BiBe
25.10.2004, 23:04
Hallo,

vielen Dank für den Tipp. In der emerge-Datenbank hatte ich zwar auch gesucht, allerdings fehlerhaft.

Leider bricht die mldonkey Installation aus der emerge-Datenbank aber auch ab. Diesmal allerdings mit einer auch mir logisch erscheinenden Fehlermeldung:



--17:00:37-- http://savannah.nongnu.org/download/mldonkey/release-2.5-4/official/mldonkey-2.5-4.tar.gz
=> `/usr/portage/distfiles/mldonkey-2.5-4.tar.gz'
Resolving savannah.nongnu.org... 199.232.41.4
Connecting to savannah.nongnu.org[199.232.41.4]:80... connected.
HTTP request sent, awaiting response... 404 Not Found
17:00:38 ERROR 404: Not Found.

!!! Couldn't download mldonkey-2.5-4.tar.gz. Aborting.


Werde morgen noch einmal versuchen, ob die Datei wieder verfügbar ist. Habe ich Alternativen für den Fall, dass dies auch nicht klappt?

Nochmals vielen Dank und viele Grüße

Birger

Freakazoid
25.10.2004, 23:46
Ja hier: http://download.berlios.de/pub/mldonkey/spiralvoice/mldonkey-2.5-16t.static.i386-Linux.rar

Einfach entpacken und fertig ist es.

Mußt nur noch ./mlnet ausführen, dann läufts.

Als GUI empfehl ich Dir Sancho.

blue
26.10.2004, 13:35
schon mal mldonkey ohne gtk kompiliert?
also
USE="-gtk" emerge net-p2p/mldonkey

blue

BiBe
26.10.2004, 19:13
Hallo,

vielen Dank für den Link zu dem rar-Archiv. Damit hat's nach einigen Anfängerproblemen wunderbar geklappt...

Bis später !

Birger

SethGecko
09.11.2004, 08:28
emerge amule ... :)

soll deutchlich besser sein als mldonkey und wird noch weiterentwickelt.