Zuordnung von usb-Gerät zu device file

Dieses Thema im Forum "Linux OS" wurde erstellt von supersucker, 30.11.2006.

  1. #1 supersucker, 30.11.2006
    Zuletzt bearbeitet: 30.11.2006
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Hi,

    wie kann ich den rausfinden welches device file unter /dev einem usb-gerät zugeordnet ist?

    Hintergrund ist der, das ich mir einen neuen mp3-Player (Anschluß über usb) gekauft habe mit Bediensoftware, die natürlich wieder nur für Windows ist (wer hätte das gedacht....).

    Also wollte ich das Ding einfach mounten und mp3s raufkopieren, nun scheiterts aber schon am mounten:

    dmesg sagt nach dem Einstecken:

    Code:
    dmesg | tail -n 3
    [17179626.720000] rausb0: no IPv6 routers present
    [17188415.432000] cdrom: This disc doesn't have any tracks I recognize!
    [17193872.440000] usb 5-3: new high speed USB device using ehci_hcd and address 3
    
    Soweit so gut, lsusb sagt nun:

    Code:
    lsusb
    Bus 005 Device 003: ID 041e:4150 Creative Technology, Ltd
    Bus 005 Device 002: ID 050d:7050 Belkin Components F5D7050 ver 1000 WiFi
    Bus 005 Device 001: ID 0000:0000
    Bus 001 Device 001: ID 0000:0000
    Bus 004 Device 001: ID 0000:0000
    Bus 003 Device 001: ID 0000:0000
    Bus 002 Device 001: ID 0000:0000
    
    (Belkin ist mein Wlan-Stick)

    So, diese Angaben helfen mir auch nicht dabei rauszufinden welches device ich denn nun mounten soll.

    ls hilft mir auch nicht weiter.....

    Code:
    ls -al /dev/us*
    ls: /dev/us*: No such file or directory
    
    Code:
    ls -al /dev/sd*
    ls: /dev/sd*: No such file or directory
    
    Irgendjemand ne Idee wie ich nun rauskriege, welches device-file nach dem Einstecken angelegt wurde, damit ich das blöde Ding mounten kann und meine Musik draufziehen kann?

    Danke für jeden Tip!
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. rikola

    rikola Foren Gott

    Dabei seit:
    23.08.2005
    Beiträge:
    2.133
    Zustimmungen:
    0
    Welche Distribution?
    Ist usb_storage geladen?
    Benutzt Du udev?

    Leg mal /dev/sda1 an ( mknod /dev/sda b 8 0; mknod /dev/sda1 b 8 1)
    und steck dann das Geraet nochmal ein. Und warte ein paar Sekunden, bevor Du dmesg eingibst.
     
  4. MrBoe

    MrBoe Routinier

    Dabei seit:
    13.06.2006
    Beiträge:
    399
    Zustimmungen:
    0
    Ort:
    braunschweig/nds/de/world
    So:
     
  5. #4 supersucker, 30.11.2006
    Zuletzt bearbeitet: 30.11.2006
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Ubuntu Dapper Drake.

    War nicht geladen, habs jetzt geladen:

    Code:
    root@fuckup:~# modprobe usb_storage
    root@fuckup:~# lsmod | grep usb_storage
    usb_storage            74304  0
    usbcore               130820  7 usb_storage,ndiswrapper,islsm_usb,rt2570,ehci_hcd,uhci_hcd
    scsi_mod              139496  2 usb_storage,libata
    
    Ist mir allerdings nicht klar, mein Usb-Stick (reiner Datenstick) wurde auch immer ohne usb_storage erkannt....

    Ich nutze Kernel

    Code:
     uname -r
    2.6.15-27-386
    
    da meines Wissens devfs seit dem 2.6 Kernel genutzt, wäre die Antwort ja.

    Auch der Dämon läuft:

    Code:
     ps aux | grep udev
    root      2200  0.0  0.0   2436   924 ?        S<s  11:32   0:00 /sbin/udevd --daemon
    root     18329  0.0  0.0   2880   812 pts/0    S+   16:49   0:00 grep udev
    


    Hab ich gemacht:

    Code:
    mknod /dev/sda b 8 0
    mknod /dev/sda1 b 8 1
    

    Hab ich gemacht, d.h. Player raus, wieder rein, paar Sekunden gewartet, dann meint dmesg:

    Code:
     dmesg | tail -n 3
    
    [17198680.108000] usb 5-1: USB disconnect, address 4
    [17198686.648000] usb 5-1: new high speed USB device using ehci_hcd and address 5
    [17198720.036000] Driver 'sd' needs updating - please use bus_type methods
    
    Ok, relevant scheint hier:

    Code:
    Driver 'sd' needs updating - please use bus_type methods
    
    So, google ich mal danach krieg ich zwar ein paar Hits, aber nichts was mich wirklich weiterbringt. Entweder taucht die Meldung im Zusammenhang mit anderen Problemen auf oder die Leute haben auf ihre Frage was sie tun sollen keine Antwort gekriegt......

    Anyway, hab dann auch mal versucht zu mounten in der Hoffnung das ich das ignorieren kann:

    Code:
    mount -t auto /dev/sda1 /mnt/usbstick/
    mount: you must specify the filesystem type
    
    ok, im Handbuch steht nix dazu, aber da Win-Software dabei ist gehe ich mal von ntfs aus:

    Code:
    mount -t ntfs /dev/sda1 /mnt/usbstick/
    mount: /dev/sda1 is not a valid block device
    
    Alles klar, das wäre auch zu einfach gewesen......mit "mount -t vfat" krieg ich das gleiche Ergebnis.

    Es scheint also wirklich mit

    Code:
    Driver 'sd' needs updating - please use bus_type methods
    
    zu tun zu haben, oder evtl doch nicht?

    Bin ratlos nun, jemand einen Tip oder ne Idee?

    Nachtrag:

    Code:
    cat /proc/partitions
    major minor  #blocks  name
    
       3     0   40146624 hda
       3     1     192748 hda1
       3     2    6835657 hda2
       3     3    6835657 hda3
       3     4          1 hda4
       3     5    1461883 hda5
       3     6   24820393 hda6
     253     0     192748 dm-0
     253     1    6835657 dm-1
     253     2    6835657 dm-2
     253     3    1461883 dm-3
     253     4   24820393 dm-4
    
    
     
  6. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Die Fehlermeldung wegen dem sd-Device bekommst du, weil du das Device per Hand angelegt hast. Im Normalfall ist das Aufgabe des Kernel-Moduls.
    Wenn du deinen USBStick ansteckst, wird das Modul usb_storage garantiert geladen, sonst würde der garnicht funktionieren.
    Die Meldung "cdrom: This disc doesn't have any tracks I recognize!" bekommst du wahrscheinlich, weil ide-scsi nicht geladen ist. Diese Meldung kommt vom Automounter. Hättest du allerdings auch selbst rausfinden können, wenn du mal nach der Meldung gegooglet hättest.
     
  7. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  8. #6 supersucker, 30.11.2006
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Sorry, aber der Beitrag war ja jetzt gerade mal komplett sinnlos, oder?

    Die Meldung

    Code:
     "cdrom: This disc doesn't have any tracks I recognize!" 
    
    kam weil ich halt noch gleichzeitig was am cd-Laufwerk rumgefummelt hab.

    Nur ging es ja überhaupt nicht um mein cd-Laufwerk sondern um meinen MP3-Player.

    Also warum zur Hölle hätte ich nach der Meldung googlen sollen, wenn ich weder gefragt habe was sie bedeutet noch sie mich überhaupt interessiert?

    Die stand halt zufällig in meinem dmesg-Auszug drin, mehr nicht.

    So, aber mal zu meinem Problem zurückzukommen, noch jemand ne Idee?
     
  9. MrBoe

    MrBoe Routinier

    Dabei seit:
    13.06.2006
    Beiträge:
    399
    Zustimmungen:
    0
    Ort:
    braunschweig/nds/de/world
    Hmm, wenn bei der Auflistung der Partitionen der Stick nicht dabei ist, dann kannst du ihn auch nicht mounten. Ich gehe mal davon aus, dass auch dem Stick kein NTFS drauf ist. Hab ich noch nie gehabt, allerdinga hatte ich auch noch nie einen Stick über 2GB. Im Nomalfall ist da FAT32 drauf. Also unter Linux vfat.

    Ich weiss leider auch nicht weiter, aber bevor du in /proc/partitions nichts gelistet bekommst, kannst du das Teil definitiv nicht mounten.
     
Thema:

Zuordnung von usb-Gerät zu device file

Die Seite wird geladen...

Zuordnung von usb-Gerät zu device file - Ähnliche Themen

  1. CUPS - Treiber für Windows Klienten in Petto - zuordnung unbekannt?

    CUPS - Treiber für Windows Klienten in Petto - zuordnung unbekannt?: [GELÖST] CUPS - Treiber für Windows Klienten in Petto - zuordnung unbekannt? Hallo Gemeinde, ich mache es möglichst kurz : -> CUPS läuft,...
  2. Dateizuordnung Jameica-Hibiscus unter KDE

    Dateizuordnung Jameica-Hibiscus unter KDE: Hallo, Wenn ich meine Kontoauszüge mittels PDF Anzeigen lasse, startet Hibiscus das Programm Gimp. In KDE 4.2 (Installiert) ist die...
  3. Konqueror ohne Dateizuordnungen unter Openbox

    Konqueror ohne Dateizuordnungen unter Openbox: Hi, Und hier präsentiere ich mal wieder ein typ. Der_Da_93-Problem: Also unter KDE kann ich mit dem Konqueror ganz normal Dateien durch klicken...
  4. [GELÖST] Firefox; Filetype Zuordnung

    [GELÖST] Firefox; Filetype Zuordnung: Hallo Forum, bin beim schreiben eben selber auf die Lösung gekommen. Mein Problem war das ich im Firefox/Iceweasel ein Dateityp einer Anwendung...
  5. Durcker:Treiberzuordnung nach Neustart weg

    Durcker:Treiberzuordnung nach Neustart weg: Hallo Leute! Ich habe folgendes Problem: Ein SLES 9 mit Samba 3 dient mir als Printserver in der Firma. Alle Treiber sind erfolgreich...