Xserver zerschossen, Ati Treiber macht probleme

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von Emess, 09.11.2006.

  1. Emess

    Emess Turmspringer

    Dabei seit:
    08.10.2006
    Beiträge:
    1.045
    Zustimmungen:
    0
    Ort:
    Odenwald
    Habe das Problem von meinem letzten posting eingrenzen können ( 5 oder 6 postings weiter unten).
    Habe also den Xserver mittels tasksel deinstalliert und danach neu installiert.
    nach einem startx versucht Linux x zustarten bricht aber ab und zeigt an, dass Ati Radeon Probleme macht.
    Würde euch auch gerne einen Auszug aus Xorg.0.log posten.
    Nur wie bekomme ich die Datei auf eine Diskette oder USB-Stick. Ich weiß das sollten Grundlagen sein und ich will sie ja ach mit eure Hilfe erlernen.
    Also cat geht bei mir nicht nano geht zwar, aber keine Ahnung wie die Datei auf eine Diskette bekomme. Vi: no comment!
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 Goodspeed, 09.11.2006
    Goodspeed

    Goodspeed Foren Gott
    Moderator

    Dabei seit:
    21.04.2004
    Beiträge:
    4.165
    Zustimmungen:
    1
    Ort:
    Dresden
    Mit ein bißchen suchen hier im Forum hättest Du das schon gefunden ...
    1. USB-Stick anstecken
    2. Mit "fdisk -l" schauen, welches Device er bekommen hat und ob er eventuell partitioniert ist (sda oder sda1 oder sdb oder ...
    3. USB-Stick mounten: "mount /dev/sdXY /mnt"
    4. Log kopieren: " cp /var/log/Xorg.0.log /mnt"
    5. Aushängen: "umount /mnt"
    6. USB-Stick abziehen ...

    Und ich glaube nicht, dass "cat" nicht geht ...

    P.S.: root-Rechte wären für obiges nicht schlecht ...
     
  4. Emess

    Emess Turmspringer

    Dabei seit:
    08.10.2006
    Beiträge:
    1.045
    Zustimmungen:
    0
    Ort:
    Odenwald
     
  5. #4 Lumpi, 09.11.2006
    Zuletzt bearbeitet: 09.11.2006
    Lumpi

    Lumpi Haudegen

    Dabei seit:
    14.06.2006
    Beiträge:
    663
    Zustimmungen:
    0
    Ort:
    Dessau
    Hallo

    mount & copy einer Datei

    mount /dev/fd0 /dein/mountpunkt
    /dein/mountpunkt muss existieren..
    wenn nicht schon getan mit
    mkdosfs /dev/fd0
    "schnell-formatieren"
    nun
    cp /dein/verzeichnis/datei.log /dein/mountpunkt
    datei wird kopiert...
    kopieren "per cat"
    cat /verzeichnis/datei > /dein/mountpunkt/ausgabedatei
    nun noch ein
    umount /dein/mountpunkt
    Floppy wird abgehängt
    Ende

    Gruß Lumpi
     
  6. #5 Fusselbär, 09.11.2006
    Fusselbär

    Fusselbär FreeBSD Noobie

    Dabei seit:
    02.08.2004
    Beiträge:
    198
    Zustimmungen:
    0
    Wo bitte ist der Unixboard Briefkasten? (Zum Einwurf von USB Sticks usw.)

    Hallo Emess,

    warum in aller Welt willst Du die Log Datei
    auf eine Diskette oder einen USB Stick bekommen.
    Willst du die Diskette oder den USB Stick etwa
    an das Unixboard einschicken? :think:

    Nur weil gerade mal kein X-Server läuft,
    ist so ein Linux doch nicht hilflos!
    Gehste eben ohne X-Server ins Forum
    und postest halt mit einem anderem
    Webbrowser.
    Lynx, Links oder Elinks wären so Kandiadaten
    mit denen Du das machen kannst.

    Wenn Dir die Maus ohne X-Server zu sehr fehlt,
    nimmste halt gpm unter Linux oder moused unter FreeBSD.
    Damit kannste dann ganz bequem copy und paste machen.

    Und wenn Du zu sehr schiss ohne X-Server hast,
    schlichtweg ein bißchen was grafisches brauchst,
    um Dich wohlzufühlen,
    nimmte halt den mc (Midnight Commander) zuhilfe.

    Wenn Du was wissen willst, fragste einfach das manual:
    Code:
    man [I]das_was_interessiert[/I]
    
    Suchen kann man mit
    Code:
    apropos [I]was_gesucht_wird[/I]
    

    Gruß, Fusselbär
     
  7. Emess

    Emess Turmspringer

    Dabei seit:
    08.10.2006
    Beiträge:
    1.045
    Zustimmungen:
    0
    Ort:
    Odenwald
    Bei Kopieren mit cp
    cp /var/log/Xorg.0.log /dev/fd0/media/floppy0/Xorg.0.log
    Meldung
    Xorg.0.log ist kein Verzeichnis. Das gleich passiert auch mit cat.
     
  8. Emess

    Emess Turmspringer

    Dabei seit:
    08.10.2006
    Beiträge:
    1.045
    Zustimmungen:
    0
    Ort:
    Odenwald

    Hallo Fusselbär, ich bin sicher dass Linux auch ohne bunte Oberfäche online gehen kann.
    Doch mir fehlen dazu die höheren Weihen.
    Ich werd daran arbeiten, versprochen. Doch im Augenblick ist das für einen bis vor kurzem nur Windowsuser noch etwas hoch.:think:
     
  9. #8 kbdcalls, 09.11.2006
    kbdcalls

    kbdcalls Master of Universe

    Dabei seit:
    16.10.2006
    Beiträge:
    518
    Zustimmungen:
    0
    Das das in Hose geht ist klar :D . Das /dev/fd0 darf garnicht angegeben werden.

    Erst mountet man die Disktette

    Code:
    mount /dev/fd0 /media/floppy0
    Und dann kopiert man die Datei.

    Code:
    cp /var/log/Xorg.0.log  /media/floppy0/Xorg.0.log
    Voraussetzung bei dem Ganzen ist das der Mountpoint existiert . ANsonsten geht auch nicht. Aber das sollte klar sein.
     
  10. Emess

    Emess Turmspringer

    Dabei seit:
    08.10.2006
    Beiträge:
    1.045
    Zustimmungen:
    0
    Ort:
    Odenwald
    Auch das klappt nicht in meiner fstab steht folgendes:
    /dev/fd0 /media/floppy0 auto rw,usr,noauto
    /dev/sda1 /mnt vfat defaults noauto usr,uid=1000,gid=1000,unmask=022

    also
    cp /var/log/Xorg.0.log /media/floppy0/Xorg.0.log
    gibt Meldung "Xorg.0.log ist kein Verzeichniss" aus
     
  11. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  12. #10 kbdcalls, 09.11.2006
    Zuletzt bearbeitet: 09.11.2006
    kbdcalls

    kbdcalls Master of Universe

    Dabei seit:
    16.10.2006
    Beiträge:
    518
    Zustimmungen:
    0
    Hätte ja sein das ich jetzt vertan hätte. Habs einfach mal so per Copy & Paste kopiert und Return gedrückt.

    Code:
    matthias@biljana:~$ su
    root@biljana:/home/matthias# cp /var/log/Xorg.0.log /media/floppy0/Xorg.0.log
    root@biljana:/home/matthias# dir /media/floppy
    floppy/      floppy0/     floppyu1440/
    root@biljana:/home/matthias# dir /media/floppy0/Xorg.0.log  -l
    -rw-r--r-- 1 root root 38006 2006-11-09 21:44 /media/floppy0/Xorg.0.log
    root@biljana:/home/matthias#
    
    Und wie du siehst funtionierts. Nur mit vorhandenem Verzeichnis. Die Diskette hab ich nicht gemountet. Allerdings bevor du die Diskette entfernst mußt du sie unmounten.

    umount /dev/fd0

    Erst gann wird die Datei physikalisch auf die Diskette gechrieben. Bevor das nicht passiert ist befindet die sich im Cache. Und nicht auf Diskette. Das wäre bei einem USBstick nicht anders.
     
  13. Emess

    Emess Turmspringer

    Dabei seit:
    08.10.2006
    Beiträge:
    1.045
    Zustimmungen:
    0
    Ort:
    Odenwald
    umount /dev/fd0

    kleine Ursache, große Wirkung. Wieder was gelernt!! :D :D :D :D :D

    Hoffe wir können jetzt an mein eigentliches Problem mit dem Xserver voran kommen.
    Hab en neuen Thread aufgemacht
     
Thema:

Xserver zerschossen, Ati Treiber macht probleme

Die Seite wird geladen...

Xserver zerschossen, Ati Treiber macht probleme - Ähnliche Themen

  1. xserver startet nicht: no screens

    xserver startet nicht: no screens: Hallo Hab wohl bei einem meiner Debian-Sid System den xserver zerschossen. Screens not found. nvidia-kernel-dkms ist instaliert,...
  2. Angepasste Minimal-GUI xserver-xorg fvwm2

    Angepasste Minimal-GUI xserver-xorg fvwm2: Moin, ich habe bisher tiefgreifende Erfahrung auf der Kommandozeile, bin aber ein Dummchen für die Linux GUI, es gab einen anderen Thread,...
  3. CentOS - nxserver - keyboard problem

    CentOS - nxserver - keyboard problem: :hilfe2: Hallo zusammen. Zuerst mal Angaben zum System: CentOS release 5.5 (final) nxserver, client und node von der Homepage (gestern...
  4. Linuxserver Debian 4.0 fehlermeldung

    Linuxserver Debian 4.0 fehlermeldung: hi hab da mal ne frage hab mir nen server bestellt, (bevor kommt hast du ahnung von linux) habe an meinem home server (ebenfalls linux debian...
  5. xserver update kein x mehr mit mobile radeon

    xserver update kein x mehr mit mobile radeon: Hallo, hoffentlich kann mir hier eine helfen. Nach einem "aptitude upgrade" ist X ( bei mir kde4) nicht mehr gestartet. Nachdem ich mir die...