Xpm und Imlib2 in Fluxbox aktivieren

Dieses Thema im Forum "Sonstige Window Manager" wurde erstellt von Spot, 06.05.2007.

  1. Spot

    Spot Waldgänger

    Dabei seit:
    15.03.2007
    Beiträge:
    113
    Zustimmungen:
    0
    Hallo ! :)

    Wollte gerne mal das hinzufügen von Icons im Fluxbox-Menü ausprobieren.
    Doch nach einiger Lektüre im Internet (besonders der Fluxbox wiki) und der Ausgabe von

    Code:
    fluxbox -i
    in der Konsole musste ich feststellen.

    Ich habe Fluxbox ohne XPM und IMLIB2 kompiliert :(

    Code:
    Fluxbox version: 1.0rc3
    Compiled: Apr  9 2007 17:21:25
    Compiler: GCC
    Compiler version: 4.1.1 20060724 (prerelease) (4.1.1-3mdk)
    
    [...]
    
    Compiled options [B](- => disabled):[/B]
    -DEBUG
    EWMH
    GNOME
    [B]-IMLIB2[/B]
    KDE
    -NLS
    REMEMBER
    RENDER
    SHAPE
    SLIT
    TOOLBAR
    XFT
    -XINERAMA
    XMB
    [B]-XPM[/B]
    
    Wie kann ich jetzt die XPM und IMLIB2 Unterstützung nachträglich aktivieren ?
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 Wolfgang, 06.05.2007
    Wolfgang

    Wolfgang Foren Gott

    Dabei seit:
    24.04.2005
    Beiträge:
    3.978
    Zustimmungen:
    0
    Ort:
    Erfurt
    Hallo
    Indem du das nochmal mit den gewünschten Optionen kompilierst.

    Gruß Wolfgang
     
  4. #3 Spot, 06.05.2007
    Zuletzt bearbeitet: 06.05.2007
    Spot

    Spot Waldgänger

    Dabei seit:
    15.03.2007
    Beiträge:
    113
    Zustimmungen:
    0
    Alles klar, dann gehts wohl nicht andersn.

    Danke für die Hilfe ;)
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    Seltsam, ich habe fluxbox mit
    Code:
    ./configure --enable-xpm --enable-imlib2
    kompiliert und trotzdem sind xpm und imlib2 immer noch deaktviert...

    Code:
    [ich@localhost ~]$ fluxbox -i
    Fluxbox version: 1.0rc3
    Compiled: May  6 2007 18:14:52
    Compiler: GCC
    Compiler version: 4.1.1 20060724 (prerelease) (4.1.1-3mdk)
    
    Defaults:
        menu: /usr/local/share/fluxbox/menu
       style: /usr/local/share/fluxbox/styles/Clean
        keys: /usr/local/share/fluxbox/keys
        init: /usr/local/share/fluxbox/init
    
    Compiled options (- => disabled):
    -DEBUG
    EWMH
    GNOME
    -IMLIB2
    KDE
    -NLS
    REMEMBER
    RENDER
    SHAPE
    SLIT
    TOOLBAR
    XFT
    -XINERAMA
    XMB
    -XPM
    
     
  5. #4 gropiuskalle, 06.05.2007
    gropiuskalle

    gropiuskalle terra incognita

    Dabei seit:
    01.07.2006
    Beiträge:
    4.857
    Zustimmungen:
    0
    Ort:
    Berlin
    Installiere Dir mal die devels dazu ('xorg-x11-libXpm-devel' & 'imlib2-devel').
     
  6. Spot

    Spot Waldgänger

    Dabei seit:
    15.03.2007
    Beiträge:
    113
    Zustimmungen:
    0
    Ich habe jetzt folgende Pakete installiert:

    Code:
    imlib2-devel
    libxpm4
    libxpm4-devel
    libxpm4-static-devel
    Jetzt zeigt fluxbox -i:

    Code:
    [...]
    -DEBUG
    SLIT
    TOOLBAR
    XPM
    -IMLIB2
    GNOME
    KDE
    EWMH
    REMEMBER
    SHAPE
    XFT
    XMB
    
     
  7. #6 gropiuskalle, 06.05.2007
    gropiuskalle

    gropiuskalle terra incognita

    Dabei seit:
    01.07.2006
    Beiträge:
    4.857
    Zustimmungen:
    0
    Ort:
    Berlin
    Hmmmm.... und wenn Du vor dem Kompilieren ein 'updatedb' ausführst?
     
  8. Spot

    Spot Waldgänger

    Dabei seit:
    15.03.2007
    Beiträge:
    113
    Zustimmungen:
    0
    Muss ich das so eingeben:

    Code:
    [root@localhost fluxbox-1.0rc3]# updatedb
    ?

    Wenn ja, dann kommt:

    Code:
    /usr/bin/slocate: option requires an argument -- l
     
  9. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  10. #8 Wolfgang, 06.05.2007
    Wolfgang

    Wolfgang Foren Gott

    Dabei seit:
    24.04.2005
    Beiträge:
    3.978
    Zustimmungen:
    0
    Ort:
    Erfurt
    Hast du vorher das andere (alte) entfernt?
    Gibt es beim Kompilieren Fehler?

    Stell sicher, dass es wirklich die Version ist, die du neu kompiliert hast.

    Gruß Wolfgang
     
  11. #9 Spot, 06.05.2007
    Zuletzt bearbeitet: 06.05.2007
    Spot

    Spot Waldgänger

    Dabei seit:
    15.03.2007
    Beiträge:
    113
    Zustimmungen:
    0
    Das andere (alte) habe ich nicht gelöscht.
    Beim Kompilieren gibt es keinen Fehler.

    Und es ist Version 1.0rc3 die ich kompiliert habe.

    €: Habe jetzt noch einmal neu kompiliert - und jetzt geht es ! :)

    Vielen Danke für eure Hilfe ! :)
     
Thema:

Xpm und Imlib2 in Fluxbox aktivieren

Die Seite wird geladen...

Xpm und Imlib2 in Fluxbox aktivieren - Ähnliche Themen

  1. Fluxbox: Neue Version 1.3.6 korrigiert Fehler

    Fluxbox: Neue Version 1.3.6 korrigiert Fehler: Fast vier Jahre nach der stabilen Version 1.3 und fast zwei Jahre nach der letzten Version 1.3.5 haben die Entwickler des schlanken...
  2. Fluxbox Schriften unscharf

    Fluxbox Schriften unscharf: Hallo, habe mir letzte Woche Slackware 13.1 mit Fluxbox auf meinem alten Rechner installiert. Aus irgend einem Grund ist die Schriftdarstellung...
  3. Ubuntu 9.10 minimal Autologin und X starten (Fluxbox)

    Ubuntu 9.10 minimal Autologin und X starten (Fluxbox): Hallo, ich habe eine Ubuntu 9.10 minimal Installation und muss nach dem einloggen Fluxbox mit startx starten. Ich hätte gerne einen Autologin,...
  4. [Fluxbox] Zwei kleine Probleme

    [Fluxbox] Zwei kleine Probleme: Hallo, nutze seit kurzen wieder Fluxbox für Ubuntu und bin soweit eigentlich ziemlich zufrieden. wBar läuft, conky hab ich auch nen schön...
  5. Fluxbox localhost

    Fluxbox localhost: Hallo Leute, also ich bin vor 2 Tage von Gnome auf Fluxbox umgestiegen. Jetzt habe ich mein Webserver (lampp den ich auch unter Gnome...