XP zur Samba-Domaine

Dieses Thema im Forum "Samba" wurde erstellt von flugopa, 08.01.2007.

  1. #1 flugopa, 08.01.2007
    flugopa

    flugopa Der lernwillige

    Dabei seit:
    27.05.2006
    Beiträge:
    739
    Zustimmungen:
    0
    Ort:
    München
    Hallo,

    ich wollte erstmal einen XP-PC zur Domaine hinzufügen und bekomme die Meldung:
    "unbekannter Benutzername oder falsches Kennwort"

    Manuell kann ich mich mit allen Freigaben des Sambaservers verbinden.

    (Ich bastele noch)
    smb.conf
    [global]
    dos charset = UTF-8
    workgroup = NETZWERK
    server string = %T
    interfaces = 192.168.1.11/28
    bind interfaces only = Yes
    log level = 1
    log file = /etc/samba/%m.log
    max log size = 50
    name resolve order = host lmhosts wins bcast
    time server = Yes
    server signing = auto
    max open files = 1000
    printcap name = /etc/printcap
    add user script = /usr/sbin/useradd -d /dev/null -g workstations -s /bin/false -M %u
    delete user script = /usr/sbin/userdel %u
    add group script = /usr/sbin/groupadd %g
    delete group script = /usr/sbin/groupdel %g
    delete user from group script = /usr/sbin/deluser %u %g
    logon script = login.cmd
    logon path = \\%N\profiles\%U
    logon home = \\\\%N\\%U\\profiles
    domain logons = Yes
    os level = 65
    preferred master = Yes
    domain master = Yes
    wins support = Yes
    admin users = admin2, root
    create mask = 0760
    directory mask = 0750
    hosts allow = 192.168.1.10
    hosts deny = 192.168.1.14, 0.0.0.0/0
    max connections = 500
    max reported print jobs = 50
    cups options = raw
    printer name = lexmark111
    vfs objects = recycle

    [homes]
    path = /home/%S
    valid users = %S
    read only = No

    u.s.w.


    Auszug aus XP-PC.log
    [2007/01/08 00:47:05, 0] smbd/service.c:make_connection_snum(773)
    make_connection: connection to IPC$ denied due to security descriptor.


    Also, wahrscheinlich stehe ich im Wald und sehe kein Baum.

    Gruß
    Flugopa
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 AndreasMeyer, 08.01.2007
    AndreasMeyer

    AndreasMeyer FreeBSD 6.1

    Dabei seit:
    16.07.2005
    Beiträge:
    48
    Zustimmungen:
    0
  4. #3 flugopa, 08.01.2007
    flugopa

    flugopa Der lernwillige

    Dabei seit:
    27.05.2006
    Beiträge:
    739
    Zustimmungen:
    0
    Ort:
    München
  5. #4 Klein_Karlchen, 13.01.2007
    Klein_Karlchen

    Klein_Karlchen Jungspund

    Dabei seit:
    28.04.2006
    Beiträge:
    11
    Zustimmungen:
    0
    Was fürn Backend nutz du? Hast du ne Account für den Rechner angelegt?
     
  6. #5 flugopa, 13.01.2007
    flugopa

    flugopa Der lernwillige

    Dabei seit:
    27.05.2006
    Beiträge:
    739
    Zustimmungen:
    0
    Ort:
    München
    Setze gerade den Rechner mit Fedora6 neu auf.
    Backend? Samba bringt doch bereits viele Voreinstellungen mit; dache ich.
    siehe unter testparm -v|more

    Einen Account für den Windowsrechner hatte ich nicht angelegt, weil ich davon ausgegangen bin, das dieser autom. angelegt wird sobald er der Domaine beitritt, oder? So ist es eigentlich seit NT4, oder?
     
  7. #6 pitschi5, 13.01.2007
    pitschi5

    pitschi5 ***BOFH

    Dabei seit:
    30.04.2005
    Beiträge:
    81
    Zustimmungen:
    0
    Ort:
    Wasserliesch, Germany
    wenn du das in der smb.conf konfiguriert hast, dann können die Rechner auch automatisch beitreten.

    so long....
     
  8. #7 Klein_Karlchen, 13.01.2007
    Klein_Karlchen

    Klein_Karlchen Jungspund

    Dabei seit:
    28.04.2006
    Beiträge:
    11
    Zustimmungen:
    0
    okay, die Rechner legen sich selber an. Das ist möglich. Aber hat du von Hand ne Account für root angelegt? (smbpasswd -a root)
     
  9. #8 flugopa, 13.01.2007
    Zuletzt bearbeitet: 13.01.2007
    flugopa

    flugopa Der lernwillige

    Dabei seit:
    27.05.2006
    Beiträge:
    739
    Zustimmungen:
    0
    Ort:
    München
    Hatte ich nicht gemacht, weil ich dachte: "... user "admin2" ist Mitglied der Gruppe root auf der Linuxkiste..."

    Hier mal die aktuelle smb.conf:

    [global]
    workgroup = NETZWERK
    server string = %T
    security = DOMAIN
    log file = /etc/samba/%m.log
    max log size = 50
    time server = Yes
    add user script = /usr/sbin/useradd %u
    delete user script = /usr/sbin/userdel %u
    add group script = /usr/sbin/groupadd %g
    delete group script = /usr/sbin/groupdel %g
    delete user from group script = /usr/sbin/deluser %u %g
    add machine script = /usr/sbin/adduser -n -g machines -c Machine -d /dev/null -s /bin/false %u
    os level = 99
    preferred master = Yes
    domain master = Yes
    dns proxy = No
    wins support = Yes
    hosts allow = 192.168.1.10, 192.168.1.11, 127.

    [homes]
    path = /home/%S
    valid users = %S
    write list = %S
    read only = No

    [root]
    path = /
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    Wenn ich XP in die Domain Netzwerk reinhängen will kommt sofort die Abfrage für Username und Passwort, so wie es sein sollte.

    Wer hat noch Ideen? Wer kennt sich gut aus?

    smb.conf + log

    Aktuellste smb.conf:
    [global]
    workgroup = NETZWERK
    server string = %T
    security = DOMAIN
    log level = 1
    log file = /etc/samba/%m.log
    max log size = 50
    time server = Yes
    add user script = /usr/sbin/useradd %u
    delete user script = /usr/sbin/userdel %u
    add group script = /usr/sbin/groupadd %g
    delete group script = /usr/sbin/groupdel %g
    delete user from group script = /usr/sbin/deluser %u %g
    add machine script = /usr/sbin/adduser -n -g machines -c Machine -d /dev/null -s /bin/false %u
    domain logons = Yes
    os level = 99
    preferred master = Yes
    domain master = Yes
    dns proxy = No
    wins support = Yes
    hosts allow = 192.168.1.10, 192.168.1.11, 127.

    [homes]
    path = /home/%S
    valid users = %S
    write list = %S
    read only = No

    [root]
    path = /
    #############################################

    pc2400.log = Windows-XP

    [2007/01/13 20:00:28, 1] smbd/service.c:make_connection_snum(941)
    pc2400 (192.168.1.10) connect to service root initially as user admin2 (uid=500, gid=501) (pid 2345)
    [2007/01/13 20:00:35, 1] smbd/service.c:close_cnum(1141)
    pc2400 (192.168.1.10) closed connection to service root
    [2007/01/13 20:00:40, 1] smbd/service.c:make_connection_snum(941)
    pc2400 (192.168.1.10) connect to service admin2 initially as user admin2 (uid=500, gid=501) (pid 2347)
    [2007/01/13 20:00:42, 1] smbd/service.c:make_connection_snum(941)
    pc2400 (192.168.1.10) connect to service admin2 initially as user admin2 (uid=500, gid=501) (pid 2347)
    [2007/01/13 20:00:43, 1] smbd/service.c:make_connection_snum(941)
    pc2400 (192.168.1.10) connect to service root initially as user admin2 (uid=500, gid=501) (pid 2347)
    [2007/01/13 20:01:02, 1] smbd/service.c:close_cnum(1141)
    pc2400 (192.168.1.10) closed connection to service admin2
    [2007/01/13 20:01:02, 1] smbd/service.c:close_cnum(1141)
    pc2400 (192.168.1.10) closed connection to service admin2
    [2007/01/13 20:01:02, 1] smbd/service.c:close_cnum(1141)
    pc2400 (192.168.1.10) closed connection to service root
    adduser: invalid numeric argument 'machines'
    [2007/01/13 20:01:31, 0] passdb/pdb_interface.c:pdb_default_create_user(368)
    _samr_create_user: Running the command `/usr/sbin/adduser -n -g machines -c Machine -d /dev/null -s /bin/false pc2400$' gave 3
    adduser: invalid numeric argument 'machines'
    [2007/01/13 20:02:09, 0] passdb/pdb_interface.c:pdb_default_create_user(368)
    _samr_create_user: Running the command `/usr/sbin/adduser -n -g machines -c Machine -d /dev/null -s /bin/false pc2400$' gave 3
    adduser: invalid numeric argument 'machines'
    [2007/01/13 20:07:23, 0] passdb/pdb_interface.c:pdb_default_create_user(368)
    _samr_create_user: Running the command `/usr/sbin/adduser -n -g machines -c Machine -d /dev/null -s /bin/false pc2400$' gave 3
     
  10. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  11. #9 pitschi5, 13.01.2007
    pitschi5

    pitschi5 ***BOFH

    Dabei seit:
    30.04.2005
    Beiträge:
    81
    Zustimmungen:
    0
    Ort:
    Wasserliesch, Germany
    trag in deine smb.conf unter global ein:

    domain admin = root oder
    domain admin = smbadmin

    und du musst die user alle in die passwd eintragen, samba-root <> linux-root

    so long...
     
  12. #10 flugopa, 14.01.2007
    flugopa

    flugopa Der lernwillige

    Dabei seit:
    27.05.2006
    Beiträge:
    739
    Zustimmungen:
    0
    Ort:
    München
    Meine Sambaversion=3.0.23c in der dieser Eintrag (domain admin =) ignoriert wird. Alternative habe ich "admin users = root, admin2" hinzugefügt.

    Unter testparm -v>smb.conf.alle werden viele Möglichkeiten und die Default angezeigt.

    Hier das frische Logfile:

    [2007/01/14 10:48:12, 0] passdb/pdb_interface.c:pdb_default_create_user(368)
    _samr_create_user: Running the command `/usr/sbin/adduser -n -g machines -c Machine -d /dev/null -s /bin/false pc2400$' gave 3
    adduser: invalid numeric argument 'machines'

    Jetzt habe ich es. Mir fehlte die Gruppe "machines".


    Danke an alle, die so viel Geduld mit mir hatten.
     
Thema:

XP zur Samba-Domaine