xorg-x11 startet unbenutzbar

Dieses Thema im Forum "Grafik / Video" wurde erstellt von posiputt, 28.11.2009.

  1. #1 posiputt, 28.11.2009
    Zuletzt bearbeitet: 28.11.2009
    posiputt

    posiputt zwar!

    Dabei seit:
    10.12.2004
    Beiträge:
    321
    Zustimmungen:
    0
    Ort:
    hamburg
    edit: problem ist geloest, ich musste nur den hald starten. sorry ;)
    hat ja nur ein paar wochen gedauert, das zu bemerken...

    ich weisz leider nicht, ob das wirklich ein hardwareproblem ist, ein kernel- und ein nvidia-drivers-update hat es allerdings schon unveraendert ueberstanden.

    auf einem x86-64-rechner betreibe ich ein gentoo 10.0 (non-multilib) mit einer gf9500-grafikkarte. ich verwende xorg-server-1.6.3.901-r2 und nvidia-drivers-185.18.36. die installation ist noch recht frisch und bis jetzt habe ich x11 nicht vernuenftig zum laufen bekommen. das "nicht vernuenftig" aeuszert sich wie folgt:

    starte ich x11 mit dem befehl "X", wird der bildschirm schwarz und die hintergrundbeleuchtung geht aus. nach einigen sekunden geht sie wieder an und mir wird angezeigt, dass auf dem dvi-eingang tatsaechlich ein signal reinkommt. weiter passiert nichts.

    starte ich x11 mit dem befehl "xinit", erscheint in der linken oberen ecke ein xterm ohne fokus. es ist kein mouse-cursor zu sehen und mousebewegungen allgemein haben ueberhaupt keinen effekt. auf ctrl-alt-backspace reagiert x11 nicht, mit ctrl-alt-F* kann ich nicht auf irgendeine konsole wechseln und muss also per ssh eingeloggt x11 killen.

    beim starten von x11 erscheinen drei fehlermeldungen:

    Code:
    (EE) Failed to load module "xtrap" (module does not exist, 0)
    (EE) Failed to load module "dri" (module does not exist, 0)
    (EE) Failed to load module "dri2" (module does not exist, 0)
    die zeile "load dri" ist in der xorg.conf allerdings auskommentiert.
    wenn ich "load xtrap" auskommentiere, verschwindet auch die entsprechende fehlermeldung beim start von x11.

    an der mouse liegts scheinbar nicht, ich habe, um das zu testen, den gpm installiert und in der konsole habe ich keine probleme mit der mouse. X laeuft auszerdem unter ubuntu ohne probleme.

    ich habe googlend keine aehnlichen problembeschreibungen gefunden, daher vermute ich, dass es ein ganz simples problem ist, aber ich weisz leider nicht mehr weiter. any thoughts?

    edit: meine xorg.conf ist hier zu sehen
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 slackfan, 28.11.2009
    slackfan

    slackfan König

    Dabei seit:
    18.04.2006
    Beiträge:
    809
    Zustimmungen:
    0
    Ort:
    Bonn
    Version 1.6.3 des X-Servers benutzt schon Hal und ignoriert die Einstellungen der xorg.conf ohne gesetzten Parameter innerhalb der xorg.conf. Ctrl+Alt+Backspace ist seit 1.6 per Vorgabe deaktiviert. Das muss man in der xorg.conf erst aktivieren, sollte der X-Server nicht entsprechend gepatcht sein. Wieso existieren die Module nicht? Ich vermute mal, die müssen da sein :)
     
  4. #3 gropiuskalle, 28.11.2009
    Zuletzt bearbeitet: 28.11.2009
    gropiuskalle

    gropiuskalle terra incognita

    Dabei seit:
    01.07.2006
    Beiträge:
    4.857
    Zustimmungen:
    0
    Ort:
    Berlin
    Nicht ganz. Sind dort Einträge für Monitor und Grafikkarte zu finden, werden so werden diese nicht ignoriert. Sollen auch Eingabegeräte über die xorg.conf verwaltet werden, so muss in der Section "ServerLayout" folgendes stehen:

    Code:
    Option "AllowEmptyInput" "off"
    Option "AutoAddDevices" "off"
    Option "AutoEnableDevices" "off" 
    Allerdings ergibt z.B. "dri" bei 'ner NVidia keinen Sinn, und das ist in der xorg.conf ja auch auskommentiert. *grübel*
     
  5. #4 schwedenmann, 28.11.2009
    schwedenmann

    schwedenmann Foren Gott

    Dabei seit:
    18.11.2003
    Beiträge:
    2.635
    Zustimmungen:
    2
    Ort:
    Wegberg
    xorg

    Hallo

    Sind auch die letzten 3 Zeilen in der xorg.conf auskommentiert ?

    #Section "DRI"
    #Mode o666
    #EndeSection

    mfg
    schwedenmann
     
  6. #5 posiputt, 28.11.2009
    posiputt

    posiputt zwar!

    Dabei seit:
    10.12.2004
    Beiträge:
    321
    Zustimmungen:
    0
    Ort:
    hamburg
    hi

    @slackfan: wie gropiuskalle bemerkte, vertragen sich nvidia und dri nicht, daher ists auskommentiert.

    @schwedenmann: die drei zeilen sind zwar nicht auskommentiert, aber nur, weil sie garnicht in der datei drinstehen.

    und es ist ja so, dass x durchaus startet, nur ohne mouse. einen wm in die .xinitrc einzutragen aendert daran uebrigens garnichts. im moment kann ich nur kalle zustimmen: *gruebel*

    gibt es denn noch irgendwas auf ebene des hal, was man falsch (oder besser: richtig) machen kann?
     
  7. #6 schwedenmann, 28.11.2009
    schwedenmann

    schwedenmann Foren Gott

    Dabei seit:
    18.11.2003
    Beiträge:
    2.635
    Zustimmungen:
    2
    Ort:
    Wegberg
    xorg

    Hallo

    Poste doch mal den Ausschnitt aus der xorg.conf, der sich auf die Tastatur bezieht.

    mfg
    schwedenmann
     
  8. #7 posiputt, 28.11.2009
    Zuletzt bearbeitet: 28.11.2009
    posiputt

    posiputt zwar!

    Dabei seit:
    10.12.2004
    Beiträge:
    321
    Zustimmungen:
    0
    Ort:
    hamburg
    Code:
    Section "InputDevice"
        Identifier     "Keyboard0"
        Driver         "kbd"
    EndSection
    
    und vielleicht noch:
    Code:
    Section "ServerLayout"
        Identifier     "X.org Configured"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
    EndSection
    
    das steht aber doch auch in der kompletten xorg.conf, die ich im eingangsbeitrag verlinkt habe.
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    update: habe mouse und keyboard jetzt zum laufen gebracht, indem ich den hald von hand startete. ich dachte... scheinbar, dass das automatisch laeuft. das scheint das problem behoben zu haben. weird. ich dachte ich haett alles probiert.

    ich nenn das problem mal "solved"
    danke trotzdem fuer die antworten :)
     
  9. doc

    doc Kaffeetrinker

    Dabei seit:
    26.08.2006
    Beiträge:
    586
    Zustimmungen:
    0
    Ort:
    bremen
    hast du

    x11-drivers/xf86-input-evdev

    installiert ?

    ich glaube mal gelesen zu haben, daß das ein muss ist, damit das mit hal funktioniert

    edit ok zu spät ;)
     
  10. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  11. #9 schwedenmann, 28.11.2009
    schwedenmann

    schwedenmann Foren Gott

    Dabei seit:
    18.11.2003
    Beiträge:
    2.635
    Zustimmungen:
    2
    Ort:
    Wegberg
    xorg.conf

    Hallo

    In Debian-Sid steht bei mir in der xorg.conf


    In arch sieht der Abschnitt so aus, dieselbe Hardware

    ev. hilft dir das.

    mfg
    schwedenman
     
  12. #10 posiputt, 28.11.2009
    posiputt

    posiputt zwar!

    Dabei seit:
    10.12.2004
    Beiträge:
    321
    Zustimmungen:
    0
    Ort:
    hamburg
    @schwedenmann danke, aber das problem hat sich schon erledigt, ich musste nur den hald starten
     
Thema:

xorg-x11 startet unbenutzbar

Die Seite wird geladen...

xorg-x11 startet unbenutzbar - Ähnliche Themen

  1. Xorg-X11 6.9.0/7.0 SuSE RPM?

    Xorg-X11 6.9.0/7.0 SuSE RPM?: Guten Tag. Ich suche eine RPM des neuen Xorgs für mein SuSE 10.0 System. Ich konnte aber auf ftp.suse.com oder gwdg nichts finden. Weiß...
  2. MDK 10.1 xorg-x11-devel installieren - Geht nicht

    MDK 10.1 xorg-x11-devel installieren - Geht nicht: Hallo! Muss mir das Paket xorg-x11-devel auf mein MDK 10.1 System spielen. Wenn ich aber das Paket auswähle, wird mir nur gesagt "Das Paket...
  3. LEDE: Fork von OpenWRT gestartet

    LEDE: Fork von OpenWRT gestartet: Unter dem Namen LEDE haben einzelne OpenWRT-Entwickler ein neues Projekt gestartet. Ziel des neuen Projektes ist es, eine gemeinschaftszentrierte...
  4. X startet nichtmehr

    X startet nichtmehr: Hallo, ich habe versucht CUDA und OPENCL mit meiner Graka zum laufen zu bekommen ... nun hängt er aber schon beim Booten bei "started Update UTMP...
  5. Humble Devolver Bundle gestartet

    Humble Devolver Bundle gestartet: Mit dem »Humble Devolver Bundle« sind nun ein weiteres Mal zahlreiche Independent-Spiele zu einem selbst wählbaren Preis für Linux, Mac OS X und...