xorg.conf für zwei Grafikkarten

Dieses Thema im Forum "Debian/Ubuntu/Knoppix" wurde erstellt von Lockslay, 10.10.2011.

  1. #1 Lockslay, 10.10.2011
    Lockslay

    Lockslay Grünschnabel

    Dabei seit:
    12.04.2002
    Beiträge:
    8
    Zustimmungen:
    0
    Hallo zusammen

    Ich hatte bisher eine GeForce 7600 GS Grafikkarte im Einsatz, daran habe ich zwei Monitore betrieben.
    Jetzt habe ich mir eine zweite Grafikkarte gekaut und eingebaut, um zwei weiter Monitore beitreiben zu können.
    Ebenfalls eine GeForce 7600 GS.
    Code:

    Code:
    01:00.0 VGA compatible controller: nVidia Corporation G73 [GeForce 7600 GS] (rev a1)
    02:00.0 VGA compatible controller: nVidia Corporation G73 [GeForce 7600 GS] (rev a1)
    Ich habe jetzt meine xorg.conf versucht anzupassen.
    Ich habe das neu hinzugefügt:
    Code:

    Code:
    #neu
    Section "Device"
        Identifier     "Device2"
        Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
      BoardName      "GeForce 7600 GS"
      BusID       "PCI:02:00:0
    EndSection
    Ganze xorg.conf habe ich als Anhang hinzugefügt.

    Was muss ich den in die
    Screen-Section einfügen ?

    Nur leider kann ich die Ausgabe immer noch nicht nutzen.
    nvidia-settings bringt mich leider auch nicht weiter.
    Die Neue Grafikkarte bzw der Monitor wird als braunes Fenster angezeigt.
    Habe das als Bild beigefügt.

    Vielleicht kann mir hier einer helfen meine beiden Karten zum laufen zu bringen.
     

    Anhänge:

    • xorg.png
      xorg.png
      Dateigröße:
      124,1 KB
      Aufrufe:
      12
    • xorg.txt
      Dateigröße:
      2 KB
      Aufrufe:
      4
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. @->-

    @->- Guest

  4. #3 Lockslay, 12.10.2011
    Lockslay

    Lockslay Grünschnabel

    Dabei seit:
    12.04.2002
    Beiträge:
    8
    Zustimmungen:
    0
    Hallo

    danke für deinen Link.
    Ich habe die letzte Nacht einmal durch getestet, leider hatte ich immer nur die Konsole als Anzeige und kein x Server :(

    Da ich leider nicht wirklich weiter komme würde ich gerne hier einige Fragen stellen.

    Punkt 1

    Für jede Grafikkarte habe ich einen solchen Eintrag, natürlich habe ich die Identifier und die BusID der Karte angepasst.
    Mein lspci zeigt mir aber eine 01:00.0 bzw 02:00.0 an das habe ich auch versucht.
    Laut der Link Anleitung steht da Identifier "Card0" bei meiner von nvidia-setting erstellen xorg.conf steht aber Identifier "Device0" habe auch beide Versionen getestet ohne Erfolg.


    Code:
     Section "Device"
    	Identifier  "Card0" 
    	Driver      "nvidia"
    	VendorName  "nVidia Corporation"
    	BoardName   "GT218 [GeForce 210]"
    	BusID       "PCI:1:0:0"
    EndSection
    
    mache ich hier schon was falsch ?

    Punkt 2

    Laut Anleitung steht zum Thema Monitore das da:
    Code:
    Section "Monitor"
    	Identifier   "Monitor0"
    	VendorName   "Monitor Vendor"
    	ModelName    "Monitor Model"
    EndSection
    
    Section "Screen"
    	Identifier "Screen0"
    	Device     "Card0"
    	Monitor    "Monitor0"
    	SubSection "Display"
    		Viewport   0 0
    		Depth     1
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     4
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     8
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     15
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     16
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24
    	EndSubSection
    EndSection
    Ich habe einmal meine "alt" Section Screen komplett gelöscht und durch die Obere ersetzt.
    Ich habe auch für jeden Monitor (drei) einen solchen Eintrag gemacht. Habe natürlich die Identifier
    und die Device bzw Monitor angepasst.
    Brauche ich für jeden Monitor einen solchen Eintrag wie in der Anleitung beschrieben ??

    Da ich nicht wirklich weiter komme und ich auch bei google nicht wirklich eine Anleitung finde würde ich mich sehr freuen wenn mir hier einer helfen könnte.

    Gruß,
    Lockslay
     
  5. @->-

    @->- Guest

    Denke bitte daran das lspci liefert die Adresse hexadecimal, xorg benötigt aber die Adresse in decimal Form.

    Zu beginn solltest du mit einer vorgefertigten xorg.conf beginnen. Lasse einfach eine Konfiguration von Xorg erstellen mit einem:
    Code:
    X -configure
    Da sollten dann alle Monitore und Grafikkarten erkannt sein. Diese xorg.conf kannst du mal hochladen dann kann ich dir mehr helfen.

    Grüße
     
  6. #5 Lockslay, 12.10.2011
    Lockslay

    Lockslay Grünschnabel

    Dabei seit:
    12.04.2002
    Beiträge:
    8
    Zustimmungen:
    0
    Hallo @->-


    dein Wunsch ist mir Befehl :))
    Habe die Datei erstellen lassen und als Anhang hinzugeführt.

    So wie ich das mit meinem Anfänger Blick sehe sind da nur zwei Monitore eingetragen.

    "Monitor0" und "Monitor1" aber der dritte Monitor fehlt noch

    Dafür sind jetzt beide Karten eingetragen.

    Section "Device" BusID "PCI:1:0:0" und BusID "PCI:2:0:0"

    Section "Screen"
    gibt es ebenfalls zweimal einmal für "Monitor0" und einmal für Monitor "Monitor1"
    Ich habe den dritten Monitor (Samsung SyncMaster 753DFX) mit einem VGA auf DVI Adapter am laufen, aber das sollte doch keine Probleme machen.

    Den Rest der conf Verstehe ich nicht, und hoffe das du mir einen entscheiden Tipp geben kannst.

    Gruß,
    Lockslay
     

    Anhänge:

  7. @->-

    @->- Guest

    Das sieht doch schon mal ganz gut aus. Ich sehe aber du nimmst den freien Nvidia Treiber. Du hast aber den richtigen Treiber von Nvidia installiert? Der freie bietet glaube ich keinen support für mehrere Monitore.

    Ändere mal deine beiden
    Code:
    Driver      "nv"
    in

    Code:
    Driver      "nvidia"
    und schaue ob Xorg startet. Sollte Xorg starten musst du noch einen Monitor hinzufügen. Ich habe deine Xorg.conf mal angepasst und um einen Monitor erweitert. Im Abschnitt Screen2 musst du noch Device "CardX" anpassen, ersetze dort das X durch die Nummer der Karte an welcher der Monitor angeschlossen ist.

    Im Grunde sollte das klappen, aber keine Garantie darauf, solche Fernkonfigurationen sind nicht immer optimal :)

    Zusätzlich könntest du noch deinen nv Treiber entfernen, das Paket wird in der Art xf86-video-nv heißen, danach kannst du Xorg noch einmal eine Konfiguration erstellen lassen, dann nimmt er die nvidia Treiber.

    Grüße Den Anhang xorg.conf.multi.txt betrachten
     
  8. #7 Lockslay, 13.10.2011
    Lockslay

    Lockslay Grünschnabel

    Dabei seit:
    12.04.2002
    Beiträge:
    8
    Zustimmungen:
    0
    Hallo @->-

    so ich habe jetzt einmal meinen xconfig geändert wie du es gesagt hast.
    Code:
    Driver      "nvidia"
    das ging aber leider nicht.

    Dann habe ich deine xconfig übernommen und "CardX" angepasst.
    Wenn ich das richtig verstanden habe ist damit der Ausgang der Grafikkarte gemeint als entweder 0 oder 1 ?

    Da ich auch bei der Version einen schwarzen Bildschirm hatte, poste ich einmal die Error Log Datei.

    Code:
     (II) Oct 13 15:50:02 NVIDIA(0):     enabled.
    (EE) Oct 13 15:50:04 NVIDIA(0): Failed to find a valid SLI configuration.
    (EE) Oct 13 15:50:04 NVIDIA(0): Invalid SLI configuration 1 of 1:
    (EE) Oct 13 15:50:04 NVIDIA(0): GPUs:
    (EE) Oct 13 15:50:04 NVIDIA(0):     1) NVIDIA GPU at PCI:1:0:0
    (EE) Oct 13 15:50:04 NVIDIA(0):     2) NVIDIA GPU at PCI:2:0:0
    (EE) Oct 13 15:50:04 NVIDIA(0): Errors:
    (EE) Oct 13 15:50:04 NVIDIA(0):     - Chipset not approved for SLI
    (WW) Oct 13 15:50:04 NVIDIA(0): Failed to find a valid SLI configuration for the
    Ich verstehe nicht viel von dieser Log aber mir ist das hier aufgefallen, vielleicht bist du so nett und kannst dir diese Datei einmal ansehen.

    Gruß.
    Lockslay
     

    Anhänge:

  9. #8 marcellus, 13.10.2011
    marcellus

    marcellus Kaiser

    Dabei seit:
    09.05.2007
    Beiträge:
    1.392
    Zustimmungen:
    0
    Ich bin mir nicht so sicher, dass du zwei nvidia karten auf einem mainboard zusammenschließen kannst, ohne, dass das board sli unterstützt.
    Es kann natürlich auch sein, dass du sli support am mainboard hast, aber es im bios abgedreht ist.

    Um zu checken, ob das am nvidia treiber liegt, oder ob es wirklich nicht möglich ist würd ich als treiber "vesa" eintragen.

    Aber da du nicht der erste bist und eine sli konfiguration haben willst wärs eine idee bei google zu suchen, dann findest du zb http://ubuntuforums.org/showpost.php?p=5315359&postcount=3 aber sicher deine xorg.conf vorher.
     
  10. @->-

    @->- Guest

    Nein, damit ist die Grafikkarte gemeint. Du hast ja zwei stück eingebaut. Die erste hat den Namen Card0 und die andere Card1.

    Das ist kein Problem. Das ganze hat ja mit sli nichts zu tun. Es sind im prinzip nur zwei Grafikkarten die getrennt voneinander arbeiten. Er könnte jetzt auch eine nvidia und eine ati/amd nutzen, das wäre nur nicht wirklich sinnvoll :)

    Das ganze einzurichten ist nur nicht so einfach. Ich habe auch so einige male fast graue Haare bekommen. Habe hier einen Rechner mit 2xG210 Grafikkarten, an diesem Rechner können mit 2 Monitore/Maus/Tastatur 2 Leute unabhängig voneinander Arbeiten.

    Grüße
     
  11. #10 marcellus, 14.10.2011
    marcellus

    marcellus Kaiser

    Dabei seit:
    09.05.2007
    Beiträge:
    1.392
    Zustimmungen:
    0
    Bei multiseat hat man normal aber auch 2 unterschiedliche x server laufen. Ich bin mir nur nicht sicher, ob der nvidia treiber zwei grafikkarten ohne sli verwenden kann.
     
  12. #11 Lockslay, 16.10.2011
    Lockslay

    Lockslay Grünschnabel

    Dabei seit:
    12.04.2002
    Beiträge:
    8
    Zustimmungen:
    0
    Hallo zusammen,

    ich bin etwas weitergekommen.
    Habe einmal die config von @->- einkopiert und die "CardX" Einstellung geändert einmal in Card0 und einmal in Card1
    Das Ergebnis war bei beiden das ich beide Grafikkarten angesteuert bekam aber bei der Card0 (die alte Karte die als erstes eingebaut war) nur ein Ausgang angesteuert wurde.

    Ich habe ja an jeder Karte zwei Ausgänge beim Hochfahren werden beide Ausgänge der ersten Karte angezeigt. Nach dem Start von kdm geht der Bildschirm 1 aus und der Bildschirm von Grafikkarte 2 an.

    Habe unter Section "Monitor" einmal alles durch getestet Identifier "Monitor0" auf 1 gesetzt und Identifier "Monitor1 auf 2 usw. Das gleiche habe ich mit den Section "Screen" gemacht aber leider ohne Erfolg.
    Nachdem ich die halbe Nacht getestete habe blicke ich jetzt leider nicht mehr richtig durch und meine Eltern meckern auch schon ;(

    Vielleicht habt ihr noch wertvolle Tipps.


    Gruß,
    Lockslay
     
  13. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  14. #12 Lockslay, 19.10.2011
    Lockslay

    Lockslay Grünschnabel

    Dabei seit:
    12.04.2002
    Beiträge:
    8
    Zustimmungen:
    0
    Hallo,

    keiner mehr hilfreiche Tipps ? :hilfe2:
    Oder Alternative Vorschläge wie ich das Problem gelöst bekomme.


    Gruß,
    Lockslay
     
  15. #13 Lockslay, 27.10.2011
    Lockslay

    Lockslay Grünschnabel

    Dabei seit:
    12.04.2002
    Beiträge:
    8
    Zustimmungen:
    0
    Hallo zusammen,

    ich habe die Monitore am laufen :trash:
    Juhu nach dem ganzen hin und her und dem ganzen Testen habe ich es nun endlich geschafft !
    Bin überglücklich !!!!!!!!!!!!!!!!!!
    Danke für die ganze Hilfe.

    Habe aber leider noch ein kleines Problem.
    Ich ahbe einmal ein Screen meines alten Destop gemacht. Dort habe ich einen Aktiven Desktop mit KDE und einen ohne KDE nur zur Ablage, von Programmen wie Firefox usw
    In meiner neuen Einstellung mit dem neuen Monitor habe ich alle drei Fenster als KDE Seite ich würde aber gerne nur einen Monitor mit KDE Funktion und die beide anderen zur Ablage.
    Aber ich finde die Einstellungen dafür nicht.

    Könnt ihr mir dabei helfen -.... Bitte :hilfe2:

    Gruß,
    Lockslay
     

    Anhänge:

    • xorg1.jpg
      xorg1.jpg
      Dateigröße:
      191,6 KB
      Aufrufe:
      10
Thema: xorg.conf für zwei Grafikkarten
Besucher kamen mit folgenden Suchen
  1. Linux zwei vga xorg.conf

    ,
  2. linux zwei monitore zwei grafikkarten

    ,
  3. linux nvidia zwei grafikkarten

    ,
  4. multiseat linux mit einer grafikkarte,
  5. ubuntu 2 grafikkarten,
  6. linux 2 grafikkarten,
  7. Linux zwei Grafikkarten,
  8. Linux mehere Grafikkarten nutzen
Die Seite wird geladen...

xorg.conf für zwei Grafikkarten - Ähnliche Themen

  1. [Suse 10.0] Umstellung von Tastaturlayout in KDE zerschießt xorgconf

    [Suse 10.0] Umstellung von Tastaturlayout in KDE zerschießt xorgconf: Hab ein seltsames Problem... Nach dem ich mir die ATI Treiber für meine Mibility X700 installiert hatte, läuft mein Notebook zwar soweit. Aber...
  2. SAMBA für Windows10 Domäne einrichten

    SAMBA für Windows10 Domäne einrichten: Hallo, ich habe letztes Wochenende verzweifelt versucht, Samba auf meinem Server einzurichten, daher versuche ich aktuell meinen Fehler zu...
  3. Empfehlung für Server Distribution

    Empfehlung für Server Distribution: Hallo, ich habe hier zu Hause einen kleinen Heimserver, auf welchem ich ein paar Daten für den Zugriff im Haus, einen kleinen Web Service für...
  4. Kleinigkeiten für Euch, mich nicht :-) pkg_add ; DVD rw mounten

    Kleinigkeiten für Euch, mich nicht :-) pkg_add ; DVD rw mounten: Hallo, ich habe 2 Problemchen. Ich kann nichts mehr installieren. Ich brauche aber unbedingt ein Brenn-Programm. Ein schönen Partitionierer usw....
  5. Welche Distri für Programming from the Ground Up

    Welche Distri für Programming from the Ground Up: Hallo! Ich möchter gerne das Buch Programming from the Ground Up durcharbeiten. savannah_nongnu_org/projects/pgubook/ Da geht es um Programmieren...