XMMS öffnet keine MP3

Dieses Thema im Forum "Sound" wurde erstellt von gangster_x, 08.11.2006.

  1. #1 gangster_x, 08.11.2006
    gangster_x

    gangster_x Mitglied

    Dabei seit:
    22.07.2006
    Beiträge:
    27
    Zustimmungen:
    0
    Hab opensuse 10,1 und XMMS öffnet keine MP3.

    Wenn ich auf Play klicke zeigt er mir das verzeichniss welches ich wählte , suche ich mir eine mp3 aus, ist sie nicht drin im Programm, drücke ich aus Play bekomme ich wieder zusehen, dass ich ne MP3 auswählen kann.

    Habe xmms über die sehrviel gespächigere Konsole gestartet unddie Spuckt beim öffnen von MP3s das aus:
    manu@abpo:~> xmms
    Message: device: hw:0,0

    Gtk-WARNING **: invalid cast from `(unknown)' to `GtkObject'

    Gtk-CRITICAL **: file gtkobject.c: line 1034 (gtk_object_set_data): assertion `GTK_IS_OBJECT (object)' failed.

    Gtk-WARNING **: invalid cast from `GtkCTreeExpanderStyle' to `GtkObject'

    Gtk-CRITICAL **: file gtkobject.c: line 1034 (gtk_object_set_data): assertion `GTK_IS_OBJECT (object)' failed.
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 oyster-manu, 08.11.2006
    Zuletzt bearbeitet: 08.11.2006
    oyster-manu

    oyster-manu toast

    Dabei seit:
    26.06.2003
    Beiträge:
    1.055
    Zustimmungen:
    0
    AFAIK ist auch bei opensuse kein MP3-decoder dabei, daher kann xmms auch keine dekodieren. mach mal ein online-update mit yast und guck ob es dort nen decoder gibt. ansonsten nimm die mp3lib von mpg123 (oder einem anderen mp3-player mit offenem mp3decoder) und kopier die ins xmms-decoder-verzeichnis.

    etwas konkreter:
    lad dir von www.mpg123.de die software runter und kopier die "libmpg123.so" und "libmpg123.la" nach /usr/lib/xmms/Input. eventuell musst du xmms noch sagen, dass es bitte mpg123 benutzen soll.
    es gibt bestimmt noch sauberere methoden allerdings ist mpg123 ein sehr ressourcensparender decoder.

    manu
     
  4. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Installiere einfach die w32codecs und es sollte funktionieren. Bekommst du im Normalfall über das Online-Update. Das Thema wurde hier aber schon mehrfach durchgekaut. Schau also einfach mal in die Boardsuche.
     
  5. #4 gangster_x, 09.11.2006
    gangster_x

    gangster_x Mitglied

    Dabei seit:
    22.07.2006
    Beiträge:
    27
    Zustimmungen:
    0
    Ich habe nirgentswo Libs gefunden in den archiven (tar.gz) waren nur .c und.h Datein die noch compiliert werden müssen.
     
  6. #5 DennisM, 09.11.2006
    DennisM

    DennisM Moderator u. Newsposter

    Dabei seit:
    08.05.2004
    Beiträge:
    4.883
    Zustimmungen:
    0
    Ort:
    GER/NRW/Essen
    Evtl musst du auch das MAD-Plugin für XMMS installieren, die W32Codecs waren für andere Sachen zuständig afaik.

    MFG

    Dennis
     
  7. #6 damager, 09.11.2006
    damager

    damager Moderator

    Dabei seit:
    27.08.2003
    Beiträge:
    3.065
    Zustimmungen:
    0
    Ort:
    Munich
  8. Jabo

    Jabo Aufgabe ohne Minister

    Dabei seit:
    12.10.2006
    Beiträge:
    1.322
    Zustimmungen:
    0
    Ort:
    Hamburg
    Suse baut aus Lizenzgründen XMMS um. Auf mp3 ist ein Patent.

    Multimedia-Zeugs von Packman oder sowas ist unkastriert, wie du ja gerade selber erzählst :D

    Ich würde Packman und / oder Guru als Installationsquelle einstellen und zusehen, daß die immer vor SuSE-Originalquellen abgefragt werden. Wenn du irgend was multimediamäßiges installierst, kriegst du immer erst mal eine Version angeboten, die vermutlich funtioniert.
     
  9. #8 damager, 09.11.2006
    damager

    damager Moderator

    Dabei seit:
    27.08.2003
    Beiträge:
    3.065
    Zustimmungen:
    0
    Ort:
    Munich
    äh ja, das war eigentlich auch die message hinter meinen posting ... nur evtl. etwas kürzer :D

    zitat aus:http://www.unixboard.de/vb3/showthread.php?p=184875#post184875 (suse / smart /sticky)
     
  10. #9 gangster_x, 09.11.2006
    gangster_x

    gangster_x Mitglied

    Dabei seit:
    22.07.2006
    Beiträge:
    27
    Zustimmungen:
    0
    Sachmal oyster-manu , kannste mir die Datein alle Packen und mir mailen, also den Ordner wo die Plugins drin sind und ich kopiere sie rein und dann läuft?

    Denn bisweilen scheitere ich. :-( Scheine wohl zu doof zu sein.
     
  11. #10 supersucker, 09.11.2006
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Ja,

    und warum einfach wenn es auch umständlich geht?

    Die letzten 4 posts haben dir doch genug Möglichkeiten aufgezeigt, das Ganze in 1 Minute komfortabel über die Paketverwaltung zu installieren.
     
  12. #11 gangster_x, 09.11.2006
    gangster_x

    gangster_x Mitglied

    Dabei seit:
    22.07.2006
    Beiträge:
    27
    Zustimmungen:
    0
    Ach der will doch nicht.

    Das mit der einen installationsquelle angeben hab ich gemacht und dann installiert,- ging immer noch nicht.

    Dann wenn ich mir die Dateien von der packman seite sauge passiert nur soetwas:
    abpo:/home/manu/Desktop # rpm -vhU xmms-lib-1.2.10-103.pm.1.x86_64.rpm
    warning: xmms-lib-1.2.10-103.pm.1.x86_64.rpm: Header V3 DSA signature: NOKEY, key ID 5f6842a4
    error: Failed dependencies:
    libGL.so.1()(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libX11.so.6()(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libXext.so.6()(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libXi.so.6()(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libasound.so.2()(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libasound.so.2(ALSA_0.9)(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libasound.so.2(ALSA_0.9.0rc4)(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libaudiofile.so.0()(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libc.so.6()(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libc.so.6(GLIBC_2.2.5)(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libc.so.6(GLIBC_2.3)(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libc.so.6(GLIBC_2.3.4)(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libc.so.6(GLIBC_2.4)(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libdl.so.2()(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libdl.so.2(GLIBC_2.2.5)(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libesd.so.0()(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libgdk-1.2.so.0()(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libglib-1.2.so.0()(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libgmodule-1.2.so.0()(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libgthread-1.2.so.0()(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libgtk-1.2.so.0()(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libm.so.6()(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libm.so.6(GLIBC_2.2.5)(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libmikmod.so.2()(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libogg.so.0()(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libpthread.so.0()(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libpthread.so.0(GLIBC_2.2.5)(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libvorbis.so.0()(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libvorbisfile.so.3()(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libz.so.1()(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libxmms.so.1 is needed by (installed) xmms-kde-3.1-70.i586
    libxmms.so.1 is needed by (installed) xmms-plugins-1.2.10-44.5.i586
    libxmms.so.1 is needed by (installed) xmms-1.2.10-103.i586
    libxmms.so.1 is needed by (installed) xmms-mac-0.3.1-0.pm.1.i586
    libxmms.so.1 is needed by (installed) madman-0.94beta1-2.pm.tla20060329.1.i586


    Hab alle 3 Dateien die man saugen kann auf dem Desktop liegen.
     
  13. cremi

    cremi Dude

    Dabei seit:
    15.02.2004
    Beiträge:
    329
    Zustimmungen:
    0
    Ort:
    AUT/Ktn
    warum machst du das nicht über yast
     
  14. #13 gangster_x, 09.11.2006
    gangster_x

    gangster_x Mitglied

    Dabei seit:
    22.07.2006
    Beiträge:
    27
    Zustimmungen:
    0
    yast öffnet mir die besagten dateien garnicht erst :-(


    Und wenn ichs mit dem Installer öffnen will kommt das:
    '/home/manu/Desktop/xmms-1.2.10-103.pm.1.x86_64.rpm' is not available or fully up to date.
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. Jabo

    Jabo Aufgabe ohne Minister

    Dabei seit:
    12.10.2006
    Beiträge:
    1.322
    Zustimmungen:
    0
    Ort:
    Hamburg
    Da fehlt was....
    • alles was nach XMMS riecht, deinstallieren...
    • rpm -ivhU xmms-lib-1.2.10-103.pm.1.x86_64.rpm (wobei -ivv reichen sollte)
    probier das mal, vor allem vorher XMMS weg....
     
  17. #15 gangster_x, 09.11.2006
    gangster_x

    gangster_x Mitglied

    Dabei seit:
    22.07.2006
    Beiträge:
    27
    Zustimmungen:
    0
    Scheiterte auch wie der ivv Installationsbefehl:
    abpo:/home/manu/Desktop # rpm -ivhU xmms-lib-1.2.10-103.pm.1.x86_64.rpm
    warning: xmms-lib-1.2.10-103.pm.1.x86_64.rpm: Header V3 DSA signature: NOKEY, key ID 5f6842a4
    error: Failed dependencies:
    libGL.so.1()(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libX11.so.6()(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libXext.so.6()(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libXi.so.6()(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libasound.so.2()(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libasound.so.2(ALSA_0.9)(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libasound.so.2(ALSA_0.9.0rc4)(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libaudiofile.so.0()(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libc.so.6()(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libc.so.6(GLIBC_2.2.5)(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libc.so.6(GLIBC_2.3)(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libc.so.6(GLIBC_2.3.4)(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libc.so.6(GLIBC_2.4)(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libdl.so.2()(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libdl.so.2(GLIBC_2.2.5)(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libesd.so.0()(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libgdk-1.2.so.0()(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libglib-1.2.so.0()(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libgmodule-1.2.so.0()(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libgthread-1.2.so.0()(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libgtk-1.2.so.0()(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libm.so.6()(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libm.so.6(GLIBC_2.2.5)(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libmikmod.so.2()(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libogg.so.0()(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libpthread.so.0()(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libpthread.so.0(GLIBC_2.2.5)(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libvorbis.so.0()(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libvorbisfile.so.3()(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
    libz.so.1()(64bit) is needed by xmms-lib-1.2.10-103.pm.1.x86_64
     
Thema:

XMMS öffnet keine MP3

Die Seite wird geladen...

XMMS öffnet keine MP3 - Ähnliche Themen

  1. Streamtuner/xmms - Stream wird in neuer Playlist geöffnet

    Streamtuner/xmms - Stream wird in neuer Playlist geöffnet: [gelöst] Streamtuner/xmms - Stream wird in neuer Playlist geöffnet Hi zusammen :) Wenn ich beim Streamtuner (SHOUTcast) irgendwas abspiele...
  2. xmms versus audacious

    xmms versus audacious: Hallo Nutze Debian-Sid, kernel 2.6.30 und habe xmms (obwohl aus Debian rausgeflogen immer noch drauf) und audacious in Betrieb. Audacious...
  3. Probleme bei Plugininstallation für XMMS

    Probleme bei Plugininstallation für XMMS: Hallo. wollte für XMMS ein Plugin für eine Media Library installieren. Hab die Datei in mein Documentsverzeichniss runtergeladen und entpackt....
  4. XMMS Vu Meter Plugin Installations Problem

    XMMS Vu Meter Plugin Installations Problem: Hi, ich hab ein Problem das Vu Meter Plugin zu installieren. Bin nach der Anleitung in der README vorgegangen, es kommt aber wenn ich...
  5. Kein Starten von xmms per Doppelklick auf eine damit verknüpfte Datei

    Kein Starten von xmms per Doppelklick auf eine damit verknüpfte Datei: Und noch ein Problemchen, wenn auch ein nicht sooo erhebliches: Ich habe xmms per Yast von Packman installiert, es ist auch als...