xgl will nicht so ganz

Dieses Thema im Forum "Gnome" wurde erstellt von Nemesis, 29.04.2006.

  1. #1 Nemesis, 29.04.2006
    Nemesis

    Nemesis N3RD

    Dabei seit:
    28.01.2005
    Beiträge:
    2.165
    Zustimmungen:
    0
    hi,
    ich hab gerade von ubuntu 5.10 auf dapper geupdatet und dann auch gleich nach folgendem howto versucht xgl zum laufen zu bekommen. irgendwie will er nicht :(
    ich sitze jetzt vor nem komplett weissen bildschirm nach dem booten.

    is das von euch auch schon jemandem passiert?


    thx
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen
    Lass mal die Configs in Ruhe ;)
    Ich habe es nach diesem Howto probiert (mit Erfolg!) - https://wiki.ubuntu.com/XglHowto

    Code:
    [FONT=monospace]
    [/FONT]sudo ln -sf /usr/bin/Xgl /etc/X11/X
    
    und fürs Repo noch diese 2 Zeilen eintragen

    Code:
    deb http://xgl.compiz.info/ dapper main
    deb http://www.beerorkid.com/compiz/ dapper main
    
    Dann sollte das ganz easy klappen ;)
     
  4. Unfug

    Unfug Grünschnabel

    Dabei seit:
    12.07.2004
    Beiträge:
    4
    Zustimmungen:
    0
  5. #4 Nemesis, 03.05.2006
    Nemesis

    Nemesis N3RD

    Dabei seit:
    28.01.2005
    Beiträge:
    2.165
    Zustimmungen:
    0
    also, ich hab mich jetzt mal an devilz howto rangemacht, wenn ich jetzt aber mit
    Code:
    Xgl -fullscreen :1 -ac -accel glx:pbuffer -accel xv:fbo & sleep 2 && DISPLAY=:1 gnome-session 
    versuche eine xgl-session in meiner bereits bestehenden x-session zu starten, dann öffnet er zwar ein fenster mit einem neuen x-server (ka ob das xgl ist) aber er startet darin weder gnome noch gdm.
    welche möglichkeit habe ich da, dass ich erst xgl testen kann, ohne gleich alle configs auf xgl umzustellen?

    thx
     
  6. #5 Mµ*e^13.5_?¿, 03.05.2006
    Mµ*e^13.5_?¿

    Mµ*e^13.5_?¿ Routinier

    Dabei seit:
    21.02.2006
    Beiträge:
    453
    Zustimmungen:
    0
    Also einfacher geht es vermutlich mit startx
    Code:
    startx /path/to/gnome-session -- /path/to/Xgl -fullscreen :1 -ac -accel glx:pbuffer -accel xv:fbo
    Aber es scheint so, dass gnome-session sich weigert mehr als einmal zu starten, ich habe es zumindest nicht überreden können, das solltest du also beachten.
     
  7. #6 Nemesis, 03.05.2006
    Zuletzt bearbeitet: 04.05.2006
    Nemesis

    Nemesis N3RD

    Dabei seit:
    28.01.2005
    Beiträge:
    2.165
    Zustimmungen:
    0
    hm, irgendwie kommt es mir so vor als wolle mein nb kein xgl^^
    ich habe kein gnome laufen, aber er will trotzdem keins auf nem xgl laufen lassen.
    jetzt probier ich doch ma den andern weg.

    edit:

    wenn ich jetzt in gdm als session xgl auswähle, dann steigt er mir nach 10 sec. wieder aus, und im ~/xsession-errors steht:
    Code:
    /etc/gdm/PreSession/Default: Registering your session with wtmp and utmp
    /etc/gdm/PreSession/Default: running: /usr/bin/sessreg -a -w /var/log/wtmp -u /var/run/utmp -x "/var/lib/gdm/:0.Xservers" -h "" -l ":
    0" "nemesis"
    /etc/gdm/Xsession: Beginning session setup...
    SESSION_MANAGER=local/nemesis-mobil:/tmp/.ICE-unix/6497
    Gnome-Message: gnome_execute_async_with_env_fds: returning -1
    compiz.real: No composite extension
    
    ** (gnome-terminal:6640): WARNING **: Kein Handler für Kontrollsequenz »device-control-string« festgelegt.
    
    ** (gnome-terminal:6640): WARNING **: Kein Handler für Kontrollsequenz »device-control-string« festgelegt.
    
    ** (gnome-terminal:6640): WARNING **: Kein Handler für Kontrollsequenz »device-control-string« festgelegt.
    
    ** (gnome-terminal:6640): WARNING **: Kein Handler für Kontrollsequenz »device-control-string« festgelegt.
    
    ** (gnome-terminal:6640): WARNING **: Kein Handler für Kontrollsequenz »device-control-string« festgelegt.
    
    ** (gnome-terminal:6640): WARNING **: Kein Handler für Kontrollsequenz »device-control-string« festgelegt.
    
    ** (gnome-terminal:6640): WARNING **: Kein Handler für Kontrollsequenz »device-control-string« festgelegt.
    
    ** (gnome-terminal:6640): WARNING **: Kein Handler für Kontrollsequenz »device-control-string« festgelegt.
    
    ** (gnome-terminal:6640): WARNING **: Kein Handler für Kontrollsequenz »device-control-string« festgelegt.
    
    ** (gnome-terminal:6640): WARNING **: Kein Handler für Kontrollsequenz »device-control-string« festgelegt.
    
    danach bin ich vorgegangen:
    https://wiki.ubuntu.com/xglati

    edit2:

    so, jetzt habe ich es ma nach diesem howto gemacht: *howto*
    und ich bin wieter gekommen.
    ich habe in die /etc/X11/xorg.conf folgende zeile auskommentiert:
    Code:
    Load    "GLcore"
    wenn ich jetzt gdm neu starte und dann als sitzung xgl auswähle startet er auch, aber er bringt mir nur den desktop mit meinem hintergrundbild aber sonst nichts, werder panel noch sonst etwas.
     
  8. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  9. #7 Nemesis, 05.06.2006
    Nemesis

    Nemesis N3RD

    Dabei seit:
    28.01.2005
    Beiträge:
    2.165
    Zustimmungen:
    0
    so, jetzt hab auch ich es hinbekommen ;)

    noch eins: ist es möglich, dass man in gdm wählen kann ob ich eine xgl session starten möchte oder nicht?
    bei mir startet er nu immer xgl, egal ob ich im gdm xgl oder gnome wähle. kann man das ändern?
     
  10. #8 Echtor2oo3, 16.06.2006
    Zuletzt bearbeitet: 16.06.2006
    Echtor2oo3

    Echtor2oo3 Mitglied

    Dabei seit:
    22.05.2006
    Beiträge:
    45
    Zustimmungen:
    0
    http://echtor.xglusers.de/

    [​IMG]
    Damit kannst Du vor oder nach dem start wählen ;)
    Ich hab auch XGL nur nach dem how2 von www.xglusers.deinstalliert , ohne werbung machen zu wollen, bei mir kam nur 1 fehler den ich mit hilfe von #xgl-de und irssi innerhalb von 15 min gefixt hatte

    [Eine Frage noch]
    Weiß jemand wie man x von der Konsole aus reseten kann? Würde in dem tool noch fehlen ;)

    mfg
    Echtor2oo3
     
Thema:

xgl will nicht so ganz

Die Seite wird geladen...

xgl will nicht so ganz - Ähnliche Themen

  1. Umzug auf SSD nicht ganz reibungslos

    Umzug auf SSD nicht ganz reibungslos: Hallo, ich möchte mein Debian auf eine SSD umziehen. Ich habe diese dazu passend formatiert und / mit rsync -av --one-file-system / /mnt/ssd auf...
  2. pc fährt nicht ganz runter

    pc fährt nicht ganz runter: hi. ich habe gentoo 2.6.23 auf einem ibm x60 laufen. habe unter anderem das problem dass der befehl shutdown -h now und auch poweroff das...
  3. nested groups funktioniert nicht ganz

    nested groups funktioniert nicht ganz: Hallo, ich bin dabei einen Linux-Server (Gentoo) über Samba/Winbind (3.0.24) an ein Active Directory (Small Business Server 2003 Standard)...
  4. Tastatur geht nicht so ganz

    Tastatur geht nicht so ganz: Hi, heute hab ich Linux installiert und alles läuft super, bis darauf, dass eine taste auf miener Tastatur nich funktioniert. Und zwar ist es die...
  5. User sollen Dateien speichern und ändern, aber nicht neu anlegen dürfen

    User sollen Dateien speichern und ändern, aber nicht neu anlegen dürfen: Hallo liebe Helfer, welche Einstellungen muss ich in der smb.conf bzw. unter Linux vornehmen, damit User vorhandene Dateien öffnen und speichern...