XFS : bad magic number -> Kernel Panic

Dieses Thema im Forum "Gentoo" wurde erstellt von Nano, 04.12.2006.

  1. Nano

    Nano Foren As

    Dabei seit:
    02.12.2006
    Beiträge:
    93
    Zustimmungen:
    0
    Der Kernel spuckt beim booten folgenden fehler aus :

    XFS : bad magic number
    XFS : SB validate failed
    No filesystem could mount root, tried : xfs
    Kernel panic - not syncing : VFS : Unable to mount root fs on unknown-block(3,4)


    hda1 - windoofs
    hda2 - /boot - ext2
    hda3 - swap
    hda4 - / - ext3

    selbiges steht auch in der /etc/fstab

    Da meine kenntnise noch sehr bescheiden sind habe ich im web gesucht und leider nur den hinweiss auf eine defekte partition gefunden welche mit xfs_repair zu beheben sei, nun ist es aber so das ich überhaupt keine xfs partition habe, daher versuchte ich e2fsck bei hda2 und 4 bei 4 gab es einen kleinen fehler der behoben wurde leider kommt die fehlermeldung immernoch.

    Kann es sein das ich den Kernel falsch kompiliert habe ? Ich habe dazu eine für meinen Laptopversion vorgefertigte .config genutzt per make oldconfig und die entsprechenden neuen möglichkeiten nach besten wissen / unwissen geaddet.

    Beim booten lande ich auch in der grub prompt, den kernel starte ich indem ich setup (hd0,1) root (hd0,1) kernel /boot/kernelname root=/dev/hda4 angebe und dann in der prompt "boot"

    Die grub.conf sieht folgendermassen aus :

    default 0
    timeout 30
    titel=....
    root (hd0,1)
    kernel /boot/kernel-2.6.18-gentoo-r3 root=/dev/hda4

    leider verstehe ich nicht ganz wo der fehler liegt zumal unknown-block(3,4)
    mir nicht viel sagt 0,4 sollte ja /dev/hda4 sein und 0,3 hda3 die swap partition

    Das System ist frisch installiert als kernel source habe ich die gentoo-sources verwendet.
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 supersucker, 04.12.2006
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    Prüf mal ob du

    1. Die Treiber für deinen IDE-Controller und deine verwendeten Filesysteme im Kernel hast und

    2. ob die fest drin sind, die dürfen nicht als Modul geladen werden.

    10 zu 1 das da der Fehler liegt.
     
  4. Nano

    Nano Foren As

    Dabei seit:
    02.12.2006
    Beiträge:
    93
    Zustimmungen:
    0
    Danke daran hat es gelegen, ext3 war nur als M eingeteragen die .config baute wohl auf XFS als root partion auf, leider gelingt es mir aber noch nicht den kernel zu booten

    no filesystem could mount root, tried: ext3
    Kernel panic - not syncing : VFS : Unable to mount root fs on unknown-block(3,4)

    in der grub prompt habe ich nach durcharbeiten des manuals und des handbuchs

    root (hd0,1) angegeben da /dev/hda2 meine /boot enthält
    setup (hd0,1) ebenfalls wegen /dev/hda2
    kernel /boot/kernelname root=/dev/hda4

    wobei bei letzterem wohl das problem liegt, allerdings kann ich es nicht finden
    per google wurde das versuchen von root=/dev/hd4 empfohlen dies funktioniert leider auch nicht

    gebe ich die falschen parameter mit oder habe ich eventuel etwas mit der root partition falsch gemacht, inizialisiert wurde sie mit mke2fs -j /dev/hda4 was ext3 entsprechen sollte.
     
  5. Jabo

    Jabo Aufgabe ohne Minister

    Dabei seit:
    12.10.2006
    Beiträge:
    1.322
    Zustimmungen:
    0
    Ort:
    Hamburg
    Keine Module?

    Hallo,

    ich dachte doch, bloß wenn man initrd benutzt, müssen benötigte Module wie das für das Root-Filesystem mit in die Ramdisk?! Macht Gentoo das anders?

    Sie dürfen nur nicht als Module auf einem Filesystem liegen, wo man die für bräuchte, um es zu mounten überhaupt.... dann wäre der Schlüssel zur Kiste in der Kiste.

    Bei mir packt "mk_initrd" immer das Modul mit rein.

    Wenn man mit initrd bootet und legt auf dem Root-Dateisystem einen leeren Ordner /initrd an, hat man nach erfolgreichem Booten deren Inhalt in diesem Ordner, da auch das:
    Code:
    /initrd/lib/modules/[Kernel-Version]/kernel/fs/[Dateisystem-Name]/[Dateisystem].ko
    
     
  6. Nano

    Nano Foren As

    Dabei seit:
    02.12.2006
    Beiträge:
    93
    Zustimmungen:
    0
    die initrid benutze ich nicht die ist doch nur für genkernel gedacht oder irre ich mich da?
     
  7. #6 keytoaster, 05.12.2006
    keytoaster

    keytoaster Jungspund

    Dabei seit:
    21.10.2006
    Beiträge:
    21
    Zustimmungen:
    0
    Ort:
    Hamm
    Laut Handbuch sollte man keine initrd verwenden (wie es auch 90% aller Gentoo-User tun). Die Treiber für ext3 und die IDE bzw. S-ATA-Treiber müssen also fest in den Kernel einkompiliert werden.
     
  8. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  9. Nano

    Nano Foren As

    Dabei seit:
    02.12.2006
    Beiträge:
    93
    Zustimmungen:
    0
    es hat geklappt, die initrd ist nicht nötig es lag wie von supersucker bereits gesagt daran das die ext2 und 3 filesystem im kernel nur als module angegeben waren.

    Danke!
     
  10. Jabo

    Jabo Aufgabe ohne Minister

    Dabei seit:
    12.10.2006
    Beiträge:
    1.322
    Zustimmungen:
    0
    Ort:
    Hamburg
    warum?

    Hallo,

    ich muß erst mal sagen, daß ich mit Gentoo bisher nur "liebäugele", aber es außer in einer VM (von einer ISO) noch nicht installiert habe. Das Thema finde ich aber nicht uninteressant.

    Natürlich ist eine Initrd nicht *nötig*, bevor es die gab, konnte Linux ja auch booten :O ... A-Bär:

    Ist das nicht gerade ein *Vorteil*, daß ein Kernel aus einer Intrd heraus immer noch modular funktionieren kann und man bei Bedarf dort einfach ein entsprechendes Modul rein / dazu tut, satt den Kernel mit entsprechenden statischen Einstellungen neu kompilieren zu müssen?

    Ansonsten ist es (siehe auch mein voriges Posting) natürlich so, daß ohne Initrd alles statisch in den Kernel muß, was dieser braucht, um auf das Dateisystem zugreifen zu können. Bei Gentoo ist das Thema bestimmt auch ausgiebig diskutiert worden, da stecke ich nicht so in der Materie drin...

    Aber was spricht wirklich gegen eine Intrd? Ok, ich werde mal darauf hin das Gentoo-Handbuch wälzen, das hier ist eine spontane Reaktion von mir, ich hab's noch nicht nachgelesen!
     
Thema:

XFS : bad magic number -> Kernel Panic

Die Seite wird geladen...

XFS : bad magic number -> Kernel Panic - Ähnliche Themen

  1. Sun Blade 1000 mit Fehlermeldung: bad magic number in disk label

    Sun Blade 1000 mit Fehlermeldung: bad magic number in disk label: Hallo Forum, ich habe mir über Ebay eine Sun Blade 1000 Maschine ohne DVD-ROM und Monitor gekauft. Habe mir daraufhin ein DVD ROM (Scsi) und...
  2. "bad gzip magic numbers"

    "bad gzip magic numbers": Ich habe mal versucht Mandrake drauf zu spielen. Installation klappt auch problemlos. Bloß wenn ich dann nach der Installation Mandrake starten...
  3. MagicStick erhält Ubuntu Core als Alternative

    MagicStick erhält Ubuntu Core als Alternative: MagicStick ist ein derzeit auf Indiegogo finanzierter PC-Stick, der ein TV-Gerät in einen Smart-TV verwandeln soll. Wegen des großen Erfolgs ist...
  4. Magicka 2 für Linux veröffentlicht

    Magicka 2 für Linux veröffentlicht: Das von Pieces Interactive entwickelte und von Paradox vertriebene »Magicka 2« steht nun auch allen Linux- und SteamOS-Spielern zum Bezug bereit....
  5. Magic Lantern startet Linux auf Canon EOS

    Magic Lantern startet Linux auf Canon EOS: Die Entwickler der Firmware-Erweiterung »Magic Lantern«, die verschiedene Canon-Kameramodelle um neue Funktionalität erweitert, haben Linux auf...