WPA-PSK mit der WLAN karte WG311T

Dieses Thema im Forum "Internet, lokale Netzwerke und Wireless Lan" wurde erstellt von ccc, 23.02.2006.

  1. #1 ccc, 23.02.2006
    Zuletzt bearbeitet: 25.02.2006
    ccc

    ccc Routinier

    Dabei seit:
    01.11.2003
    Beiträge:
    288
    Zustimmungen:
    0
    hi

    bringe WPA-PSK mit der WLAN karte WG311T von Netgear unter Debian Sarge Stable nicht zum laufen:
    Code:
    # lsmod | grep ath
    ath_pci                81596  0
    ath_rate_sample        16584  1 ath_pci
    wlan                  146140  4 wlan_wep,ath_pci,ath_rate_sample
    ath_hal               148592  3 ath_pci,ath_rate_sample
    
    
    # vi /etc/default/wpasupplicant
    
    # WARNING! Make sure you have a configuration file!
    
    ENABLED=1
    
    # Useful flags:
    #  -D <driver>          Wireless Driver
    #  -i <ifname>          Interface (required, unless specified in config)
    #  -c <config file>     Configuration file
    #  -d                   Debugging (-dd for more)
    #  -w                   Wait for interface to come up
    
    OPTIONS="-i ath0 -D madwifi -c /etc/wpa_supplicant.conf -w"
    
    
    # vi /etc/wpa_supplicant.conf
    
    ctrl_interface=/var/run/wpa_supplicant
    ctrl_interface_group=0
    eapol_version=1
    #nach Access Point suchen
    ap_scan=0
    
    
    # WPA-PSK
    network={
            proto=WPA2
            key_mgmt=WPA-PSK
    	pairwise=CCMP TKIP 
            group=TKIP
            scan_ssid=1      
    	ssid="myessid"
            psk="mykey"
    }
    
    
    # vi /etc/network/interfaces
    
    # wg311t wireless card 
    auto ath0
    iface ath0 inet static
    address 192.168.200.20
    netmask 255.255.255.0
    network 192.168.200.0
    broadcast 192.168.200.255
    gateway 192.168.200.1
    dns-nameservers 192.168.200.1
    dns-search dom
    #wireless-essid myessid
    #wireless-channel auto
    #wireless-key mykey
    #up /sbin/iwpriv ath0 authmode 2
    name wlan WG311T
    
    
    # wpa_supplicant -i ath0 -c /etc/wpa_supplicant.conf -D madwifi -w
    Trying to associate with 00:0f:b5:3b:d8:e6 (SSID='myessid' freq=2457 MHz)
    ioctl[IEEE80211_IOCTL_SETMLME]: Argument list too long
    Association request to the driver failed
    Authentication with 00:00:00:00:00:00 timed out.
    
    weiss jemand woran es liegt ?
    WEP Verschlüsselung funktionierte aber mit dieser hardware bestens.
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. sven

    sven devilz|work

    Dabei seit:
    23.02.2006
    Beiträge:
    176
    Zustimmungen:
    0
    Ort:
    Rhein-Main
    Du könntest mal den CVS Treiber von madwifi Probieren ....
     
  4. nic

    nic typeT

    Dabei seit:
    25.01.2006
    Beiträge:
    34
    Zustimmungen:
    0
    Welche Version von wpa_supplicant hast du denn?
    Afaik gab es mit den madwifi Treibern einige Probleme.

    Ansonsten versuch mal das ganze per iwconfig und iwpriv per Hand zum Laufen zu bekommen, dann siehst du wenigstens mal ob es denn ueberhaupt funktioniert.

    Und dann wuerde ich mal dieser Zeile etwas Aufmerksamkeit widmen, vielleicht bringt dich das weiter:
     
  5. ccc

    ccc Routinier

    Dabei seit:
    01.11.2003
    Beiträge:
    288
    Zustimmungen:
    0
    Code:
    # wpa_supplicant -v
    wpa_supplicant v0.3.8
    Copyright (c) 2003-2005, Jouni Malinen <jkmaline@cc.hut.fi> and contributors
    
    ich glaube das problem ist:

    0: 00:0f:b5:3b:d8:e6 ssid='myessid' wpa_ie_len=24 rsn_ie_len=0
    skip - could not parse WPA/RSN IE
    Code:
    # wpa_supplicant -w -i ath0 -D madwifi -c /etc/wpa_supplicant.conf -dd
    
    Initializing interface 'ath0' conf '/etc/wpa_supplicant.conf' driver 'madwifi'
    Configuration file '/etc/wpa_supplicant.conf' -> '/etc/wpa_supplicant.conf'
    Reading configuration file '/etc/wpa_supplicant.conf'
    ctrl_interface='/var/run/wpa_supplicant'
    ctrl_interface_group=0
    eapol_version=1
    ap_scan=0
    Line: 10 - start of a new network block
    proto: 0x2
    key_mgmt: 0x2
    pairwise: 0x18
    group: 0x8
    scan_ssid=1 (0x1)
    ssid - hexdump_ascii(len=12):
         61 6c 61 6d 61 6b 6f 74 61 37 37 37               myessid
    PSK - hexdump(len=32): [REMOVED]
    Priority group 0
       id=0 ssid='myessid'
    Initializing interface (2) 'ath0'
    EAPOL: SUPP_PAE entering state DISCONNECTED
    EAPOL: KEY_RX entering state NO_KEY_RECEIVE
    EAPOL: SUPP_BE entering state INITIALIZE
    EAP: EAP entering state DISABLED
    EAPOL: External notification - portEnabled=0
    EAPOL: External notification - portValid=0
    Own MAC address: 00:0f:b5:26:d1:c9
    wpa_driver_madwifi_set_wpa: enabled=1
    wpa_driver_madwifi_del_key: keyidx=0
    wpa_driver_madwifi_del_key: keyidx=1
    wpa_driver_madwifi_del_key: keyidx=2
    wpa_driver_madwifi_del_key: keyidx=3
    wpa_driver_madwifi_set_countermeasures: enabled=0
    wpa_driver_madwifi_set_drop_unencrypted: enabled=1
    Setting scan request: 0 sec 100000 usec
    Wireless event: cmd=0x8b06 len=8
    RTM_NEWLINK, IFLA_IFNAME: Interface 'ath0' added
    RTM_NEWLINK, IFLA_IFNAME: Interface 'ath0' added
    EAPOL: Port Timers tick - authWhile=0 heldWhile=0 startWhen=0 idleWhile=0
    EAPOL: Port Timers tick - authWhile=0 heldWhile=0 startWhen=0 idleWhile=0
    Wireless event: cmd=0x8b19 len=12
    Received 743 bytes of scan results (3 BSSes)
    Scan results: 3
    Selecting BSS from priority group 0
    0: 00:0f:b5:3b:d8:e6 ssid='myessid' wpa_ie_len=24 rsn_ie_len=0
       skip - could not parse WPA/RSN IE
     
  6. nic

    nic typeT

    Dabei seit:
    25.01.2006
    Beiträge:
    34
    Zustimmungen:
    0
    Funktionierts denn mit "proto=WPA" anstelle von WPA2?

    Was passiert wenn du das Ganze per Hand startest:
    Code:
    ifconfig ath0 up
    iwconfig ath0 mode "managed"
    iwpriv ath0 set AuthMode="WPAPSK"
    iwpriv ath0 set EncrypType="AES"
    iwpriv ath0 set WPAPSK="YOURSECRETKEY"
    iwconfig ath0 essid "youressid" 
    
    Evtl. noch dhcp starten oder direkt eine IP zuweisen.
     
  7. #6 ccc, 26.02.2006
    Zuletzt bearbeitet: 26.02.2006
    ccc

    ccc Routinier

    Dabei seit:
    01.11.2003
    Beiträge:
    288
    Zustimmungen:
    0
    mit "proto=WPA" funktioniert auch nicht

    und wenn ich von Hand eingebe, dannn habe folgende Fehlermeldungen:
    Code:
    debian:~# ifconfig ath0 up
    debian:~# iwconfig ath0 mode "managed"
    debian:~# iwpriv ath0 set AuthMode="WPAPSK"
    Invalid command : set
    debian:~# iwpriv ath0 set EncrypType="AES"
    Invalid command : set
    debian:~# iwpriv ath0 set WPAPSK="mykey"
    Invalid command : set
    debian:~# iwconfig ath0 essid myessid
    debian:~#
     
  8. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  9. nic

    nic typeT

    Dabei seit:
    25.01.2006
    Beiträge:
    34
    Zustimmungen:
    0
    Nach einem kurzen google hab ich den Eindruck, dass die Hardware WPA nur nach einem Upgrade (Firmware evtl?!) zu unterstuezen scheint.
    Ich wuerde mal in der Richtung ein bissl suchen, evtl kann die Karte im Moment mit WPA garnix anfangen (weshalb auch iwpriv dann meckert)...
     
  10. #8 ccc, 26.02.2006
    Zuletzt bearbeitet: 06.03.2006
    ccc

    ccc Routinier

    Dabei seit:
    01.11.2003
    Beiträge:
    288
    Zustimmungen:
    0
    es funktioniert jetzt !

    es lag aber nicht an der firmware.

    ich habe folgendes gemacht:zuerst das neuster madwifi holen und installieren:
    Code:
    # cd /usr/src
    # svn checkout http://svn.madwifi.org/trunk madwifi-ng
    # cd madwifi-ng
    # make clean 
    # make
    # make install
    
    anschliessend neuster wpa_supplicant von http://hostap.epitest.fi/wpa_supplicant/
    entpacken, anpassen und installieren:
    Code:
    # cd wpa_supplicant-0.4.8
    
    mit dem editor ein file .config erstellen und folgendes hinfügen:
    
    # cat .config
    CONFIG_DRIVER_MADWIFI=y
    CFLAGS += -I/usr/src/madwifi-ng
    CONFIG_CTRL_IFACE=y
    
    der pfad zu madwifi-ng unbedingt anpassen !
    
    # make clean
    # make 
    # make install
    
    jetzt kann ich starten mit:
    Code:
    # /usr/local/sbin/wpa_supplicant -B -w -i ath0 -D madwifi -c /etc/wpa_supplicant.conf -dd
    State: GROUP_HANDSHAKE -> COMPLETED
    
    es lag sehr wahrscheinlich an wpa_supplicant und erst mit der neusten version funktioniert !

    nur mit ifconfig sehe ich, dass meine wlan karte jetzt doppelt erkant wird als ath0 und wifi0
     
Thema:

WPA-PSK mit der WLAN karte WG311T

Die Seite wird geladen...

WPA-PSK mit der WLAN karte WG311T - Ähnliche Themen

  1. AVM Fritz WLAN USB-Stick mit WPA-PSK über ndiswrapper installieren

    AVM Fritz WLAN USB-Stick mit WPA-PSK über ndiswrapper installieren: Wollte den AVM Fritz WLAN USB-Stick unter SuSe 10.1 mit Hilfe von ndiswrapper installieren. Bin nach der Anleitung von vorgegangen. Hab...
  2. SUSE 10.1 und WLAN mit WPA-PSK

    SUSE 10.1 und WLAN mit WPA-PSK: Wie kann ich mich bei SUSE 10.1 in ein Netzwerk das WPA verschlüsselt ist einloggen? Die vorgegebene Funktion ist ja nur für WEP. Danke.
  3. Routing 2 Subnetze (WLAN und ETH)

    Routing 2 Subnetze (WLAN und ETH): Hallo, hoffe ich bin hier richtig. Ich habe ein Raspberry Pi welcher als WLAN-Accesspoint dient. Dabei sehen die Interfaces wie folgt aus: wlan1...
  4. Installation, aber wo hin mit dem WLAN Passwort?

    Installation, aber wo hin mit dem WLAN Passwort?: Hallo, ich hab nicht gewußt wohin mit dem Wlan-Passwort (WPA2). Dadurch habe ich MidnightBSD gefunden und da installier ich was, aber es ist...
  5. Raspberry Pi 3 mit WLAN und Bluetooth

    Raspberry Pi 3 mit WLAN und Bluetooth: Die Gerüchteküche um einen neuen Raspberry Pi köchelt schon seit einigen Monaten. Jetzt gibt es erste konkrete Hinweise, was Nutzer von dem neuen...