WLAN Verbindung bricht zusammen

Dieses Thema im Forum "Internet, lokale Netzwerke und Wireless Lan" wurde erstellt von Klein_Karlchen, 22.09.2007.

  1. #1 Klein_Karlchen, 22.09.2007
    Klein_Karlchen

    Klein_Karlchen Jungspund

    Dabei seit:
    28.04.2006
    Beiträge:
    11
    Zustimmungen:
    0
    Also ich habe folgendes Problem. Mein WLAN Verbindung bricht unter Linux regelmäßig zusammen und muss sich dann neu auf bauen, das ist ganz schön nervig, wenn man Webseiten dauernd neuladen muss und das Webradio dauernd ins stocken kommt.
    Irgendwann nach ca. 10 Mal neu aufbauen der Verbindung, läst sich dann gar keine Verbindung mehr herstellen.
    Unter Windows funktioniert das WLAN ohne Probleme. Die Verbindungsstärke beträgt unter Windows und Linux mehr als 75 Prozent. Der Access Point ist auch nur eine Wand entfernt.
    Mein Rechner ist ne IBM Thinkpad (T41) mit einem Atheros 5212 WLAN-Chip. Mein Linux ist ne OpenSuSE 10.2 mit aktuellen 0.9.3.2 madwifi Treibern. Mein Windows ist ne XP mit den von IBM mit gelieferten Treibern.
    Die Verbindung ist WEP verschlüsselt. Der Router auf der anderen Seite der Funkstrecke ist ein Siemens SE551.
    Zum Verbindungsaufbau nutze ich den in OpenSuSE mitgelieferte KNetworkManager.

    dmesg gibt folgendes aus:
    Code:
    ath0: no IPv6 routers present
    ADDRCONF(NETDEV_UP): ath0: link is not ready
    ADDRCONF(NETDEV_CHANGE): ath0: link becomes ready
    martian source 192.168.2.101 from 77.67.2.203, on dev ath0
    ll header: 00:05:4e:45:c7:c1:00:01:e3:e9:9e:2a:08:00:45:00:02:00:49:04:40:00:3b:11:e1:cd:4d:43:02:cb:c0:a8:02:65:60:bf:1b:3a:01:ec:0c:ac:a0:ff:08:00:09:00:04:24:c5:40:09:0f:43:2c:53:84:f6:00:00:7a:d1:10:d0:a5:46:a4:58:63:17:f9:12:7f:6e:60:7d:13:7a:7f:52:27:38:c4:0e:d5:e5:f5
    
    ....
    
    martian source 192.168.2.101 from 77.67.2.203, on dev ath0
    ll header: 00:05:4e:45:c7:c1:00:01:e3:e9:9e:2a:08:00:45:00:01:f7:49:0d:40:00:3b:11:e1:cd:4d:43:02:cb:c0:a8:02:65:60:bf:1b:3a:01:e3:9a:60:40:09:18:43:2c:53:89:0b:00:00:72:c5:49:87:12:22:48:28:9c:71:b8:5a:df:59:52:83:be:10:ff:ed:05:d2:a9:8c:53:cb:5f:16:a1:d9:8c:10:52:86:0c:72
    ath0: no IPv6 routers present
    ADDRCONF(NETDEV_UP): ath0: link is not ready
    ADDRCONF(NETDEV_CHANGE): ath0: link becomes ready
    
    Würde mich sehr freuen wenn mir jemand helfen kann, den sonst muss ich das ungeliebte Windows nutzen.
    Gruß Karl
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 Tomekk228, 22.09.2007
    Tomekk228

    Tomekk228 Lebende Foren Legende

    Dabei seit:
    14.08.2007
    Beiträge:
    2.417
    Zustimmungen:
    0
    Ort:
    /home/tomekk/
    Wie wurde das gerät installiert? nativ oder ndiswrapper?
    Freund von mir konnte seine Atheros wlan karte nur mit ndiswrapper nutzen und dazu noch mit der einschränkung 11g. Demzufolge brach auch ab und zu die verbindung ab.

    Poste mal die ausgabe von "iwconfig"
     
  4. #3 Klein_Karlchen, 22.09.2007
    Zuletzt bearbeitet: 22.09.2007
    Klein_Karlchen

    Klein_Karlchen Jungspund

    Dabei seit:
    28.04.2006
    Beiträge:
    11
    Zustimmungen:
    0
    Um die konfiguration habe ich mir nicht viele Gedanken gemacht, hab also wahrscheinlich nicht den ndiswrapper genutzt.

    Code:
    # iwconfig
    lo        no wireless extensions.
    
    irda0     no wireless extensions.
    
    eth0      no wireless extensions.
    
    wifi0     no wireless extensions.
    
    ath0      IEEE 802.11g  ESSID:"WEBM-13-440"
              Mode:Managed  Frequency:2.427 GHz  Access Point: Not-Associated
              Bit Rate:24 Mb/s   Tx-Power:14 dBm   Sensitivity=1/1
              Retry:off   RTS thr:off   Fragment thr:off
              Encryption key:4457-696E-6664-4264-574D-3134-21   Security mode:restricted
              Power Management:off
              Link Quality=51/70  Signal level=-42 dBm  Noise level=-93 dBm
              Rx invalid nwid:2436  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    
    sit0      no wireless extensions.
    
    
     
  5. #4 Tomekk228, 22.09.2007
    Zuletzt bearbeitet: 22.09.2007
    Tomekk228

    Tomekk228 Lebende Foren Legende

    Dabei seit:
    14.08.2007
    Beiträge:
    2.417
    Zustimmungen:
    0
    Ort:
    /home/tomekk/
    looking here>
    Code:
    [tomekk@Arch ~]$ iwconfig
    lo        no wireless extensions.
    
    eth0      no wireless extensions.
    
    eth1      IEEE 802.11g  ESSID:"wlan"  
              Mode:Managed  Frequency:2.472 GHz  Access Point: 00:04:0E:2E:86:86   
              Bit Rate:[B]54 Mb/s[/B]   Tx-Power:15 dBm   
              Retry limit:15   RTS thr:off   Fragment thr:off
              Power Management:off
              Link Quality=98/100  Signal level=-26 dBm  Noise level=-27 dBm
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:309   Missed beacon:0
    
    [tomekk@Arch ~]$ 
    
    > http://de.wikipedia.org/wiki/Wireless_Local_Area_Network#Datenraten

    Du hast weniger als die hälfte, vllt erklärt das schon alles, hast schonmal anderen stick oder so probiert? oder unter eine andere distri mit dem selben hardware?
     
  6. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

WLAN Verbindung bricht zusammen

Die Seite wird geladen...

WLAN Verbindung bricht zusammen - Ähnliche Themen

  1. Mit Wlan-Stick Netgear wg111v3 Internetverbindung herstellen

    Mit Wlan-Stick Netgear wg111v3 Internetverbindung herstellen: Hallo Leute, ich habe das Problem, dass ich mit meinem Wlan-Stick Netgear WG111v3 keine Internetverbindung herstellen kann. Er erkennt ihn, aber...
  2. Internet DSL WLAN Verbindung Opensolaris

    Internet DSL WLAN Verbindung Opensolaris: Hi, ich habe fuer meine Netzwerkarte den nfo Treiber installiert. Der command devfsadm -i nfo meldet devfsadm: driver failed to attach: nfo....
  3. Ubuntu 9.04: keine WLAN-Verbindung

    Ubuntu 9.04: keine WLAN-Verbindung: Ich habe Ubuntu 9.04 installiert und wollte mich nun mit meinem WLAN verbinden. Frage 1: -------- Mein WLAN-Gerät bietet mir nur eine...
  4. Verbindungslevel WLAN unter Linux miserabel, unter Windows hervorragend

    Verbindungslevel WLAN unter Linux miserabel, unter Windows hervorragend: Hallo Gemeinde, in meiner Not wende ich mich an Euch. Stundenlange verzweifelte Suche im Netz brachte keine befriedigenden Ergebnisse :/ Mein...
  5. Opensuse 11 WLAN sichtbar, jedoch keine Verbindung

    Opensuse 11 WLAN sichtbar, jedoch keine Verbindung: Hallo, das WLAN ist sichtbar, jedoch läuft das Zahnrad ca. 1 Minute und es kommt keine Verbindung zustande. Per LAN geht es einwandfrei....