WLAN USB Stick unter OpenSuse 10.1

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von DerKleineVomSee, 04.08.2006.

  1. #1 DerKleineVomSee, 04.08.2006
    DerKleineVomSee

    DerKleineVomSee Grünschnabel

    Dabei seit:
    04.08.2006
    Beiträge:
    4
    Zustimmungen:
    0
    Hi an alle die mir helfen wollen,
    ich beschreibe erstmal mein Problem. Ich habe letzte Woche OpenSuse 10.1 installiert und bin eigentlich ziemlich zufrieden damit. Das einzigste was ich nicht hinbekomme ist mein USB WLAN Stick. Bei diesem USB Stick handelt es sich um den D-Link DWL-122, welcher unter Suse 10.0 auch noch wunderbar funkionierte. Kurze Ablaufbeschreibung was ich gemacht habe um den Stick zum laufen zu bekommen.

    Als erstes habe ich das Paket wireless-tools per yast installiert, weil in diesem Paket die benötigten prism2_usb Treiber vorhanden sein sollen. Als nächstes habe ich den WLAN USB Stick eingesteckt und alle benötigten Einstellungen unter Yast->Netzwerkgeräte->Netzwerkarte vorgenommen. Anschließend wollte ich per Hand das benötigte Kernel Modul als Root wie folgt nachladen.

    $ modprobe prism2_usb
    leider mit folgender Fehlermeldung
    FATAL: Module prism2_usb not found.

    Leider verstehe ich nicht warum das nicht funktioniert. Mittels make xconfig habe ich im Kernel noch einmal nachgeschaut ob die Prism2 sachen auch korrekt eingetragen sind. (Als Module)...und das sind sie auch.

    Auch wenn ich den Rechner neustarte wird niemals dieser prism2_usb Treiber als Modul geladen. Fehlermeldungen in den /var/log/xxx Dateien habe ich nicht gefunden. Der USB Stick wird aber korrekt vom System geladen, nur der WLAN Treiber nicht.

    Ich hoffe einer von euch erkennt meinen Fehler oder weis, wo das Problem liegt. ndiswrapper möchte ich verwenden, weil ich damit nicht wirklich gute Erfahrungen in der Vergangenheit gesammelt habe.

    Ich bin für jeden Hinweis und Tip sehr dankbar. (Hat sich in sachen WLAN irgendwas wichtiges zwischen Suse 10.0 und 10.1 geändert?)
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. obec

    obec Foren As

    Dabei seit:
    02.07.2006
    Beiträge:
    86
    Zustimmungen:
    0
    Hallo,

    das ist das gleiche Problem wie bei dem Fritz! USB WLAN Stick.Der Treiber aggiert mit dem neuen Kernel aus SuSE 10.1 nicht.Bei ndiswrapper ist das leider das gleiche.Ich würde mal einen properitären Treiber versuchen(Gibst im Web).
    Welchen Chipsatz hast du(Zydas, Railink)?

    Gruß

    obec
     
  4. #3 DerKleineVomSee, 05.08.2006
    DerKleineVomSee

    DerKleineVomSee Grünschnabel

    Dabei seit:
    04.08.2006
    Beiträge:
    4
    Zustimmungen:
    0
    Ohhh. Irgendwie erschreckt mich deine Antwort und macht mich auch wieder froh.(Bin doch wohl doch nicht so blöde dafür :-)). Aber wie kommst du auf diese erkenntnis, dass das mit dem suse 10.1 kernel nicht passt und welchen grund gibt es dafür?
    Chipsatz ist ein Prism 2/2.5/3. (http://de.opensuse.org/HKL/Netzwerk-Karten_(WLAN)#USB).
    Welche andere Möglichkeit gibt es den WLAN USB Stick nutzen zu können??

    PS: Habe heute mal ein update gemacht und nutze jetzt den Kernel 2.6.16.21-0.13
     
  5. obec

    obec Foren As

    Dabei seit:
    02.07.2006
    Beiträge:
    86
    Zustimmungen:
    0
    Hallo,

    der Kernel ist einfach zu neu für die Treiber.In deinem Fall würde ich eher ein Downgrade empfehlen:War nurn Witz:D .Ich würde trotztdem mal den Properitäen Treiber versuchen.
    Ansonsen musst du ein "Kernel-Downgrade":D machen oder wieder auf SuSE 10.0 wechseln.

    Gruß

    obec
     
  6. #5 DerKleineVomSee, 05.08.2006
    Zuletzt bearbeitet: 05.08.2006
    DerKleineVomSee

    DerKleineVomSee Grünschnabel

    Dabei seit:
    04.08.2006
    Beiträge:
    4
    Zustimmungen:
    0
    Welchen Properitären Treiber würdest du für diesem Chipsatz entfehlen?
    Ich habe micht für den rt2570(usb) entschieden weil damit auch mein WLAN USB Stick funktionieren soll. (http://rt2x00.serialmonkey.com/wiki/index.php/Downloads). Als erste habe ich jetzt den Treiber installiert und mittels modprobe geladen, was ohne Probleme funktionierte. Anschließend habe ich die Netzwerkkarte eingerichtet (Gerätetyp Drathlos und Modulname rt2570).
    Nach einem Neustart des Rechners habe ich mit nochmal die Modulliste mittels lsmod ausgeben lassen.
    $lsmod
    rt2570 163776 0
    usbcore 115716 5 usb_storage,uhci_hcd,ehci_hcd,rt2570
    (nur die beiden wichtigen)
    ....und das sieht erstmal richtig aus.

    Falls ich jetzt jedoch iwconfig aufrufe erhalte ich nur diese Geräte. Sollte da nicht wlan0 auftauchen?(Ist zumindest der Gerätename unter Yast)
    $ iwconfig
    lo no wireless extensions.

    eth0 no wireless extensions.

    sit0 no wireless extensions.


    Auch beim Aufruf von ifconfig taucht wlan0 nicht auf, auch wenn man es manuell landen möchte.

    Habe ich irgendwas vergessen in config Dateien noch eintragungen zu machen?
     
  7. #6 DerKleineVomSee, 21.09.2006
    DerKleineVomSee

    DerKleineVomSee Grünschnabel

    Dabei seit:
    04.08.2006
    Beiträge:
    4
    Zustimmungen:
    0
    Nach langer langer Zeit habe ich jetzt mal den WLAN USB Stick zum laufen bekommen. Da einige immer noch Probleme haben, mal eine kurze Anleitung wie ich den Stick zum funken gebracht habe.
    Ich hatte gelesen das der Stick bein eingen Leuten funktioniert, falls dieser bei der Installation angeschlossen habe. Also habe ich mir einfach die DVD genommen und ein Update des Systems vorgenommen. Somit werden zwar die schon Online aktuallisierteren Pakete gelöscht und die Pakete mit den Stand auf der DVD aktualisiert, aber das kann man ja im nachhinein nochmal updaten. Als nach der Installation auf neue Updates geprüft werden sollte, wurde der D-Link dwl-122 gefunden. Nun nur noch unter Yast die entsprechenden Einstellungen vorgenommen (SSID, Verschlüsselung etc.) und nun funktioniert er ohne Probleme.
    Ist vielleicht nicht die schönste Variante, aber hauptsache man kann ihn nun verwenden. Ich hoffe ich kann einigen Leuten damit helfen.
     
  8. #7 Yogibaer, 01.11.2006
    Yogibaer

    Yogibaer Routinier

    Dabei seit:
    01.11.2006
    Beiträge:
    330
    Zustimmungen:
    0
    Bei mir liegt ein ähnliches Problem vor. Ich habe einen USB-WLAN-Stick von Micronet. Da steckt ein ZYDAS Chip drin. Mit den Anleitungen von der Zyxel Seite ist es mir gelungen, diesen Stick ans laufen zu bringen. Das finktioniert, da ich momentan mit meinem Suse dies Nachricht schreibe. Ich habe aber noch ein Problem. Ich muß das WLAN Netzwerk nach dem Booten manuell starten. Als erstes kommt ein

    Terminal aufmachen

    ifconfig wlan0 up

    Terminal: exit

    Dann Yast die Netzwerkverbindungen öffnen. Irgendeine Änderung vornehmen, ohne diese zu übernehmen, und dann Beenden. Dann startet das Networkmanger applet und ich darf mich verbinden. Übrigens wird nach dem Booten auch die vorhandene, aber nicht verwendete eth0 nicht bei ifconfig angezeigt.

    Meine Frage: Wie bringe ich das WLAN beim booten dazu, direkt aktiv zu sein. Ich weiß, dass wahrscheinlich noch Infos fehlen werden, aber ich kenne mich bei Linux nur bedingt aus und bin stolz, diesen Stick überhaupt ans Laufen bekommen zu haben.

    Für Eure Hilfe möchte ich mich jetzt schon bedanken.
     
  9. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  10. g0t0

    g0t0

    Dabei seit:
    25.05.2006
    Beiträge:
    313
    Zustimmungen:
    0
    schreib einfach mal ans ende der /etc/init.d/rc.d (oder so ähnlich) dein ifconfig wlan0 up.

    Dann fügst du im yast ein gerät hinzu und klicks auf die methode mit dem networkmanager und nicht traditionell mit ifup. Da fügst du dien gerät hinzu noch die richtigen modulnamen eingeben und fertig.
     
  11. #9 Yogibaer, 09.11.2006
    Yogibaer

    Yogibaer Routinier

    Dabei seit:
    01.11.2006
    Beiträge:
    330
    Zustimmungen:
    0
    Ich will das hier nur abschliessen. Ich fahre mittlerweile das Wlan mit ifup hoch und das tut es sehr gut. Mit dem networkmanager war in der gleichen konfiuration noch immer ein Problem. Das durchforsten der vielen Foren hilft manchmal doch. Aber danke für Eure Hilfe.
     
Thema:

WLAN USB Stick unter OpenSuse 10.1

Die Seite wird geladen...

WLAN USB Stick unter OpenSuse 10.1 - Ähnliche Themen

  1. SuSe 11.4 und wlan stick TL-WN422g

    SuSe 11.4 und wlan stick TL-WN422g: Hallo erstmal an alle, Ich habe da ein Problem und versuche es jetzt schon seit geschlagenen 3stunden selbst zu lösen (mit Pausen:D) Ich...
  2. Cisco WUSB600N wlan stick installieren

    Cisco WUSB600N wlan stick installieren: Hallo, ich wollte meinen USB Stick WUSBN600N ver. 2 unter linux installieren. Habe bereits im internet geschaut, dort habe ich aber keine...
  3. Mit Wlan-Stick Netgear wg111v3 Internetverbindung herstellen

    Mit Wlan-Stick Netgear wg111v3 Internetverbindung herstellen: Hallo Leute, ich habe das Problem, dass ich mit meinem Wlan-Stick Netgear WG111v3 keine Internetverbindung herstellen kann. Er erkennt ihn, aber...
  4. USB WLan Stick für Netzwerk und Drucker

    USB WLan Stick für Netzwerk und Drucker: Guten Abend Ich suche einen USB WLan Stick der unter Mandriva oder OpenSuse gut läuft. Er sollte den 802.11g Standard reibungslos beherschen....
  5. ein wlan-stick zwei rechner

    ein wlan-stick zwei rechner: hallo, ich habe folgendes problem. ich bekomme im moment mein internet über einen wlan-stick, der über usb an einem rechner angeschlossen ist....