wlan usb mit linux suse 9.0 home einrichten

Dieses Thema im Forum "Internet, lokale Netzwerke und Wireless Lan" wurde erstellt von meistert, 13.04.2004.

  1. #1 meistert, 13.04.2004
    meistert

    meistert Grünschnabel

    Dabei seit:
    13.04.2004
    Beiträge:
    6
    Zustimmungen:
    0
    Hallo zusammen,
    könnte mir jemand helfen einen D-Link DWL-120+ USB Wlan über LINUX SUSE 9.0 HOME EDITION mit D-Link DI-614+ zu verbinden. Habe schon viel darüber gelesen komme allerdings trotzdem nicht weiter. Der ständige Wechsel zwischen WinXP und SUSE treibt mich langsam zum Wahnsinn.
    Unter anderem habe ich versucht über die Netzwerkkonfiguration den Adapter einzurichten. Jedoch erfolglos!
    Und für mich unerklärlich kann ich den Befehl iwconfig nicht nutzen.

    Über jede Hilfe würde ich mich freuen

    Gruß
    Markus
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 SilverHawK, 13.04.2004
    SilverHawK

    SilverHawK UnBanned

    Dabei seit:
    08.03.2004
    Beiträge:
    170
    Zustimmungen:
    0
    Ort:
    Franken - Coburg
    hier mal ne deutsche anleitung für Suse 8.2 und Suse 9 zum installieren der wlan_ng-treiber

    is hier zwar speziell für den MA-111 von netgear aber ich denk das der dwl-120 auch geht mein dwl-122 tuts ja auch :)

    http://www.andis-homepage.de/wlan.htm

    ich hoffe sie hilft dir
     
  4. #3 meistert, 13.04.2004
    meistert

    meistert Grünschnabel

    Dabei seit:
    13.04.2004
    Beiträge:
    6
    Zustimmungen:
    0
    Vorerst mal vielen Dank,
    ich werde mich dann jetzt mal belesen!
    Logge mich wieder ins Forum ein um ein oder kein Erfolgssignal von mir zu geben!

    Gruß
    Markus
     
  5. #4 meistert, 13.04.2004
    meistert

    meistert Grünschnabel

    Dabei seit:
    13.04.2004
    Beiträge:
    6
    Zustimmungen:
    0
    Hallo,

    hab mich tapfer durchgekämpft. Allerdings ohne Erfolg!

    Kleiner Auszug:
    - In /etc/wlan die config Dateien anpassen (Abhängig von SSID und WEP)
    dieser Ordner lag unter usr/share habe in dann in o.g. Ordner kopiert!
    denn Rest dieses Hyperlinks konnte ich durchführen.
    Nach weiterem Neustart trotzdem nichts.

    Wenn ich in der Konsole dann iwconfig eingebe, kommt jetzt erstmals eine Meldung. Allerdings verheist die meiner Meinung nach nichts gutes:
    Zu lo und sit0 steht jeweils no wireless extensions.

    Nach einem Blick in die LOG-Datei steht folgender Eintrag:
    wlan0 failed

    Ich weiss mir jetzt keinen weiteren Reim darauf zu machen.
    Kann damit jemand irgendwas anfangen?

    Danke im vorraus
    Markus
     
  6. #5 qmasterrr, 13.04.2004
    qmasterrr

    qmasterrr Foren Gott

    Dabei seit:
    01.01.2004
    Beiträge:
    2.735
    Zustimmungen:
    0
    Ort:
    Germany/NRW/Wesel
    du solltest auf diese scripte und config dateien komplett verzichten und es nur über wlanctl-ng machen
     
  7. #6 meistert, 13.04.2004
    meistert

    meistert Grünschnabel

    Dabei seit:
    13.04.2004
    Beiträge:
    6
    Zustimmungen:
    0
    Könntest Du mir das näher erklären?
    Vielen Dank!
    Gruß
    Markus
     
  8. #7 qmasterrr, 14.04.2004
    qmasterrr

    qmasterrr Foren Gott

    Dabei seit:
    01.01.2004
    Beiträge:
    2.735
    Zustimmungen:
    0
    Ort:
    Germany/NRW/Wesel
    eigentlich hhabe ich das hier schon zu oft gemacht aber ich werde es trotzdem nochmal machen:
    modprobe prism2_usb prism2_doreset=1 #laden des modules
    wlanctl-ng wlan0 lnxreq_ifstate ifstate=enable #scheint alles zu aktivieren
    wlanctl-ng wlan0 lnxreq_autojoin ssid=WLAN authtype=opensystem #legt die ssif und den authtype fest
    ifconfig wlan0 192.168.2.2 # meine wunsch IP
    route add default gw 192.168.2.1 #damit ich ins internet komme muss ich über meinen router

    wlanctl-ng wlan0 dot11req_mibget mibattribute=dot11PrivacyOptionImplemented #nun gehts an die verschlüsselung
    wlanctl-ng wlan0 lnxreq_hostwep decrypt=true encrypt=true #so alles schön einstellen
    wlanctl-ng wlan0 dot11req_mibset mibattribute=dot11WEPDefaultKeyID=0 #auswählen des keys
    wlanctl-ng wlan0 dot11req_mibset mibattribute=dot11ExcludeUnencrypted=true
    wlanctl-ng wlan0 dot11req_mibset mibattribute=dot11PrivacyInvoked=true
    wlanctl-ng wlan0 dot11req_mibset mibattribute=dot11WEPDefaultKey0=AA:AA:AA:AA:AA
    :AA:AA:AA:AA:AA:AA:AA:AA #hier träggste deinen key ein ohne wäre es ja blöde

    so das is eigentlich auch schon alles das musste als root ausführen am besten in ein script packen und das immer beim booten ausführen lassen
     
  9. #8 meistert, 14.04.2004
    meistert

    meistert Grünschnabel

    Dabei seit:
    13.04.2004
    Beiträge:
    6
    Zustimmungen:
    0
    Vielen Dank schonmal,
    habe mein bestes getan, bin allerdings nicht ganz klar gekommen. Bin jetzt hingegangen und habe die PC ohne Router über Adhoc vernetzt.

    Gruß
    Markus
     
  10. #9 SilverHawK, 14.04.2004
    SilverHawK

    SilverHawK UnBanned

    Dabei seit:
    08.03.2004
    Beiträge:
    170
    Zustimmungen:
    0
    Ort:
    Franken - Coburg
    dein router agiert doch auch nur als pc zumindest fürs netzwerk den müsstest eigentlich sehen auch in adhoc modus müsstest du zum router connecten können...

    hasste die jetzt über linux oder windows vernetzt ?
     
  11. #10 meistert, 15.04.2004
    meistert

    meistert Grünschnabel

    Dabei seit:
    13.04.2004
    Beiträge:
    6
    Zustimmungen:
    0
    Habe den "normalen" PC mit suse 9 home am Router über dhpc und LAN connected, den Laptop mit winxp und wlan parallel an den Router gehängt. Kämpfe jetzt mit vnc. Kann laut einer vnc
    Seite mit dem PC connecten. Geht auch, allerdings bekomme ich einen eigenen Bildschirm der nicht dem tatsächlichen Bild entspricht. Mit krfb ginge das allerdings. machte aber eine Fehlermeldung mit ./config. Als Newbie sind das doch noch ziemliche Hürden, aber ich bin ja lernfähig (Hoffe ich).

    Vielen Dank für die Beiträge.
    Habe zumindest dazugelernt!
    Mein Fehler wenn ich die gutgemeinten Ratschläge (noch) nicht umsetzen kann.

    Gruß
    Markus
     
  12. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  13. #11 SilverHawK, 15.04.2004
    SilverHawK

    SilverHawK UnBanned

    Dabei seit:
    08.03.2004
    Beiträge:
    170
    Zustimmungen:
    0
    Ort:
    Franken - Coburg
    ne is schon ok du solltest aber im vornherein dein problem genaustens beschreiben das erleichtert jedem dir zu helfen evtl. auch sogar dir selbst da genauer und konkreter geantwortet werden kann :)
     
  14. #12 redlabour, 17.04.2004
    redlabour

    redlabour -

    Dabei seit:
    23.05.2003
    Beiträge:
    4.353
    Zustimmungen:
    0
    Ort:
    Wuppertal, NRW
    Bitte schau demnächst vor allem genauer wo Dein Problem hingehört - verschoben ! ;)
     
Thema:

wlan usb mit linux suse 9.0 home einrichten

Die Seite wird geladen...

wlan usb mit linux suse 9.0 home einrichten - Ähnliche Themen

  1. Suche WLAN Nano USB Dongle mit 802.11n Standard für Linux

    Suche WLAN Nano USB Dongle mit 802.11n Standard für Linux: Hallo allerseits. Ich bin auf der Suche nach einem Nano USB Dongle welches den 802.11n Standard kann und unter Linux (ab Kernelversion 3.10...
  2. Google bringt WLAN-Router mit Gentoo Linux auf den Markt

    Google bringt WLAN-Router mit Gentoo Linux auf den Markt: Google stellt einen Router vor, der mit Gentoo Linux läuft und dem ac-Standard entspricht. Der »OnHub« genannte Router wurde zusammen mit dem...
  3. Artikel: WLAN unter Linux: Grundlagen

    Artikel: WLAN unter Linux: Grundlagen: Ein WLAN ist unschlagbar, um Rechner mit wenig Aufwand über kurze Strecken zu vernetzen. Dieser Artikel erklärt, wie man drahtlose Netze unter...
  4. Ralink vervollständigt Linux-WLAN-Treiber

    Ralink vervollständigt Linux-WLAN-Treiber: Der taiwanesische Hersteller Ralink hat damit begonnen, Verbesserungen zum Linux-Treiber für seine eigenen WLAN-Chips direkt beizutragen....
  5. Vector-Linux: WLAN funktioniert nicht mit Kanal 13

    Vector-Linux: WLAN funktioniert nicht mit Kanal 13: Hallo, ich habe einen alten Laptop (Maxdata Harvard) mit PII 333 MHz und 64MB RAM. Da das installierte Win2k nicht gerade gut funktioniert,...