wlan rt61 - Keine Verbindung

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von exception, 16.02.2008.

  1. #1 exception, 16.02.2008
    exception

    exception Jungspund

    Dabei seit:
    16.02.2008
    Beiträge:
    24
    Zustimmungen:
    0
    Hallo!

    Zuerst möchte ich sagen das ich absoluter neueinsteiger bei Linux bin. Ich hab mich bisher in der bunten klicki-bunti Windowswelt aufgehalten und möchte jetzt aber gern umsteigen.

    Nun zu meinem Problem. Ich habe meine openSuse 10.2 gestern aufgesetzt in der hoffnung das alles ohne Probleme funktioniert. Leider fehlanzeige. Meine WLAN-Karte wird leider nicht erkannt. Ich habe eine D-Link DWL-G510 Ver C2 (AirPlus G)

    Durch endloses gewühle in X Foren habe ich herausgefunden das auf dieser Karte ein rt61 chipsatz verbaut ist. Anschließend bin ich von dieser Annahme ausgegangen und habe alles probiert was ich dazu gefunden habe. Da ich aber neuling bin hab ich keine Ahnung was ich da eigentlich gemacht habe. Ich glaube ne Firmware runtergeladen und nen Treiber installiert.

    Schließlich bin ich soweit das ich glaube das SUSE die Karte anerkennt. Zumindest kann ich bei im Yast / Netzwerkgeräte -> Netzwerkkarten einen "D-Link Ethernet controller" sehen (Zwischeneinwurf: Ethernet ist merkwürdig oder?). Außerdem wird die MAC-Adresse schon richtig ausgelesen, was mir zumindest Hoffnung macht, das ich nicht alles ganz falsch gemacht habe. (Kann mir das jemand bestätigen)

    Ich vermute das ich jetzt vor dem Problem stehe, wie ich die Verbindung zwischen meiner Karte und dem Router herstelle. Aber an dieser Stelle bin ich irgendwie am Ende meines Latein. Ich weiß nicht mal genau wo das Problem überhaupt liegt.

    iwconfig (Hier stimmt doch meiner vermutung nach was nicht)

    OliverSUSE:/home/oliver # iwconfig
    lo no wireless extensions.

    eth0 no wireless extensions.

    wmaster0 IEEE 802.11g Frequency:2.412 GHz
    RTS thr:off Fragment thr=2346 B

    ra0 IEEE 802.11g ESSID:""
    Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
    RTS thr:off Fragment thr=2346 B
    Encryption key:off

    sit0 no wireless extensions.

    OliverSUSE:/home/oliver #

    Es wäre schön wenn mir jemand helfen könnte
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. Gast1

    Gast1 Guest

    Gib uns die Ausgaben von:

    Code:
    rpm -qa |egrep 'wlan-kmp|rt61|kernel|gcc|make'
    
    find /lib/modules/$(uname -r) -iname "*rt61*"
    
    cat /etc/SuSE-release
    
    find /lib/firmware -iname "rt*"
    
    find /etc/Wireless -iname "rt*"
    Greetz,

    RM
     
  4. #3 exception, 16.02.2008
    exception

    exception Jungspund

    Dabei seit:
    16.02.2008
    Beiträge:
    24
    Zustimmungen:
    0
    OliverSUSE:/home/oliver # rpm -qa |egrep 'wlan-kmp|rt61|kernel|gcc|make'

    libgcc41-4.1.2_20061115-5
    linux-kernel-headers-2.6.18.2-3
    kernel-default-2.6.18.2-34
    make-3.81-23
    gcc41-4.1.2_20061115-5
    gcc41-gij-4.1.2_20061115-7
    kernel-source-2.6.18.2-34
    gcc-4.1.3-29
    wlan-kmp-default-1_2.6.18.2_34-16
    gcc-gij-4.1.3-29

    ----------------------------------------------

    OliverSUSE:/home/oliver # find /lib/modules/$(uname -r) -iname "*rt61*"

    /lib/modules/2.6.18.2-34-default/extra/rt61.ko
    /lib/modules/2.6.18.2-34-default/updates/rt61pci.ko

    ----------------------------------------------

    OliverSUSE:/home/oliver # cat /etc/SuSE-release

    openSUSE 10.2 (i586)
    VERSION = 10.2

    ----------------------------------------------

    find /lib/firmware -iname "rt'*"

    (Keine Ausgabe)

    ----------------------------------------------

    OliverSUSE:/home/oliver # find /etc/Wireless -iname "rt*"

    /etc/Wireless/RT61STA
    /etc/Wireless/RT61STA/rt2561s.bin
    /etc/Wireless/RT61STA/rt2561.bin
    /etc/Wireless/RT61STA/rt61sta.dat
    /etc/Wireless/RT61STA/rt2661.bin

    Ich hoffe das hilft dir weiter :) Ab jetzt gehts auch schneller mit dem antworten
     
  5. #4 Gast1, 16.02.2008
    Zuletzt von einem Moderator bearbeitet: 16.02.2008
    Gast1

    Gast1 Guest

    1. Du hast 2 Treiber für die Karte, wobei der rt61pci (="neuer" Treiber von Serialmonkey) zum Zeitpunkt des Releases der 10.2 noch sehr buggy war. => Das Paket wlan-kmp-default deinstallieren.

    2. Woher hast Du den Quellcode des selbstgebauten Treibers?

    3. Kannst Du per Kabel online gehen? (Würde einiges vereinfachen).

    4. Ich hätte eine mögliche Lösung, die ohne viel Handarbeit auskommt, dazu ist aber auch ein Kernelupdate nötig, was jedoch so oder so Pflicht sein sollte, siehe:

    http://www.unixboard.de/vb3/showthread.php?t=35838&highlight=Exploit

    5. Irgendwelche anderen Treiber von Hand installiert? (ATI/Nvidia, was anderes?)
     
  6. #5 exception, 16.02.2008
    Zuletzt bearbeitet: 16.02.2008
    exception

    exception Jungspund

    Dabei seit:
    16.02.2008
    Beiträge:
    24
    Zustimmungen:
    0
    Paket hab ich deinstalliert. Wenn ich 2 Treiber habe sollte ich einen von beiden sicherlich entfernen, oder?

    Kann ich dir leider nicht mehr sagen. Ich hab in Treiber aus diversen Linux Foren probiert. Deswegen bin ich auch so durcheinander

    Bin ich

    Wie macht man das? Ich hatte nur eine SUSE 10.2 "rumliegen" Kann ich das einfach über diesen Update Service von SUSE machen? edit: Ich les solange mal nach wie man das macht. Du musst dir ja nicht alle Arbeit für mich aufhalsen...

    Nein, ATI (X800XT) wird aber noch nötig werden, genau so wie meine Hauppauge NOVA-S. Aber das sind andere Probleme. Die tun erstmal nix zur Sache denke ich
     
  7. Gast1

    Gast1 Guest

    Den zweiten Treiber bist Du mit der Deinstallation von wlan-kmp-default schon los geworden.

    Das Kernelupdate machst Du am besten über YaST, vorher die entsprechenden Quellen aktivieren.

    http://www.pc-forum24.de/linux-howtos/1132-howtos-paketverwaltung-mit-yast-suse-10-1-10-3-a.html

    NUR die empfohlenen Quellen, das reicht für den Anfang.

    Dann ist auch der selbstgebaute Treiber weg, das ist in dem Fall gut so.

    Es geht im Übrigen darum, ob schon irgendwelche handgebauten Kernelmodule ausser dem rt61.ko installiert sind, denn die müssen nach dem Kernelupdate neu gebaut werden (nur den rt61 _nicht_, da habe ich etwas anderes mit vor).

    Also?

    Greetz,

    RM
     
  8. #7 exception, 16.02.2008
    exception

    exception Jungspund

    Dabei seit:
    16.02.2008
    Beiträge:
    24
    Zustimmungen:
    0
    Die empfohlenen Quellen hab ich aktiviert. Und Prompt werden mir 177 Updates angezeigt dich ich machen kann. (Insgesamt über 4GB download). Soll ich alles installieren oder reicht es wenn ich jetzt nur bestimmte Packages installieren und später dann alles andere? Wenn ja, welche?
     
  9. #8 supersucker, 16.02.2008
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    1.

    Hast du eine Flatrate? Ja? Dann los gehts..

    2.

    Alternativ dürfte der Kernel reichen, wobei da evtl. dann noch Abhängigkeiten mitgezogen werden.

    Das Kernel-Paket findest du über die Beschreibung die Yast mitanzeigt, vermutlich "linux-image-xxxxx" oder so ähnlich.

    Findest du schon.....:devil:
     
  10. Gast1

    Gast1 Guest

    Also Pflicht ist alles, was mit Kernel zu tun hat.

    Am einfachsten machen wir das über die Kommandozeile.

    Code:
    su
    
    Passwort
    
    zypper in kernel-default kernel-source kernel-syms
    sollte genügen.

    Danach Neustart, der neue Kernel ist dann:

    Code:
    uname -r 
    
    2.6.18.8-0.9-default
    Nun sich folgende Pakete holen und installieren.

    rt61-cvs-kmp-default-2008020205_2.6.18.8_0.9-4.1.i586.rpm

    (Treiber)

    rt2x00-firmware-1.1-1.noarch.rpm

    (Naja, ist klar oder?)

    Danach

    Code:
    su
    
    Passwort
    
    modprobe -r rt61
    
    modprobe rt61
    
    iwconfig
    
    iwlist scan
    Und es sollte sich etwas getan haben.

    Soll die Karte mit WPA betrieben werden?

    Greetz,

    RM
     
  11. #10 exception, 16.02.2008
    Zuletzt bearbeitet: 16.02.2008
    exception

    exception Jungspund

    Dabei seit:
    16.02.2008
    Beiträge:
    24
    Zustimmungen:
    0
    Du bist Klasse! So verständlich hat noch keiner geholfen :)

    Also: kernelupdate ist durch, die Packages sind auch installiert. Alles Wunderbar:

    iwlist scan

    edit: WPA wäre das Sahnehäubchen auf dem ganzen :) Ich habe 0/100 Quality :( Liegt es daran dass das Netzwerk WPA-verschlüsselt ist?
     
  12. Gast1

    Gast1 Guest

    WPA(2) und rt61-Karten mit dem sog. "legacy"-Teiber ist so eine Sache, nicht unmöglich sondern eher das Gegenteil, denn es gibt mehrere Möglichkeiten das Ganze hin zu bekommen.

    Versuche zuerst, ob eine unverschlüsselte Verbindung möglich ist, sprich der an sich Treiber für die Karte so funktioniert, dann kann man weiter sehen.

    Beachte dabei unbedingt, daß eine Einrichtung nur über die traditionelle Methode mit ifup möglich sein wird, die Verwendung des NetworkManagers wird _nicht_ funktionieren.

    Lies Dir das hier durch:

    http://www.pc-forum24.de/linux-howt...-dem-nativen-treiber-fwlanusb-einrichten.html

    Du musst natürlich als Modulname rt61 angeben, der Rest ist analog.

    WPA mit dem wpa_supplicant ist so nicht möglich, dazu braucht es ein paar Anpassungen, aber das ist zunächst Zukunftsmusik, falls überhaupt wpa_supplicant zum Einsatz kommen soll.

    Ist das ein Laptop oder ein Desktoprechner?

    Greetz,

    RM
     
  13. #12 exception, 16.02.2008
    Zuletzt bearbeitet: 16.02.2008
    exception

    exception Jungspund

    Dabei seit:
    16.02.2008
    Beiträge:
    24
    Zustimmungen:
    0
    Es ist ein Desktoprechner.

    Ich war zwischendurch unterwegs und hab den Rechner natürlich runtergefahren. Nach dem Neustart war meine ra0 wieder weg. Ich hab dann einfach modprobe -r rt61 und modprobe rt61 gemacht. Dann ging es wieder. Muss ich das jetzt immer machen?

    (Das connecten zu einem unverschlusselten Netzwerk hab ich probiert. Leider ohne erfolg. Was mich jetzt doch wieder etwas stutzig macht...)
    Edit: Ich mach es jetzt nochmal nach deiner Anleitung. Das war eher so ein Probieren mit dem YAST. Ich beeile mich...

    Noch etwas: Beim Update hat es mir wieder dieses wlan-kmp-default reingeladen. Das muss ich sicherlich wieder rausnehmen oder?

    edit2: Punkt eins kann ich sicherlich im howto überspringen, hab ja kein fritz usb, sondern eine feste Karte
     
  14. #13 Gast1, 16.02.2008
    Zuletzt von einem Moderator bearbeitet: 16.02.2008
    Gast1

    Gast1 Guest

    1. "Leider ohne Erfolg" ist keine Fehlerbeschreibung mit der man etwas anfangen kann.

    Einer der beliebtesten Fehler ist es vorher die LAN-Schnittstelle nicht zu deaktivieren.

    Code:
    su
    
    Passwort
    
    ifdown <LAN-Schnittstelle>
    
    ifup <WLAN-Schnittstelle>
    2. Das Paket wlan-kmp-default kann auch drauf bleiben, wenn man den anderen Treiber "blacklistet".

    Code:
    su 
    
    Passwort
    
    modprobe rt61pci -r
    
    modprobe rt61
    
    cd /etc/modprobe.d/
    
    cp backlist backup.blacklist
    
    echo "blacklist rt61pci" >> blacklist
    Danach sollte das hier angezeigt werden (letzte Zeile).

    Code:
    tail -n5 blacklist
    
    # Therefore we disable automatic loading of 82875p_edac. (Bug 213840)
    blacklist i82875p_edac
    #blacklist broken module r8187
    [B]backlist rt61pci[/B]
    3. Nein, das kann man alles automatisieren, aber zuerst sollte es von Hand funktionieren.

    Über YaST => System => /etc/sysconfig-Editor => nach MODULES_LOADED_ON_BOOT suchen und rt61 eintragen.

    Wenn YaST nicht will, dann von Hand Verbindung aufbauen.

    Code:
    su
    
    Passwort
    
    rcnetwork stop #schaltet alle automatischen Einrichtungen aus.
    
    iwconfig <WLAN-Schnittstelle> essid "DEINE_NETZWERK_ESSID"
    
    iwconfig <WLAN-Schnittstelle>
    sollte Dir dann anzeigen, daß die Karte assoziiert ist. (Schnittstelle ist z.B. ra0, das musst Du schon selbst wissen, iwconfig ohne Parameter sagt Dir das aber auch).

    So in etwa:
    Code:
     iwconfig
    eth1      IEEE 802.11g  ESSID:"MEINE_ESSID"
              Mode:Managed  Frequency:2.462 GHz  
              Bit Rate:18 Mb/s   Tx-Power=20 dBm   Sensitivity=8/0
              Retry limit:7   RTS thr:off   Fragment thr:off
              Encryption key:XXXXXXXXXXXXXXXXXXX   Security mode:open
              Power Management:off
              Link Quality=56/100  Signal level=-67 dBm  Noise level=-90 dBm
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:8
    (Mein WLAN-Interface heisst eth1, das tut hier aber nichts zur Sache, Deine Karte wird raX heissen).

    Danach in der selben Konsole (immer noch als root)

    Code:
    dhclient
    Alle Eingaben/Ausgaben _unbedingt_ Posten.

    //Auch Edit:

    Ja, die Treiberinstallation brauchst Du nicht, das hast Du mit den anderen Paketen vorhin schon erledigt, Punkt 3 ist für Dich besonders interessant.

    Greetz,

    RM
     
  15. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  16. #14 exception, 16.02.2008
    exception

    exception Jungspund

    Dabei seit:
    16.02.2008
    Beiträge:
    24
    Zustimmungen:
    0
    So how-to geschafft. Und auch gleich eine positve Verbesserung. Die Signal Quality. Leider bekomm ich trotzdem keine Verbindung ins Internet... Oder muss ich mich noch irgendwie speziell connecten?

     
  17. Gast1

    Gast1 Guest

    Würdest Du vor dem Posten vielleicht mal LESEN, was man Dir geschrieben hat?
     
Thema:

wlan rt61 - Keine Verbindung

Die Seite wird geladen...

wlan rt61 - Keine Verbindung - Ähnliche Themen

  1. RT61 Wlan Ubuntu Problem

    RT61 Wlan Ubuntu Problem: hi Leute ich habe hier eine W-Lan Karte von Edimax mit einem RT61 Chipsatz. Allerdings habe ich ein Problem mit der Insatllation der Treiber. Ich...
  2. WLAN rt61 kernel-sources/-headers

    WLAN rt61 kernel-sources/-headers: Hallo Benutze seit ca 1/2 Jahr SuSE 10.2, richte momentan aber wegen akuter Wegknackgefahr bei YaST und Systemstart jetzt Debian 4.0 von...
  3. Problem mit Wlan RT61 Chipsatz

    Problem mit Wlan RT61 Chipsatz: Hallo, versuche schon seit längerem die Wlankarte zum laufen zu kriegen bekomme es aber nicht hin. Die Karte wir mir in Yast nicht angezeigt,...
  4. RealTek WLAN RT61 Suse 10.2

    RealTek WLAN RT61 Suse 10.2: Hi folks... ich habe meine WLAN-Karte soweit eingerichtet und kann sie manuell mit ifconfig ra3 up aktivieren und die Parameter anschließend...
  5. wlan rt61 chipsatz unter linux 10.0

    wlan rt61 chipsatz unter linux 10.0: hallo Leute, ich hab ein Prob. mit der Anbindung meiner Conceptronic PCMCIA-Karte....an linux 10.0 die karte hat einen rt 61 chipsatz.......