WLAN Realtek 8180 SuSE 10.0 Neukonfiguration bei Neustart notwendig

Dieses Thema im Forum "SuSE / OpenSuSE" wurde erstellt von anita82, 29.09.2006.

  1. #1 anita82, 29.09.2006
    anita82

    anita82 Grünschnabel

    Dabei seit:
    29.09.2006
    Beiträge:
    2
    Zustimmungen:
    0
    Erstmal hallo an alle!

    Bin totaler WLAN-Anfänger. :D Bis jetzt war ich immer über Kabel verbunden. Ich hoffe, ich bekomme hier ein wenig Unterstützung von Euch.

    Ich nutze SuSE 10.0 mit der WLan-Karte RTL8180. Und irgendwie klappts noch nicht so richtig. Bekanntes Problem, ich weiß...

    Aber mein Problem ist neu, naja zumindest hab ich nichts darüber gefunden.

    Also, YAST hat die Karte richtig erkannt und ich habe sie als WLAN-Karte eingerichtet. Die Karte lief auch und ließ sich starten, aber die Einwahl ins WLAN funktionierte nicht. Nach vielen Stunden Arbeit und wundgetippten Fingern hab ich sie dann mit folgender Konfiguration zum laufen bekommen:

    /etc/sysconfig/network/ifcfg-eth-id-MACADRESSE

    Code:
    BOOTPROTO='static'
    BROADCAST=''
    IPADDR='192.168.1.13'
    MTU=''
    NAME='Realtek RTL8180L 802.11b MAC'
    NETMASK='255.255.255.0'
    NETWORK=''
    REMOTE_IPADDR=''
    STARTMODE='auto'
    UNIQUE='y9sn.moeRe+D9b3F'
    USERCONTROL='no'
    _nm_name='bus-pci-0000:00:0a.0'
    
    Die WLAN-Einstellungen nimmt er (vermutlich) aus:
    /etc/sysconfig/network/wireless (ohne Kommentarzeilen)
    Code:
    WIRELESS=""
    WIRELESS_MODE=""
    WIRELESS_ESSID="wlanname"
    WIRELESS_NICK=""
    WIRELESS_NWID=""
    WIRELESS_FREQ="2.422G"
    WIRELESS_CHANNEL="3"
    WIRELESS_SENS=""
    WIRELESS_RATE=""
    WIRELESS_KEY="strenggeheim"
    WIRELESS_RTS=""
    WIRELESS_FRAG=""
    WIRELESS_IWCONFIG_OPTIONS=""
    WIRELESS_IWSPY_OPTIONS=""
    WIRELESS_IWPRIV_OPTIONS=""
    
    # iwconfig
    Code:
    lo        no wireless extensions.
    
    sit0      no wireless extensions.
    
    eth0      no wireless extensions.
    
    wlan0     IEEE 802.11b  ESSID:"wlanname"  Nickname:"hostname"
              Mode:Managed  Frequency:2.422 GHz  Access Point: 00:09:5B:A8:3E:A0
              Bit Rate=11 Mb/s   Tx-Power:20 dBm   Sensitivity=0/3
              RTS thr=2432 B   Fragment thr=2432 B
              Encryption key:streng-geheim   Security mode:open
              Power Management:off
              Link Quality:100/100  Signal level:-55 dBm  Noise level:-256 dBm
              Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
              Tx excessive retries:0  Invalid misc:0   Missed beacon:0
    
    Ich habe auch mit ndiswrapper rumgespielt. Ich weiß jetzt auch nicht genau, welchen Treiber er nimmt. Den Linux- oder den WinXP-Treiber. Ich habe beide irgendwann mal eingespielt / installiert

    Die Karte läuft stabil und schnell.... bis zum nächsten Neustart. Danach kann sich die Karte nicht mehr ins WLAN einwählen. Der Access-Point ist 00:00:00:00:00:00. Die Frequenz stimmt nicht auch nicht mehr.

    Ich habe die o.g. Files schon angeschaut, sie sind genauso wie vorher. Abhilfe schafft nur
    YAST - Netzwerkarte Konfiguartion löschen - Speichern
    YAST - Netzwerkkarte als Ethernet mit Angabe IP, Gateway und DNS neu konfigurieren. - Speichern

    Dann geht es wieder.

    Hat jemand eine Ahnung, an was das liegen könnte? Was lädt YAST anders, wenn es die Netzwerkkarte neu speichert, als der Neustart des Systems es tut?

    Vielleicht hat einer eine Idee? :hilfe2: Ich würde mich freuen.
    Braucht ihr weitere Dateien? Einfach melden.

    Vielen Dank im Voraus

    Gruß Anita
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Deaktiviere mal SuSEConfig mit 'yast sysconfig', denn das scheint dir hier dazwischenzufunken. Zumindest sieht es ganz danach aus, denn durch aehnliche Probleme mit dem Zuruecksetzen von Einstellungen ist SuSEConfig mal negativerweise bekannt geworden.
     
  4. #3 anita82, 30.09.2006
    anita82

    anita82 Grünschnabel

    Dabei seit:
    29.09.2006
    Beiträge:
    2
    Zustimmungen:
    0
    Hallo!

    Danke, habs versucht, hat leider nicht geklappt. Ich hoffe wir meinen beide den gleichen Eintrag: ENABLE_SUSECONFIG : No ???

    Was noch aufgefallen ist:

    ifup wlan0 (direkt nach Neustart des Systems)
    Code:
    wlan0     device: Realtek Semiconductor Co., Ltd. RTL8180L 802.11b MAC (rev
    20)
        wlan0     configuration: eth-id-MACADRESSE
    ifup-wireless: command 'iwconfig wlan0 nick hostname' returned
    ifup-wireless:  Error for wireless request "Set Nickname" (8B1C) :
    ifup-wireless:     SET failed on device wlan0 ; Operation not permitted.
    ifup-wireless: command 'iwconfig wlan0 freq 2.422G' returned
    ifup-wireless:  Error for wireless request "Set Frequency" (8B04) :
    ifup-wireless:     SET failed on device wlan0 ; Operation not permitted.
    ifup-wireless: command 'iwconfig wlan0 channel 3' returned
    ifup-wireless:  Error for wireless request "Set Frequency" (8B04) :
    ifup-wireless:     SET failed on device wlan0 ; Operation not permitted.
    SuSEfirewall2: Warning: ip6tables does not support state matching. Extended IPv6                                                                            support disabled.
    SuSEfirewall2: Setting up rules from /etc/sysconfig/SuSEfirewall2 ...
    SuSEfirewall2: batch committing...
    SuSEfirewall2: Firewall rules successfully set
    
    ifup wlan0 (direkt nach Neukonfiguration der Karte über YAST)
    Code:
     wlan0     device: Realtek Semiconductor Co., Ltd. RTL8180L 802.11b MAC (rev                                                                            20)
        wlan0     configuration: eth-id-MACADRESSE
    SuSEfirewall2: Warning: ip6tables does not support state matching. Extended IPv6                                                                            support disabled.
    SuSEfirewall2: Setting up rules from /etc/sysconfig/SuSEfirewall2 ...
    SuSEfirewall2: batch committing...
    SuSEfirewall2: Firewall rules successfully set
    
    Fällt noch jemandem was ein?

    Gruß Anita
     
Thema:

WLAN Realtek 8180 SuSE 10.0 Neukonfiguration bei Neustart notwendig

Die Seite wird geladen...

WLAN Realtek 8180 SuSE 10.0 Neukonfiguration bei Neustart notwendig - Ähnliche Themen

  1. RealTek WLAN RT61 Suse 10.2

    RealTek WLAN RT61 Suse 10.2: Hi folks... ich habe meine WLAN-Karte soweit eingerichtet und kann sie manuell mit ifconfig ra3 up aktivieren und die Parameter anschließend...
  2. WLAN auf Ubuntu 6.10 mit Realtek 8187 USB Stick und WPA

    WLAN auf Ubuntu 6.10 mit Realtek 8187 USB Stick und WPA: Moin alle miteinander, nach mehreren Versuchen mein WLAN eingerichtet zu bekommen, wende ich mich nun an Euch. Was ich bisher gemacht habe....
  3. Wlan Realtek 8180 openSUSE 10.1

    Wlan Realtek 8180 openSUSE 10.1: !!!!Hat sich erledigt mit ndiswrapper funktioniert es!!!!!!!!!!!!!1 Hallo, ich habe folgendes Problem und hofffe das mir jemand weiterhelfen...
  4. Probleme beim Laden des neuen WLAN-Treibers von Packman für Realtek rt2500

    Probleme beim Laden des neuen WLAN-Treibers von Packman für Realtek rt2500: Hallo, hat jemand schon Erfahrungen mit dem neuen WLAN-Treiber von Packman für Realtek rt2500 (diesen hier:...
  5. Routing 2 Subnetze (WLAN und ETH)

    Routing 2 Subnetze (WLAN und ETH): Hallo, hoffe ich bin hier richtig. Ich habe ein Raspberry Pi welcher als WLAN-Accesspoint dient. Dabei sehen die Interfaces wie folgt aus: wlan1...