WLan funktionierte mit WEP -You Update und nix geht mehr

Dieses Thema im Forum "Internet, lokale Netzwerke und Wireless Lan" wurde erstellt von DerFreak, 16.07.2004.

  1. #1 DerFreak, 16.07.2004
    DerFreak

    DerFreak Grünschnabel

    Dabei seit:
    11.07.2004
    Beiträge:
    3
    Zustimmungen:
    0
    Hallo @ll,

    ich hoffe mir kann hier jmd. helfen. Ich habe mich mittlerweile an den Support von Suse gewendet, mir wurde aber höflich mitgeteilt, das das nicht unter deren kostenlosen Support möglich ist. Der Support ist mal voll fürn ..... wie ich die suse cds bei der Installation einlege, weiss ich selber. Das war auf jedenfall das letzte mal, das ich mir das Suse Paket gekauft habe. Egal, mal zu meinem Problem:
    (ich denke mal, das ist schon ein gutes HOWTO für jeden Anfänger, der auf das You Update verzichtet)

    Folgendes:
    Ich besitze ein D-Link Router DI-624+
    und den dazugehörigen USB-Stick DWL-122
    Sowie Suse Linux 9.1 Pro

    für die WLan Geräte habe ich mir den Treiber von http://www.linux-wlan.org/
    geladen, da D-Link keinen eigenen anbietet. (linux-wlan-ng-0.2.1pre21.tar.gz)

    folgendes Vorgehen:
    cd /usr/src/linux
    rm .config
    make cloneconfig
    make prepare-all

    danach in das Verzeichnis linux-wlan-ng-0.2.1pre21
    ./Configure

    -------------- Linux WLAN Configuration Script -------------
    The default responses are correct for most users.
    Build Prism2.x PCMCIA Card Services (_cs) driver? (y/n) [y]: n
    Build Prism2 PLX9052 based PCI (_plx) adapter driver? (y/n) [n]: n
    Build Prism2.5 native PCI (_pci) driver? (y/n) [n]: n
    Build Prism2.5 USB (_usb) driver? (y/n) [n]: y
    Linux source directory [/usr/src/linux]:
    The kernel source tree is version 2.6.4.52-smp
    Alternate target install root directory on host []:
    Module install directory [/lib/modules/2.6.4.52-smp]:
    It looks like you have a System V init file setup.
    Prefix for build host compiler? (rarely needed) []:
    Build for debugging (see doc/config.debug) (y/n) [n]:
    Configuration successful.

    make all
    make install

    dann habe ich die
    etc/wlan/wlan.conf editiert:
    SSID_wlan0="default"
    ENABLE_wlan0=y

    cp /etc/wlan/wlancfg-DEFAULT /etc/wlan/wlancfg-default

    und folgende Einstellungen in Yast gemacht:

    Netzwerkgeräte/Netzwerkkarte:

    bei "bereits Kofigurierte Geräte" auf "Ändern"
    dann "Hinzufügen"

    Gerätetyp: Drahtlos
    dann auf "Auswahl aus Liste"
    den prism_usb treiber gewählt

    auf "Einstellung für Funkverbindung" gegangen
    und die Eingaben gemacht:
    ESSID: default
    NWID: 6
    Verschlüsselungskey: Den KEY (zb. 1937367382938473)

    bei wählen Sie die Methode der Netwerkkonfiguration:
    Konfigurieren der statischen Adresse
    IP-Adresse: 192.168.0.2
    Subnetmaske: 255.255.255.0

    Rechnername und Nameserver habe ich folgendes Eingegeben:
    Nameserver: 192.168.0.1 Domainsuche:site

    bei Routing habe ich dann noch des Gateway eingegeben: 192.168.0.1

    So ich glaube das dürfte alles gewesen sein, was ich getan habe..
    Die Inet Verbindung lief astrein. Keine Probleme! Direkt nach dem Booten war es möglich über den Webbrowser auf den Router zuzugreifen und das mit WEP, dafür habe ich fast eine Woche probiert und getan, da ich Linux Newbe bin.

    Dann habe ich YOU ausgeführt! Internet sowie der Zugriff auf den Router waren dann nicht mehr möglich!

    Den Zugriff aufs Netz bekomme ich dann nur hin, wenn ich die "Drahtlose Verbindung" wieder aus der Einstellung von Yast rausschmeisse und folgendes ins Terminal schreibe:

    ifconfig wlan0 192.168.0.2 netmask 255.255.255.0
    route add -net default gw 192.168.0.1

    dann habe ich wieder Zugriff auf den Router sowie aufs Internet.
    allerdings habe ich keine Lust diesen kleinen Roman jedesmal zu schreiben.. und WeP habe ich dann auch nicht..

    Was mir aufgefallen ist, das über Yast IEEE 902.11-DS verwendet wird, und wenn ich die Verbindung manuell herstelle über o.g zwei Befehle wird; IEEE 802.11-b benutzt.

    Hier noch mal die Rückmeldungen bei den verschiedenen Konfigurationen:
    -----------------------------------------------------------------------------
    Die NICHT funktionierende über Yast gibt folgendes zurück:

    route
    ------
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    168.192.0.0 * 255.255.255.0 U 0 0 0 wlan0
    link-local * 255.255.0.0 U 0 0 0 wlan0
    loopback * 255.0.0.0 U 0 0 0 lo

    ifconfig
    ----------
    eth0 Link encap:Ethernet HWaddr 00:0C:6E:4A:69:BF
    inet6 addr: fe80::20c:6eff:fe4a:69bf/64 Scope:Link
    UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
    Interrupt:22 Memory:feafc000-0

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:42 errors:0 dropped:0 overruns:0 frame:0
    TX packets:42 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:2708 (2.6 Kb) TX bytes:2708 (2.6 Kb)

    wlan0 Link encap:Ethernet HWaddr 00:0F:3D:CD:29:53
    inet addr:168.192.0.2 Bcast:168.192.0.255 Mask:255.255.255.0
    inet6 addr: fe80::20f:3dff:fecd:2953/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:13 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

    iwconfig
    ------------
    wlan0 IEEE 802.11-DS ESSID:"default" Nickname:"default"
    Mode:Auto Frequency:2.437GHz Access Point: 00:00:00:00:00:00
    Bit Rate:2Mb/s Tx-Power:-147488768 dBm
    Retry min limit:8 RTS thrff Fragment thrff
    Encryption keyff
    Link Quality:0/92 Signal level:-69 dBm Noise level:-90 dBm
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0
    --------------------------------------------------------------------------------
    Die funktionierende Verbindung mit Eingabe von:

    ifconfig wlan0 192.168.0.2 netmask 255.255.255.0
    route add -net default gw 192.168.0.1

    gibt folgende Rückmeldung:

    route
    -------
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    192.168.0.0 * 255.255.255.0 U 0 0 0 wlan0
    loopback * 255.0.0.0 U 0 0 0 lo
    default 192.168.0.1 0.0.0.0 UG 0 0 0 wlan0

    ifconfig
    ----------
    eth0 Link encap:Ethernet HWaddr 00:0C:6E:4A:69:BF
    inet6 addr: fe80::20c:6eff:fe4a:69bf/64 Scope:Link
    UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:0 errors:0 dropped:0 overruns:0 frame:0
    TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
    Interrupt:22 Memory:feafc000-0

    lo Link encap:Local Loopback
    inet addr:127.0.0.1 Mask:255.0.0.0
    inet6 addr: ::1/128 Scope:Host
    UP LOOPBACK RUNNING MTU:16436 Metric:1
    RX packets:156 errors:0 dropped:0 overruns:0 frame:0
    TX packets:156 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:0
    RX bytes:12148 (11.8 Kb) TX bytes:12148 (11.8 Kb)

    wlan0 Link encap:Ethernet HWaddr 00:0F:3D:CD:29:53
    inet addr:192.168.0.2 Bcast:192.168.0.255 Mask:255.255.255.0
    inet6 addr: fe80::20f:3dff:fecd:2953/64 Scope:Link
    UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
    RX packets:876 errors:0 dropped:0 overruns:0 frame:0
    TX packets:632 errors:0 dropped:4 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:189026 (184.5 Kb) TX bytes:91470 (89.3 Kb)

    iwconfig
    -------------
    wlan0 IEEE 802.11-b ESSID:"default" Nickname:"default"
    Mode:Managed Frequency:2.437GHz Access Point: 00:0F:3D:4C:B8:96
    Bit Rate:11Mb/s Tx-Power:-190418944 dBm
    Retry min limit:8 RTS thrff Fragment thrff
    Encryption keyff
    Link Quality:74/92 Signal level:-48 dBm Noise level:-98 dBm
    Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
    Tx excessive retries:0 Invalid misc:0 Missed beacon:0

    Es wäre echt super, wenn mir hier jmd. helfen kann...

    Gruss

    DF
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 qmasterrr, 16.07.2004
    qmasterrr

    qmasterrr Foren Gott

    Dabei seit:
    01.01.2004
    Beiträge:
    2.735
    Zustimmungen:
    0
    Ort:
    Germany/NRW/Wesel
    sry das ich das sagen muss aber in meinen augen taugen diese konfigurations tools von suse 0.
    daher würde ich einfach die ensprechenden Zeilen in dein SystemVinit einbringen.
    Die entsprechenden zeilen findest du hier in etlichen threads bin nun aber zufaul zum suchen
    gl
    hoffe das hilft
     
  4. #3 DerFreak, 16.07.2004
    DerFreak

    DerFreak Grünschnabel

    Dabei seit:
    11.07.2004
    Beiträge:
    3
    Zustimmungen:
    0
    @qmasterrr

    vielen Dank! dein Posting hat mir sehr geholfen! Mein WLan läuft jetzt mit WEP und das schon direkt nach dem booten..

    endlich mal ein Forum mit qualifizierten antworten..
    danke dir

    Gruss
    DF

    PS: hat jmd. Interesse an einem HOWTO? dann werde ich mir mal die Mühe machen eins zu verfassen...
     
  5. gnadli

    gnadli Grünschnabel

    Dabei seit:
    30.07.2004
    Beiträge:
    1
    Zustimmungen:
    0
    Ich habe momentan aehnliche Probleme wie du.

    mein system

    SuSE 9.1 Pro
    D-Link 664 router mit AP
    dwl-122 stick

    wenn ich nun den stick einstecke laed SuSE das wlan modul prism2_usb automatisch (hotplug).
    durch die hinlaenglich beschriebenen befehle

    wlanctl-ng wlan0 lnxreq_ifstate ifstate=enable
    wlanctl-ng wlan0 lnxreq_autojoin ssid=<meine ssid> authtype=opensystem

    kann ich den stick aktivieren und mit

    ifconfig wlan0 <meine IP adresse>
    route add default gw <gw IP> wlan0

    das netzerk einrichten (in YAST habe wlan nicht
    eingerichtet).

    manchmal habe ich dann
    verbindung zum router und iwconfig zeigt mir
    IEEE 802.11-b mit 11Mbit, der AP-MAC, einer LinkQuality >0 usw. genauso wie du es fuer den funktionierenden fall beschrieben hast.

    haeufiger allerdings habe ich keine verbindung
    und iwconfig zeigt mir
    IEEE 802.11-DS mit 2Mbit, AP-MAC 00:00:..., LinkQuality 0/92 usw
    genauso wie du es fuer den nicht funktionierenden fall beschrieben hast.

    Ich habe schon alles moeglich probiert und habe keinen hinweis, woran es liegen koennte.
    es sieht so aus als ob die verbindung eher zufaellig mal zustande kommt.

    Vielleicht hast du in der Zwischenzeit mehr Erfahrung und kannst mir sagen wo ich drehen koennte (z.B. am usb-hotplug).

    Im voraus vielen Dank.

    Gruss,
    G
     
  6. hex

    hex Lebende Foren Legende
    Moderator

    Dabei seit:
    10.12.2003
    Beiträge:
    1.775
    Zustimmungen:
    0
    Ort:
    Stuttgart
    Ich denke HOWTO's sind immer erwünscht :)

    regards hex
     
  7. devilz

    devilz Pro*phet
    Administrator

    Dabei seit:
    01.05.2002
    Beiträge:
    12.244
    Zustimmungen:
    0
    Ort:
    Hessen

    Klar - immer ins Wiki damit -> http://wiki.unixboard.de/
     
  8. Anzeige

    Vielleicht findest du HIER Antworten.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

WLan funktionierte mit WEP -You Update und nix geht mehr

Die Seite wird geladen...

WLan funktionierte mit WEP -You Update und nix geht mehr - Ähnliche Themen

  1. Routing 2 Subnetze (WLAN und ETH)

    Routing 2 Subnetze (WLAN und ETH): Hallo, hoffe ich bin hier richtig. Ich habe ein Raspberry Pi welcher als WLAN-Accesspoint dient. Dabei sehen die Interfaces wie folgt aus: wlan1...
  2. Installation, aber wo hin mit dem WLAN Passwort?

    Installation, aber wo hin mit dem WLAN Passwort?: Hallo, ich hab nicht gewußt wohin mit dem Wlan-Passwort (WPA2). Dadurch habe ich MidnightBSD gefunden und da installier ich was, aber es ist...
  3. Raspberry Pi 3 mit WLAN und Bluetooth

    Raspberry Pi 3 mit WLAN und Bluetooth: Die Gerüchteküche um einen neuen Raspberry Pi köchelt schon seit einigen Monaten. Jetzt gibt es erste konkrete Hinweise, was Nutzer von dem neuen...
  4. Suche WLAN Nano USB Dongle mit 802.11n Standard für Linux

    Suche WLAN Nano USB Dongle mit 802.11n Standard für Linux: Hallo allerseits. Ich bin auf der Suche nach einem Nano USB Dongle welches den 802.11n Standard kann und unter Linux (ab Kernelversion 3.10...
  5. Google bringt WLAN-Router mit Gentoo Linux auf den Markt

    Google bringt WLAN-Router mit Gentoo Linux auf den Markt: Google stellt einen Router vor, der mit Gentoo Linux läuft und dem ac-Standard entspricht. Der »OnHub« genannte Router wurde zusammen mit dem...